Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-09-2014, 05:52 PM   #16
Pentaxian
Caver's Avatar

Join Date: Jun 2009
Location: Hungary (ex-pat from Transylvania, Romania)
Photos: Gallery
Posts: 429
Original Poster
QuoteOriginally posted by Caver Quote
I updated just now and I don't see any difference in AF performance or anything else.
I've tested (no scientific test, just some ordinary everyday usage) with my limiteds (21, 35, 40)
NOTE: I don't know if it's the firmware or the fact that I've formatted my Samsung memory card on my pc (in a card reader) - but since the new firmware I can use it!
Before V1.05 all I got from this card when inserted in my K-01 was "Memory card error"

03-15-2014, 06:50 PM   #17
cmv
Senior Member




Join Date: Sep 2006
Location: Chicago, IL, USA
Posts: 147
QuoteOriginally posted by Caver Quote
NOTE: I don't know if it's the firmware or the fact that I've formatted my Samsung memory card on my pc (in a card reader) - but since the new firmware I can use it!
Before V1.05 all I got from this card when inserted in my K-01 was "Memory card error"
That is excellent news -- half my SHDC cards work in my K20D but not my K-01. I am away from home but looking forward to trying them next month in the hope they all work.
04-16-2014, 04:13 PM   #18
Senior Member




Join Date: Jan 2013
Posts: 240
Have done nothing but struggle with my K-01. Caveat is that I'm 69 years old and still used to a Brownie. I've had my K-o1 for a year and put it aside for my Sony R100X (I think that's what its called.) It is easier for me to use. But I love the feel of the Pentax. I've done something to it so that the LCD screen flickers bright red. It is annoying. What have I done? Is there a way to reset the default settings so that I can start over making the same mistakes?

Secondly, what is the best Macro lense for me to use with this funny looking camera that won't break my already leaking bank account?

I've always loved Pentax picture making machines and so want to elope with this K-01. The trouble is when I pucker up, it turns its head. What is the easy way to use this bricky beast?

Oh, I have never updated firmware in my life. Does it really do any good? I guess "it depends". huh
04-16-2014, 05:49 PM   #19
Senior Member




Join Date: Jul 2012
Posts: 152
stepmac, see pages 196 and 197 of the operators manual about resetting the camera to the default settings. If you don't have a manual, you can get a PDF version here -- Downloads & Literature - RICOH Imaging

This should also stop the flashing red areas on your LCD. The flashing red areas indicate overexposed/blown highlights. Flashing yellow is for underexposed areas. The manual covers these as Bright/Dark Area Warnings on pages 156,190 and 191.

04-16-2014, 08:37 PM   #20
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,486
QuoteOriginally posted by stepmac Quote
've done something to it so that the LCD screen flickers bright red. It is annoying. What have I done? I
As Evergreen said, I think you've turned on "Bright/Dark Area". It's under Menu, tab with a camera icon and number 3, under "Live View" settings (you'll have to navigate down to LiveView, then go right to see the LV settings).

So far as firmware goes, the original firmware was one of the K-01's biggest flaws. FW 1.01 made a huge difference in focus speed and accuracy. The later versions just added support for new lenses and fixed minor things, but any of them is an improvement over FW 1.00.
04-17-2014, 12:57 AM   #21
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,126
Version 1.04 fixed the Auto ISO ramping in Video 'M' exposure setting with manual lenses or A lenses when the Iris was set on the lens instead of the camera - that was the most important fix needed first for video, and was a great improvement once done.
There was also some changes in the dithering and 'grain' type noise in the video - and fixed any macro-blocking when the data rate was causing errors during moments of high detail in movement.

+1 on the red flashes being the Bright/Dark area display.

Firmware update is super easy on the Pentax cameras - they've built in safe checks to make sure the battery is fully charged and the instructions are very clear - it takes about 30 seconds from start up to the update being done and you being ready to shoot new images.
04-17-2014, 09:05 AM - 1 Like   #22
Senior Member




Join Date: Jan 2013
Posts: 240
Thank you all for your prompt replies to my requests. As soon as I eat breakfast, take a shower and drink my morning coffee I'm going to try them. I'll do the firmware last. I am still hesitant to try. I find that futzing with computers sucks time like mad...I can spend most of a day sitting here trying to do one simple thing. I don't think "computer" well at all. When one has spent most of one's life using as slide rule and a manual typewriter these computers seem strange, as do filmless cameras.

Thanks again.

Stepmac
04-17-2014, 02:29 PM   #23
Senior Member




Join Date: Jan 2013
Posts: 240
Four hours later and a pounding headache and garnering my wife's (much smarter than I) assistance, we FINALLY got the 1.05 firmware update on my K-01 and it seems to work a little better.

I can see how doing it a few times can make it much easier. For one thing, one must follow the instructions to the T. I must have been rushing a bit. My wife, once again, turned me on to the right direction.

I've been playing with my four or Pentax lenses, that I bought years ago for my first Pentax DSLR camera. I've got another half dozen primes that I hung on my Spotmatic and K1000, and ME Super, cameras I left kicking and screaming.

---------- Post added 04-17-14 at 02:33 PM ----------

Do most K-01 users utilize the Auto focus feature? Is it sharp? Not expert on this new 1.05 firmware update yet, but before I updated I didn't think the focus was as sharp as I'd like.

04-17-2014, 11:09 PM   #24
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,126
I'm probably the odd-ball statistically speaking in this bunch, who virtually doesn't use AF (Auto Focus) anywhere near as much as everyone else ( and who bought a K-01 primarily for video,.. )
Five out of my eight lenses are MF, and the three AF lenses are just as often used on my Teleconverter, so become MF anyway.

The AF on the K-01 has a reputation for being,.. 'underperforming',.. When I have used it with my Sigma lenses, I've found it resonably accurate in well lit conditions, but it falls apart quickly as the available light level drops, and it's waaaay too easy to end up with a finger blocking the AF assist lamp on the handgrip. (in front and below the Mode dial)
When I do use the AF, most often it's at events and parties with people, and I leave it set to Face Detect, and it's been accurate enough for my purposes in decent light.

On the occasion that I tested a new Pentax lens on the front of the camera, in the excessive light at a trade show, I found the AF to be fast and able to track moving subjects in real time with no errors.

I really think the AF used in the K-01 is 'okay' for most owners, but those of us who are more into our art and would join a forum and make posts are also more likely to speak up about issues, and more likely to provide feedback on those issues.
And yes, there have been improvements made to the AF systems speed and accuracy with each update, most significantly in the 1.03 update IIRC.
Each firmware update builds on the previous, so if you've gone from the factory 1.00 release to the latest 1.05, you've got a whole raft of changes in one hit, and will notice then performance differences.


That 'half dozen primes',.... you're going to love using them on a K-01.
And if not, you can sell them to me if they're fast primes

Last edited by PiDicus Rex; 04-18-2014 at 12:22 AM.
04-18-2014, 08:40 AM   #25
Senior Member




Join Date: Jan 2013
Posts: 240
Thanks PDR for your input. I've put my Sony R100X aside and have picked up the K-01 to put it back to work. Several of my prime lenses are old screw mounts that I use with the adapter.I've got one here. Has no features and I use the magic green button. It is an Asahi Opt Co. 1:2.5/35 which probably means something to those who know. While it's labeled "auto Takumar" it doesn't have the "A" setting on the ring. It's heavy, about four inches long, all steel and comes in a very nice brown leather case. I think it's a wide angle lens. I've used it but it's been a few years. What have I got here anyway? It looks and feels like a quality piece of gear. I use a 1.4 50 mm screw mount lens that I used to use with my ES. Great little lens.

As an aside, I like the styling of the K-01 just fine. Looks like Micky Mouse could use it with his three fat fingers.
04-18-2014, 10:10 PM   #26
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,126
35mm is 'wide',..
50mm is the usual dividing line between wide and normal, 50, 80 and 135 would be 'normal', and beyond being telephoto (or 'long')
Fish-eye or super wide is numbers like 18mm and shorter - where the wide angle can be seen to visibly distort straight lines (vertical and horizontal) in to curves at the edges of the frame.

1:2.5 is the size of the aperture opening. It's always measured as the widest opening.
The wider it opens, the faster the lens is - faster comes from the larger opening being able to pass more light for the same amount of time the shutter is open for, compared to a lens that opens less.
But,.. The physical size of what is "f2" is different between a 35, a 50, or 135, or a 400 - the longer the lens is, the wider the opening needs to be to maintain the same volume of light to pass, given that light is now coming from a narrower source.

I look forward to seeing what you can create with it.

My 50mm f1:2 has a Iris opening that is physically smaller then then my 400's f6.3.

I've had a more recent 50/1.4 on my K-01, makes some beautiful images, your older M42 screw mount should give a unique look, some of the Depth of Field and focus qualities will be similar to the newer lenses, but the coatings used, the chemical composition of the glass, and the quality of the grinding used to make it, will give different characters to the colours and the way they separate due to wavelength as they pass through the glass.

Last edited by PiDicus Rex; 04-18-2014 at 10:18 PM.
05-23-2014, 06:41 PM   #27
New Member




Join Date: Apr 2013
Posts: 4
I'm having trouble updating my k-01. it's still on version 1.0 and there is no arrow sign when i go on Frameware info/options . please can anyone help me.
05-23-2014, 07:31 PM   #28
Pentaxian
PiDicus Rex's Avatar

Join Date: May 2013
Location: Melbourne, Australia
Posts: 1,126
No arrow on the menu option?
This would mean the firmware file has not be copied to the SD card correctly, or in to the position on the card as indicated in the instructions.

Backup the contents of a SD Card to your PC/Mac.
Put the card in the camera and Format it.
Back to the PC with the Card, copy the firmware file to the Root directory of the SD Card.
Put the card back in the camera and try it again.
So long as the battery is fully charged, you should be good.


Hrm,... should be getting close to Ricoh-Pentax releasing v1.06,.... Going by previous history anyway.
05-23-2014, 07:51 PM   #29
New Member




Join Date: Apr 2013
Posts: 4
QuoteOriginally posted by PiDicus Rex Quote
No arrow on the menu option?
This would mean the firmware file has not be copied to the SD card correctly, or in to the position on the card as indicated in the instructions.

Backup the contents of a SD Card to your PC/Mac.
Put the card in the camera and Format it.
Back to the PC with the Card, copy the firmware file to the Root directory of the SD Card.
Put the card back in the camera and try it again.
So long as the battery is fully charged, you should be good.


Hrm,... should be getting close to Ricoh-Pentax releasing v1.06,.... Going by previous history anyway.
i've done that multiple times and it still doesn't work.
05-24-2014, 06:13 PM - 2 Likes   #30
Pentaxian
Caver's Avatar

Join Date: Jun 2009
Location: Hungary (ex-pat from Transylvania, Romania)
Photos: Gallery
Posts: 429
Original Poster
QuoteOriginally posted by mehdi-101 Quote
i've done that multiple times and it still doesn't work.
So, here you are, one more time: everything what PiDicus Rex wrote:
QuoteOriginally posted by PiDicus Rex:
Backup the contents of a SD Card to your PC/Mac.
Put the card in the camera and Format it.
Back to the PC with the Card, copy the firmware file to the Root directory of the SD Card.
Put the card back in the camera and try it again.
So long as the battery is fully charged, you should be good.
Link to the official firmware file:
http://www.ricoh-imaging.co.jp/english/support/digital/k-01_s.html

+ info in pictures, (sorry for the quality ot the camera back photos taken with a crappy phone in the dark):
1.


2.


3.


4. After you have the firmware file in the ROOT of the SD card, put the card back in the camera (or unmount and turn off and then on the camera from the PC/MAC if you were using a cable),

5. Go to the setup menu, on the third page you will see Firmware Info/Options (last line). Note: if you are just watching the menu, then you won't see the the green arrow pointing to right, you have to scroll down to the menu, then you will see this:



6. pressing the right tab you will get this (my camera is already on firmware 1.05 but yours will show whichever firmware you have on it)



7. finally if you press the right tab again you will get this:


Select and press the Start then your camera will work on upgrading the firmware - blinking the light on the back, and then you will get a COMPLETE message. That's all.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, firmware 1.05, focus, k-01, k01, mirrorless, pentax, pentax bodies, pentax k-01
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
K-30 freeze with new firmware 1.01 EstimatedEyes Pentax K-30 & K-50 10 08-14-2013 03:15 AM
K-01 kit, including Newson bag, at Fab. MrSkelter Pentax Price Watch 13 03-04-2013 08:04 PM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM
Firmware updates for K30, K-01 and Q RKKS08 Pentax News and Rumors 4 10-29-2012 05:59 PM



All times are GMT -7. The time now is 02:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top