Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-08-2014, 07:45 PM   #1
New Member




Join Date: Dec 2014
Posts: 2
Built-in flash stuck on

Yesterday, the built-in flash on my K-01 started firing with every shot even though it is pushed down. Also, pressing the flash up button will not pop up the flash, presumably because the camera thinks that the flash is already up.

I tried changing every setting that I could think might help, but nothing worked. The only thing that prevents the flash from firing is turning the mode dial to the 'No flash' mode. I tried leaving the battery out of the camera all day today, then I reset all functions to the defaults, but that didn't help. I updated the firmware to 1.04 (I was on 1.03), but that didn't help. Eventually I pried the flash open: inside the flash housing there is the catch that holds the flash closed and a small button that presumably detects that the flash is closed; holding this button depressed while shooting still doesn't stop the flash from firing.

Any suggestions?

thanks,

Jeremy

12-08-2014, 08:34 PM   #2
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
I see the "pin" that the flash holds down while (the flash is) on the down position never did try if holding it down manually will disable the flash. Maybe you have to push the "catch" back also as you push the "pin" down? There might be something wrong electrically. Although the catch is mechanical in nature, actuating it is an electrical thing.
12-09-2014, 01:15 PM   #3
New Member




Join Date: Dec 2014
Posts: 2
Original Poster
QuoteOriginally posted by GerryL Quote
I see the "pin" that the flash holds down while (the flash is) on the down position never did try if holding it down manually will disable the flash. Maybe you have to push the "catch" back also as you push the "pin" down? There might be something wrong electrically. Although the catch is mechanical in nature, actuating it is an electrical thing.
Thanks. I tried holding the catch in different positions while holding the pin down but it didn't make any difference. I think you are right that it is an electrical problem.
08-27-2016, 02:51 PM   #4
Veteran Member
Immunogirl's Avatar

Join Date: Dec 2010
Posts: 313
My pentax k-01 has a similar problem - I've fixed it before by cleaning around the flash mechanism - but it's happening again. Anyone have any other suggestions?

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
built-in, built-in flash, button, camera, flash, k-01, k01, mirrorless, mode, pentax k-01, pop-up
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
taking photos with built in flash in extremely low light Andrew Crouch Pentax K-5 12 02-20-2014 12:10 AM
K-r: built-in flash stopped working after using external flash wedge Troubleshooting and Beginner Help 7 01-12-2014 07:57 PM
Need to disable in-built flash when using off camera flash Molly Flashes, Lighting, and Studio 18 03-27-2013 04:12 AM
Turning off built-in flash when using AF540 on K10D Reconman-1033 Troubleshooting and Beginner Help 5 01-14-2010 12:52 PM
Using built-in flash on K100d with a manual lens seeker Pentax DSLR Discussion 2 04-18-2007 10:55 AM



All times are GMT -7. The time now is 05:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top