Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-11-2020, 01:40 PM   #1
New Member




Join Date: Jul 2017
Location: Michigan
Posts: 16
Pentax K-01 Crashes With 24-70 Pentax D FA Lens

According to Ricoh, it should work, but for some reason the K-01 with the latest 1.05 firmware, does not support this lens. The camera turns on for a second, the screen flashes some stuff, and then it crashes. Any thoughts? Work fine with with my other lens (limited fa and xs).

05-11-2020, 01:50 PM   #2
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,991
I guess the obvious question is does the lens work on other cameras?

And maybe make sure you have a fully charged battery?
05-11-2020, 01:56 PM   #3
New Member




Join Date: Jul 2017
Location: Michigan
Posts: 16
Original Poster
1) Yes lens works on other cameras.
2) Charging up the battery just in case. It's 80% charged atm.
05-11-2020, 02:03 PM   #4
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,991
The other thing often recommended is to clean the contacts on both the camera and lens. Just buffing with a microfiber cloth is good.

I've never heard of a lens crashing a camera to be honest so this is interesting. I have seen a lot of weird behavior when a camera has a battery that is running low. And often things that do not really point to the battery which is why I suggested making sure its full just to eliminate that.

Let us know what happens after you test with the full battery.

05-11-2020, 02:45 PM   #5
Site Supporter
Site Supporter
jumbleview's Avatar

Join Date: May 2012
Location: Concord, CA
Posts: 925
Lucky me! No need to worry about crash. I do have K-01, but I do not have 24-70 lens.
05-11-2020, 03:14 PM   #6
Pentaxian




Join Date: Jan 2018
Location: Jersey C.I.
Photos: Albums
Posts: 2,178
I've known dirty contacts, specifically in my case on a Tamron Adaptall-2 adaptor, cause some fairly impressive responses from my cameras, all sorts of flashing lights and non-operation - a first guess, as also suggested, would be to clean the contacts. Personally I use a drop of WD40 on a cotton bud followed by a "dry polish" with a clean tissue or cloth.
05-11-2020, 03:41 PM   #7
Site Supporter
Site Supporter
luftfluss's Avatar

Join Date: Jun 2011
Location: NJ
Photos: Gallery | Albums
Posts: 9,883
Are all the in-camera lens corrections turned off?

Since the last FW update for the K-01 was 6 years ago, perhaps there is simply compatibility issues between it and some of the newer lenses with focus motors.*

Is this SDM in the lens the same motor as Tamron's USM?

05-11-2020, 04:01 PM - 1 Like   #8
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 42,004
QuoteOriginally posted by jatrax Quote
I have seen a lot of weird behavior when a camera has a battery that is running low.
That or a battery that is approaching end-of-life. Voltage sag on start-up with the extra load of the KAF3 lens on board, is a possibility.


Steve
05-11-2020, 05:05 PM - 2 Likes   #9
Loyal Site Supporter
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Working From Home
Photos: Gallery | Albums
Posts: 26,276
I can confirm the D FA24~70/2.8 performs as expected on my K-01.

Camera starts normally, lens autofocuses and all controls operate as they should. I installed a fully charged battery, fresh off the charger. It is a 2013 dated battery.

Last edited by monochrome; 05-11-2020 at 08:02 PM.
05-11-2020, 07:55 PM   #10
New Member




Join Date: Jul 2017
Location: Michigan
Posts: 16
Original Poster
No beuno from freshly charged battery (battery is old, 2012). I'm going to purchase a new battery and see what happens. One thing I did notice is that when the camera crashes, something is shifting around in the camera body; I think it's the IBIS moving. I did clear all the camera settings that I could, but that did not help.
05-12-2020, 06:01 AM   #11
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2018
Posts: 1,590
Do you have the current firmware in the K-01 ?
Latest K-01 Firmware Update : Software Downloads | RICOH IMAGING
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
crashes, fa, k-01, k01, lens, mirrorless, pentax, pentax d fa, pentax k-01, pentax k-01 crashes
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nature Chickadee crashes a lens test. normhead Post Your Photos! 10 03-23-2020 08:04 AM
For Sale - Sold: FA* 80-200 f2.8, FA* 28-70 f2.8, FA* 24 f2, FA 43 f1.9, M 50 f1.7, K-7, AF-540FGZ JerryFu Sold Items 6 02-25-2019 10:47 AM
RawTherapee Crashes after Lens Profile Correction in LR applied. BruceBanner Digital Processing, Software, and Printing 7 01-28-2018 02:03 PM
For Sale - Sold: Pentax FA* 200 macro, FA* 85, FA* 24, FA 31 LTD, FA 77 LTD, A 50/1.2, VL 125 M aegisphan Sold Items 86 09-03-2009 02:37 PM



All times are GMT -7. The time now is 09:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top