Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-26-2012, 12:52 AM   #16
Veteran Member
EarlVonTapia's Avatar

Join Date: Oct 2012
Location: Vancouver
Photos: Gallery
Posts: 1,152
Just had my first freezeup today. I've had my camera for nearly two months now, approaching 4500 shots. The majority of these shots (95%+) have been with the same 8GB memory card I got with the camera. The battery was fully charged last night, so I don't think that was the problem.

I was walking outside in a park (beautiful day today, like it was golden hour all day), using my F 50 1.7 in TAV mode. I had the camera on, and I was holding it in my hand, and every two minutes or so I was half-pressing the shutter to keep the camera awake and ready. I could tell it was still on from the vibration of the AF in the lens.

Well, just when a shot came up (some random little girl went flying into a metal fence with her bike, training wheels and all), I pressed the shutter, and . . . nothing! I set the camera so the screen is always off (no previews or anything), and it wouldn't come up when pressing anything. Turning the camera on and off did nothing. It was really frustrating actually. I ended up doing a battery pull, and everything was fine after that (though by that time the girl had already been helped up). I even went to a friend's office after and took some photos, and no other problems came up.

A few factors that may have contributed to this freezeup:

- My cruel act of poking the camera awake every two minutes or so may not have been the best thing to do. I will avoid that in the future, and just keep it off, or, let it properly go to sleep.
- It was a bit chilly outside today. Nowhere near the minimum operating temperature that was set out by Pentax, but this is the first time I've taken this thing out in this cold of a temperature. Perhaps that added something to it.
- The camera is still on the original firmware. Maybe that had something to do with it. I will get around to updating it this week.

Anyways, nearly 5000 shots before a problem, so I won't worry too much about it (I did have other problems, but they were related to Lexar memory cards). Just thought I would report it for the record. If any other problems do come up though, I'll post back here with as much details as to the circumstances, so that if there is something buggy with the K30 we can hopefully cobble together what the problem is.

Also, I still love my K30!


Last edited by EarlVonTapia; 11-26-2012 at 12:59 AM. Reason: still love my K 30!
12-07-2012, 02:35 PM   #17
New Member




Join Date: Dec 2012
Posts: 2
Hello,
I have a rather complex story with K-30.
I made the purchase in July my first K-30. A few weeks later. He froze. I returned to Pentax who sent me a new five weeks later.
4-5 weeks later, the new K-30 is also set to freeze. At the beginning, very isolated. Then, more and more often to end up almost always.
I made ​​contact with the customer service from Pentax. I had tried other memory cards, without result. I had to update the firmware. No result.
I returned the K-30 to the company.
We will send me a new one again.
EXCEPT that .... I no longer use my Sigma 10-20 or Tamron 90 my. According to Pentax, these are the lenses that cause me problemen on K-30.
So I like to keep the alternative K-30 using ONLY Pentax lenses.
Or I buy something else.
I thought to change the K-5 II. Pentax representative told me that it could still be problematic. According to them, the K-5 and K-30 are of the same generation. So the problem could happen again.

I love this case. I do not really know what to do. I can not afford to buy me a new macro just for fun. The Tamron is practically new.


So, is that other users have seen the device with frozen using other lenses that Pentax?
12-07-2012, 06:02 PM   #18
Veteran Member
EarlVonTapia's Avatar

Join Date: Oct 2012
Location: Vancouver
Photos: Gallery
Posts: 1,152
Just had my second freezeup yesterday night. 4850-ish shots. It was inside my house, so temperature was fine. Battery was more than half drained, but nowhere near close to being empty. I took a shot, then wanted to see a preview. The picture popped up on the LCD, but then the back wheel wasn't working so I couldn't zoom in. I tried that for a few seconds, then the screen went dark, and none of the other buttons were responding. I almost immediately just popped out the battery out, then popped it back in. Everything worked after that.

Today I crossed 4900 shots, and no problems yet from last night.

I'm just going to shrug this second incident off. The circumstances between this freezeup and my previous freezeup (see two posts earlier in this thread) were quite different, so there's no real pattern to examine. I still haven't upgraded the firmware (really lazy), so perhaps that's the cause.

If another freeze happens before the end of the year though, I'll take a deeper look into it.
12-07-2012, 08:51 PM   #19
Senior Member




Join Date: Feb 2011
Location: Philippines
Photos: Gallery
Posts: 182
Sylvie - Thank you for the information from Pentax that the Sigma 10-20 causes these freeze problems. The issue I reported on the previous page when I was interval shooting was using the Sigma 10-20 so I suspect that Pentax actually knows the problem and has not able to find a solution. I've seen a couple more freeze up after my interval shooting incident but it really doesn't come too often so I guess I can live with it. Try to monitor how much you encounter the problem and you could decide if this is a big issue for you.

Regards,

Chester

12-08-2012, 05:11 AM   #20
New Member




Join Date: Dec 2012
Posts: 2
Drivingback
'Hello, over time it has become a very big problem because the K30 now constantly freezes. Regardless of the lens used. Whether my 50mm Pentax, Tamron or the Sigma.
Pentax does not want to find out how to solve the problem. Pentax K30 replaces me telling me not to use this new case other than Pentax lenses. That does not make sense. Nikon or Canon do not exige from its customers not to use other lenses than the same brand as the Casing.
Pentax advance and that I am the ONE to whom it happens. As many other people will not talk, nothing will happen with Pentax.
12-30-2012, 04:11 PM   #21
New Member




Join Date: Dec 2012
Posts: 1
Front and rear dials lockup

Hi there. I've had my k30 for two months and have had two lockups with the dials.the first time with 18-55 wr lens and the second with an old sigma DL 100-300 lens. On both occasions it occured while I was reviewing images. I was unable to scroll through the pictures or use the zoom function (rear dial). When I switched back to take some photos in Av mode, the dial refused to shift the aperture. Swicthing the camera off for 10 seconds and back on solved it.
I dont think its the firmware as I have had the lockup occur with v1.00 and v1.01, battery was about half full, and only occured when reviewing images.
01-03-2013, 01:54 PM   #22
Forum Member




Join Date: Dec 2012
Photos: Gallery | Albums
Posts: 55
K-30 video problem

Hey,

can anyone help me because it happened several times when I panning with my camera. When it goes from a bright area to a darker one and/or there is a close object between, the recording is freezing for a second. In the attached video you can see from the windscreen to the side windows there is the dark area (column - if it is the right word for the car part).

Link:

Thank you!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, k-30, k-50, k30, k5, movie, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
IR problems with my K-5 Tord Pentax K-5 8 08-12-2013 06:17 AM
Everybody's got problems ;) Jeff Charles Pentax K-5 20 02-18-2011 04:54 AM
k7 problems pat Troubleshooting and Beginner Help 5 01-18-2011 10:48 PM
More K-7 problems... nelsh Troubleshooting and Beginner Help 6 10-04-2010 05:33 PM
Need help with exposure problems and snow photography problems, urgent please respond montezuma Photographic Technique 7 02-24-2008 05:43 PM



All times are GMT -7. The time now is 12:21 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top