Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-21-2012, 04:11 AM   #1
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
K-30 vs Digital Concepts Flash

I have a Digital Concepts flash model 952AF that I bought many years ago. I rarely use it.
It worked fine with my Pentax K200D, which my mother now has.

Yesterday I tried to use it for the first time with my K-30. As soon as it was powered up, it immediately started dozens of very quick uninterrupted short discharges !

I swapped the batteries, but that made no difference.

The test button on the flash works fine when the flash is off camera.

I have not tried to use it in wireless slave mode, not sure if it ever worked that way with the K200D though it supposed to.

At this point I'm not sure if it's the flash that went bad, some sort of incompatibility between it and the K-30, or maybe a defect on my K-30 I hope it's not the later. I don't have another Pentax DSLR. to test with, or another flash.

What can I do to further make the determination of the root cause ?

10-21-2012, 05:02 AM   #2
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,863
Hm, what camera settings do you have? Be sure to follow the manual on how and when to mount a flash and what settings to use.
Also, not all flashes work on all cameras. You have to be careful with that stuff, as it can even damage your gear. The flash probably has a list of cameras that it should be compatible with. Make sure Pentax is on that list.
10-21-2012, 05:02 AM   #3
New Member




Join Date: Sep 2006
Location: Budapest
Posts: 4
There is the same issue with Metz SCA 3702 M3 adapter.
It seems Pentax has changed something in the flash communication protocol.
10-21-2012, 01:02 PM   #4
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
Original Poster
Na,

QuoteOriginally posted by Na Horuk Quote
Hm, what camera settings do you have? Be sure to follow the manual on how and when to mount a flash and what settings to use.
Also, not all flashes work on all cameras. You have to be careful with that stuff, as it can even damage your gear. The flash probably has a list of cameras that it should be compatible with. Make sure Pentax is on that list.
This is a P-TTL flash, so of course Pentax is on that list.

10-21-2012, 01:06 PM   #5
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
Original Poster
QuoteOriginally posted by vocsok Quote
There is the same issue with Metz SCA 3702 M3 adapter.
It seems Pentax has changed something in the flash communication protocol.
Damn ! Was there a thread about that flash ?

If Pentax changed the protocol, how do Pentax's own old flashes still work with the K-30 ?

I guess perhaps Digital concepts didn't properly reverse engineer the Pentax flash protocol in the first place.
Sounds like I may have to sell this flash.
10-22-2012, 12:53 PM   #6
New Member




Join Date: Sep 2006
Location: Budapest
Posts: 4
QuoteOriginally posted by madbrain Quote
Sounds like I may have to sell this flash.
Wait with selling:
I am waiting for the answer from Metz.
10-22-2012, 02:04 PM   #7
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
Original Poster
QuoteOriginally posted by vocsok Quote
Wait with selling:
I am waiting for the answer from Metz.
Mine is not a Metz, it's a Digital Concepts. And I'm not aware that it has any firmware upgradeability.
10-22-2012, 10:23 PM   #8
New Member




Join Date: Sep 2006
Location: Budapest
Posts: 4
QuoteOriginally posted by madbrain Quote
Mine is not a Metz, it's a Digital Concepts. And I'm not aware that it has any firmware upgradeability.
I mean, maybe they assumes it is Pentax fault.

10-30-2012, 06:27 AM   #9
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 806
Original Poster
I tried the new 1.01 firmware for the K-30 . No improvement in P-TTL mode - I get the crazy non-stop flash behavior.

M mode works, however, not sure if I tried it before. I do see some information being passed to the flash on its LCD when I change ISO, f-stop and focal length on the camera & lens.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
concepts, flash, k-30, k-50, k200d, pentax, pentax k30, pentax k50, test
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Sakar Digital Concepts 926AF Flash Zoom rkalish Sold Items 2 01-11-2012 07:07 PM
Digital Concepts 918AF dedicated flash luma Flashes, Lighting, and Studio 8 06-04-2011 12:55 AM
Digital concepts 952AF/PEN flash stuck in manual mode? murphysf Flashes, Lighting, and Studio 3 01-02-2011 10:50 AM
Digital concepts 952AF/PEN flash madbrain Flashes, Lighting, and Studio 15 09-17-2009 04:40 AM
digital concepts PTTL flash for pentax pentaxk10duser Flashes, Lighting, and Studio 14 11-30-2007 01:51 AM



All times are GMT -7. The time now is 08:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top