Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-31-2012, 01:40 PM   #1
Site Supporter




Join Date: Apr 2008
Location: NorCal
Photos: Gallery | Albums
Posts: 146
K-30 freeze with new firmware 1.01

Seen a few posts about the K-30 freezing up, but none yet with the new firmware. 'til now. My K-30 is about a week old. I installed the firmware update and was out with it this afternoon (at the SF Giants victory parade) and after about an hour of shooting the camera froze up on me. Would not recognize change of aperture using the control wheel, and, it would not turn off either. It was basically stuck in on mode but couldn't do anything. I was shooting with three primes (2 ltds and a 135-A) and swapping lenses fairly frequently, but that should not cause it to seize up.

Taking the battery out fixed it, but wouldn't want to rely on that fix too often because taking batteries out while cameras are still on can do funky things to the camera or the memory card. Not thinking I have to RMA it based on this one incident, but if it happens again I might do so.

Anyone else have a similar issue?

10-31-2012, 01:50 PM   #2
Senior Member
metalmania's Avatar

Join Date: Feb 2011
Posts: 253
One day with Sigma 30/1.4 and no problem found.
10-31-2012, 06:05 PM   #3
New Member




Join Date: Sep 2012
Posts: 14
I've had mine for a couple of months with no freezes but I don't change lenses often. (Even though many people 'hot swap', I generally play it safe and turn off the camera when changing lenses)
10-31-2012, 06:41 PM   #4
Senior Member
Professor Batty's Avatar

Join Date: Aug 2012
Posts: 118
I've had the same issue with hot swaps in the original firmware on my K-30.

As the doctor told the patient who said "It hurts when I do this" - "Don't do that!"

It would be nice to have a reset button, but taking out the battery does work.

Or have the lens release button turn off the camera.

10-31-2012, 07:08 PM   #5
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Elida, Ohio
Photos: Gallery | Albums
Posts: 8,337
no, not with old or new firmware.
11-01-2012, 01:20 AM   #6
Pentaxian
MegaPower's Avatar

Join Date: May 2010
Location: Hong Kong / Irvine, CA
Photos: Gallery | Albums
Posts: 562
I had a few times already with the old firmware.
I did not update to the new one yet but I guess it won't help.
11-01-2012, 07:53 AM   #7
Site Supporter




Join Date: Apr 2008
Location: NorCal
Photos: Gallery | Albums
Posts: 146
Original Poster
QuoteOriginally posted by Professor Batty Quote
I've had the same issue with hot swaps in the original firmware on my K-30.
Interesting. I ordinarily do not hot swap lenses, but in the heat of the moment I do sometimes forget to flip it off. I guess its possible it happened this time, and if so at least there's an explanation for the freeze. Thanks.
11-01-2012, 07:55 AM   #8
Junior Member




Join Date: Sep 2012
Photos: Gallery
Posts: 26
Hi, I actually have had a huge crash with my K-30 after the update.... it won't really function anymore. Might be user error though (you can see my thread for more info).

11-01-2012, 03:32 PM   #9
Veteran Member




Join Date: May 2012
Posts: 698
My K-r quite often got messed up when I changed lenses without switching off. As far as I remember it only happened when I change from a modern AF lens to an old K-mount (without contacts). I eventually managed to train myself to switch off before swapping lenses and never had a freeze up again.

I have since got myself a K-30 as well and I still take care to switch off before swapping lenses. I've only had a strange behaviour once - when I was shooting at 6fps and and when I let go of the trigger it kept shooting. The only way to stop it was to remove the battery and put it back and it was fine again.
08-13-2013, 07:52 PM   #10
Veteran Member




Join Date: Dec 2012
Photos: Gallery
Posts: 696
Have a new K-30, upgraded to v1.04, two freezes since, in the last week. I *think* it's happening when I take the SD card then in again... will have to pay close attention to make sure I turn it off before removing card or lens. But am using the same lens -- a 55-300mm -- all the time.

Taking the battery out for a moment cures the problem. After all, isn't it a computer masquerading as a camera?
08-14-2013, 03:15 AM   #11
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,262
Every dSLR I have owned the manual always says to turn off the camera before changing lenses or removing/swapping memory cards.
Looking at the K-30 manual I see the same warnings.
Hot-swapping is never OK..

Last edited by Steve.Ledger; 10-25-2013 at 06:31 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, k-30, k-50, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get a K-01 to freeze Adam Pentax K-01 19 08-26-2012 10:41 AM
K-m mirror freeze karma mechanic Troubleshooting and Beginner Help 4 03-23-2012 11:57 AM
K-5 fix for shutter freeze up. garyk Pentax K-5 4 05-28-2011 04:02 AM
K-x and PK Tether freeze. Stanleyg Pentax DSLR Discussion 11 05-18-2011 10:52 PM
Using flash to freeze action eccs19 Troubleshooting and Beginner Help 39 01-18-2011 01:13 PM



All times are GMT -7. The time now is 10:34 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top