Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-29-2013, 01:30 PM   #1
Site Supporter
nutkasse's Avatar

Join Date: Aug 2008
Location: vancouver bc
Posts: 92
k30 M mode says TAv

hi all, my brand new k30,when selected to "m" on the dial shows "tav" on the lcd & functions as "tav" . anybody else has this "malfunction". i sent pentax canada an e-mail & still haven't got a reply . i wonder if i should just sent it back

01-29-2013, 01:37 PM - 1 Like   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,784
That's not a malfunction. In auto ISO mode M mode is the same thing as TAv mode. Disable auto ISO and it will say 'M'.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-29-2013, 01:37 PM   #3
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,485
Your ISO is in automatic mode. On the K-30 (and K-01), M mode + AutoISO = TAv. Try selecting a manual ISO speed.
01-29-2013, 01:45 PM   #4
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,836
On older Pentax cameras switching to M mode automatically took you out of auto-iso, you can't use even use auto-iso in M mode. Did Pentax just get lazy with the K30 and not change the firmware from the K-01?

01-29-2013, 01:49 PM   #5
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,819
So, push the ISO button and then go up/down to choose the single number instead of the range (where you can choose the range in which the camera will automatically select ISO)
01-29-2013, 02:13 PM   #6
Loyal Site Supporter
THoog's Avatar

Join Date: Aug 2012
Location: North Carolina
Photos: Gallery | Albums
Posts: 3,485
QuoteOriginally posted by boriscleto Quote
On older Pentax cameras switching to M mode automatically took you out of auto-iso, you can't use even use auto-iso in M mode. Did Pentax just get lazy with the K30 and not change the firmware from the K-01?
Personally, I think it's the other way 'round - the K-01 has the K-30's firmware with some features disabled (yes, I know the K-01 came out first, but only by a few weeks). I don't know about lazy, but they gave us a freebie TAv mode.
01-29-2013, 02:42 PM   #7
Site Supporter
nutkasse's Avatar

Join Date: Aug 2008
Location: vancouver bc
Posts: 92
Original Poster
QuoteOriginally posted by THoog Quote
Personally, I think it's the other way 'round - the K-01 has the K-30's firmware with some features disabled (yes, I know the K-01 came out first, but only by a few weeks). I don't know about lazy, but they gave us a freebie TAv mode.
thks guys, i will check it out when i get home
01-29-2013, 03:08 PM   #8
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
QuoteOriginally posted by boriscleto Quote
On older Pentax cameras switching to M mode automatically took you out of auto-iso, you can't use even use auto-iso in M mode. Did Pentax just get lazy with the K30 and not change the firmware from the K-01?
don't know what is more effort, putting 1 extra mode on the wheel dail or putting Auto ISO in manual mode?

Anyway i think it's a good idea, saves space on the dail for more options.

01-29-2013, 09:32 PM   #9
Site Supporter
nutkasse's Avatar

Join Date: Aug 2008
Location: vancouver bc
Posts: 92
Original Poster
that worked - turn auto iso off
thks everybody
05-27-2013, 10:41 AM   #10
Junior Member




Join Date: Dec 2012
Location: Normandie
Photos: Gallery
Posts: 25
I had this problem and read several posts about it and tried everything (I thought), but I still had no M mode. Then I found this posting from another site (not sure if I can post it?) where the topic was 'Can't use non-A lenses with K30', and this little bit of information saved me: "Just changed ISO to manual in Manual mode... and it works!!!" Big facepalm for me, as I didn't have the M mode, I was always in Tv or something when setting the ISO off auto! When I set the wheel to M and set ISO to manual.... abracadabra!

So, if there are others out there who needs to be fed with teaspoons, try this.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-30, k-50, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual mode on my K10D is acting like TAv mode Love my K10D Visitors' Center 9 11-06-2013 11:44 AM
K30 Av mode appear to be P mode ymfoo Troubleshooting and Beginner Help 13 09-19-2012 05:34 AM
TAv Mode L33tGreg Pentax DSLR Discussion 4 07-21-2011 01:20 PM
I think I'm in Love With TAV Mode :-) wll Photographic Technique 11 06-14-2009 09:15 PM
A way to get a TAv mode on the K-m/K200D? ManuH Pentax DSLR Discussion 28 04-07-2009 03:57 AM



All times are GMT -7. The time now is 09:07 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top