Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-15-2013, 02:21 PM   #1
New Member




Join Date: Dec 2012
Location: Ontario
Posts: 8
K-30 Lens information in Aperture,iPhoto

When I shoot in JPEG or RAW with my K5, both iPhoto and Aperture will give me the full lens information. With my K30, I only get the lens information when I shoot in RAW. Any way to get it in JPEG as well?

03-15-2013, 06:08 PM   #2
Senior Member
apfhex's Avatar

Join Date: Feb 2013
Location: Northern California
Photos: Gallery
Posts: 107
I don't have an answer, but you did just solve my mystery of seemingly random photos with "Unknown lens" in Lightroom. Those are ones I only shot as JPEG!
03-15-2013, 08:25 PM   #3
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
Can you get lens information from a JPEG with ExifTool?

ExifTool by Phil Harvey
03-16-2013, 02:10 AM   #4
Veteran Member




Join Date: Mar 2007
Location: U.K.
Posts: 685
QuoteOriginally posted by boriscleto Quote
Can you get lens information from a JPEG with ExifTool?

[ur://www.sno.phy.queensu.ca/~phil/exiftool/]ExifTool by Phil Harvey[/url]
As PhotoME couldn't read lens info from a K-30 jpg shot with Sigma 17-70 lens, I tried ExifTool in a DOS window and yes the full description of the lens is there near the bottom of the list. I'll have to look for a GUI for ExifTool as it's a bit fiddly to use as it is.

Edit:- ExifToolGUI works OK but you have to click on 'Modify>Exif:LensInfo from MakerNotes' for every image to get the full lens description to show. I'll look for a fix. By the way, be careful with ExifTool as it can edit the exif info. I've just noticed a cool thing, there's an entry called AFintegration time which does seem to be the time in milliseconds to reach an AF lock.

Edit:- I was wrong about PhotoME, it shows the full lens name but in feint text which is why I missed it.


Last edited by SteveB; 03-16-2013 at 03:11 AM.
03-16-2013, 06:52 PM   #5
Senior Member




Join Date: Sep 2011
Location: New Hampshire
Posts: 107
I have the same problem: no Exif lens info when shooting jpeg. Kr always showed it but the K30 doesn't for some reason. Haven't found a solution yet (using iPhoto).
03-17-2013, 11:11 AM   #6
New Member




Join Date: Dec 2012
Location: Ontario
Posts: 8
Original Poster
I was hoping there may have been an easy solution that I had missed. My Kr didn't give me the information when it was new, but after a year it did. It may be necessary to wait for Apple to do some magic, although I do have the latest versions of iPhoto and Aperture.
03-17-2013, 11:19 AM   #7
Senior Member




Join Date: Sep 2011
Location: New Hampshire
Posts: 107
Hopefully the same will happen. Fingers crossed!
03-17-2013, 12:03 PM   #8
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by Kingston 1000 Quote
I was hoping there may have been an easy solution that I had missed. My Kr didn't give me the information when it was new, but after a year it did. It may be necessary to wait for Apple to do some magic, although I do have the latest versions of iPhoto and Aperture.
According to one of the posts above, the info isn't showing up in Lightroom either so it seems to be a Pentax issue to fix, not an Apple issue.

03-17-2013, 12:24 PM   #9
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
QuoteOriginally posted by IchabodCrane Quote
According to one of the posts above, the info isn't showing up in Lightroom either so it seems to be a Pentax issue to fix, not an Apple issue.
It's an EXIF issue. Apple and Adobe don't update their EXIF libraries all that often...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
information, jpeg, k-30, k-50, lens, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New K-30 and Apple Aperture pippin65 Troubleshooting and Beginner Help 3 02-12-2013 10:13 AM
K-30 Viewfinder Information lil red dot Pentax K-30 & K-50 7 02-08-2013 03:10 AM
Who needs a tool to fix missing Lens identifications for iPhoto, Aperture etc? tempelorg Digital Processing, Software, and Printing 19 03-12-2012 04:10 AM
iPhoto or Aperture 3 ? CuriousEye Digital Processing, Software, and Printing 18 12-07-2011 08:54 AM
?? iPhoto/Aperture adds red hue to RAW - Lightroom does not Avilion Digital Processing, Software, and Printing 9 05-12-2010 11:49 AM



All times are GMT -7. The time now is 10:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top