Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-03-2013, 04:16 AM   #61
Site Supporter




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by eLaReF Quote
Shiny new camera arrived yesterday replacing one of my *ist's
Checked the existing Firmware and it says 1.00
Downloaded 1.04 and followed the instructions
When I press Menu & Switch on, I get the 5 sec Existing Version message then it reverts to normal
Tried several times.
Held Menu button down while the 5 sec msg displayed and kept holding it - NO change
Formatted card in camera and re-tried - NO change
Formatted card again, connected camera via cable and copied file from PC via the cable. - NO change

Suggestions anyone?
Since you are posting in the K-30 forum, by chance did you mistakenly download the K-30 firmware for your K-5 II?

05-03-2013, 05:53 AM   #62
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 904
QuoteOriginally posted by eLaReF Quote
Shiny new camera arrived yesterday replacing one of my *ist's
Checked the existing Firmware and it says 1.00
Downloaded 1.04 and followed the instructions
When I press Menu & Switch on, I get the 5 sec Existing Version message then it reverts to normal
Tried several times.
Held Menu button down while the 5 sec msg displayed and kept holding it - NO change
Formatted card in camera and re-tried - NO change
Formatted card again, connected camera via cable and copied file from PC via the cable. - NO change

Suggestions anyone?

Copy the file onto the SD card. Put the card into the camera. Switch on the camera. Go to Menu. Select Firmware. Select update. It will auto shutdown after completion. Switch camera on, Go back to the firmware menu. You are now able to see that it is updated.

The K30 updates differently from the K5/K5II/K5IIs.

It is the same for the Q/Q10.

Cheers. . .
05-03-2013, 06:58 AM   #63
New Member




Join Date: Apr 2013
Posts: 13
QuoteOriginally posted by IchabodCrane Quote
Since you are posting in the K-30 forum, by chance did you mistakenly download the K-30 firmware for your K-5 II?
Oh B****cks
I started in the K5 one!!

Thks

Will try there

No - It was the K5 file and instructions though

Thks again
05-05-2013, 08:10 AM   #64
New Member




Join Date: Sep 2012
Posts: 5
Seems this discussion has become more about Memory cards in your camera and how to update the firmware? Rather than the new firmware itself.
I was looking for information with users who have upgraded to this version 1.04 and say something about there experience.
Any more benefits discovered or disadvantages type of things ?

05-05-2013, 08:44 AM   #65
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by zerokewl Quote
Seems this discussion has become more about Memory cards in your camera and how to update the firmware? Rather than the new firmware itself.
I was looking for information with users who have upgraded to this version 1.04 and say something about there experience.
Any more benefits discovered or disadvantages type of things ?
When I got the camera from the store it was firmware 1.00, before I started using it seriously I updated to the latest version 1.04. Since then I have not noticed any of the quirks that are mentioned on the beginning and throughout this thread.
05-09-2013, 10:41 PM   #66
MFW
Inactive Account




Join Date: Mar 2013
Posts: 7
Problems updating to 104 with Resolution

Just updated to 104
Followed all instructions.
Battery fully charged.
Finished process, checked that I now had 104. OK. Switched off.
Camera wouldn't switch back on!!!! Sweating buckets!
Finally removed battery, waited 30 secs, replaced battery.
Camera now works with 104 firmware?????? What happened?
05-10-2013, 11:59 AM   #67
Junior Member




Join Date: Mar 2011
Posts: 42
I also had firmware 1.0,w 1.04 everthing went out smooth.
05-17-2013, 11:34 AM   #68
Loyal Site Supporter
onlineflyer's Avatar

Join Date: Jul 2010
Location: Ohio
Photos: Gallery | Albums
Posts: 549
QuoteOriginally posted by jssurfer Quote
D/L uptate 1.04 to computer desktop.... icon there ... what to do next .... d/l into plugged in camera... right??? cant seem to d/l into camera,, because; everytime I plug camera into the computer cord and turn camera on w/or w/o pressing the menu button the monitor stays black.... no image at all!!! I then turn camera off UNPLUG turn camera on The monitor and camera work.... really weird!!! battery charged, blank formatted 4KB card [temp] waiting for new smaller cards . anyone have this issue w/ blank screen only when plugged into computer??? help!!!!!!!! I cant d/l update without a screen
I'm having the very same problem. Have you found the problem/solution? Anyone else have a solution?

Thx

05-17-2013, 11:41 AM   #69
Veteran Member




Join Date: Oct 2011
Photos: Gallery
Posts: 496
QuoteOriginally posted by onlineflyer Quote
I'm having the very same problem. Have you found the problem/solution? Anyone else have a solution?

Thx
I just updated to 1.04, but downloaded onto sd card. After I realised I had to open the folder to find the file, it worked perfectly. Maybe you should try putting it on a card and not connecting to the computor.

Just a thought.

Tuggie76
05-17-2013, 11:48 AM   #70
Loyal Site Supporter
onlineflyer's Avatar

Join Date: Jul 2010
Location: Ohio
Photos: Gallery | Albums
Posts: 549
QuoteOriginally posted by tuggie76 Quote
I just updated to 1.04, but downloaded onto sd card. After I realised I had to open the folder to find the file, it worked perfectly. Maybe you should try putting it on a card and not connecting to the computor.

Just a thought.

Tuggie76
Thx, also found the following post that addressed the issue

https://www.pentaxforums.com/forums/pentax-k-30/221680-blank-screen-cant-d-l-update.html
05-17-2013, 11:50 AM   #71
New Member




Join Date: Apr 2013
Posts: 13
Further up this page felixH stated:-
"Copy the file onto the SD card. Put the card into the camera. Switch on the camera. Go to Menu. Select Firmware. Select update. It will auto shutdown after completion. Switch camera on, Go back to the firmware menu. You are now able to see that it is updated."
07-21-2013, 06:29 AM   #72
Junior Member




Join Date: May 2013
Posts: 45
QuoteOriginally posted by bcorson Quote
I have 1.01-1,04 . . .what would you like? You will have to give me a place to send it as I tried uploading 1.01 and doesn't seem to like it . . . too big a file I guess
Hi sir. May I trouble you for a copy of the 1.01 firmware for my K30? dmazimoto@gmail.com

Edit: never mind found it on the Pentax website

Last edited by dmazimoto; 07-21-2013 at 07:32 AM. Reason: Found my answer
07-21-2013, 01:19 PM   #73
Forum Member




Join Date: Jul 2011
Location: Texas
Posts: 80
Wish they'd "open-source" the firmware (in the spirit of the Linksys routers)! As a software person, I can always find a cpl of tweaks I'd like to do with it! Shouldn't cost Pentax anything in that they don't have to support unofficial versions and ppl. can't use the firmware w/o buying their camera and they'd get free software-development/improvements!
07-21-2013, 07:21 PM   #74
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
QuoteOriginally posted by kodai84 Quote
Wish they'd "open-source" the firmware (in the spirit of the Linksys routers)! As a software person, I can always find a cpl of tweaks I'd like to do with it! Shouldn't cost Pentax anything in that they don't have to support unofficial versions and ppl. can't use the firmware w/o buying their camera and they'd get free software-development/improvements!
I don't think they'd ever do that, as jpeg engines and in-camera processing features are mostly proprietary; Pentax wouldn't want competitors to borrow their tech and steal their customers. Though it would be nice to make your own tweaks, I'll admit.
07-21-2013, 09:05 PM   #75
Pentaxian




Join Date: Mar 2010
Location: Manila, Philippines
Posts: 1,009
One thing I dislike on my K-30 after the FW update is that the battery meter is not that accurate, I use black Eneloops instead of the lithium btw.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-30, k-50, pentax, pentax k30, pentax k50, v1.04
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-01 Firmware update - V1.02 Docrwm Pentax K-01 42 05-04-2013 06:04 AM
Firmware update v1.01 for Q10 Mistral75 Pentax Q 3 02-20-2013 03:55 AM
Apple Digital Camera RAW Compatibility Update 4.04 i83N Pentax News and Rumors 23 02-15-2013 05:45 AM
k20d v1.04 firmware barn154 Pentax DSLR Discussion 4 08-21-2010 02:32 AM
K20D Firmware v1.04 nanhi Pentax DSLR Discussion 5 05-13-2010 08:17 AM



All times are GMT -7. The time now is 04:07 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top