Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-09-2013, 10:27 PM   #1
Inactive Account




Join Date: Mar 2013
Posts: 7
Update has stopped camera working

Have just updated the firmware to my K-30 from 100 to 104. Followed full instructions. Battery fully charged throughout process. Confirmed that 104 was now the version installed. Switched off after process complete. Now the camera won't switch on at all! Help.

05-09-2013, 10:49 PM   #2
Site Supporter
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,195
Try removing the battery for a few minutes, replace and reboot.
05-09-2013, 10:49 PM   #3
Inactive Account




Join Date: Mar 2007
Location: Los Angeles
Posts: 11
QuoteOriginally posted by MFW Quote
Have just updated the firmware to my K-30 from 100 to 104. Followed full instructions. Battery fully charged throughout process. Confirmed that 104 was now the version installed. Switched off after process complete. Now the camera won't switch on at all! Help.
Did you try to remove a battery, it helps sometimes.
05-09-2013, 10:49 PM   #4
MFW
Inactive Account




Join Date: Mar 2013
Posts: 7
Original Poster
Solution Found

Removed battery for 30 seconds.
Replaced battery. Camera now works with 104 firmware.

Don't like what's just happened one bit. Takes me back to the early days of Windows!

05-09-2013, 10:53 PM   #5
MFW
Inactive Account




Join Date: Mar 2013
Posts: 7
Original Poster
Thanks for such prompt responses. Especially Lenny F and arnold. Great forum, pity about the camera / firmware / update. Caused great palpatations.
05-09-2013, 11:07 PM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
QuoteOriginally posted by MFW Quote
Have just updated the firmware to my K-30 from 100 to 104. Followed full instructions. Battery fully charged throughout process. Confirmed that 104 was now the version installed. Switched off after process complete. Now the camera won't switch on at all! Help.
That's weird, because if it it showed the new version, then your camera most likely isn't bricked. Try removing the battery for a while, charging it, and re-inserting it.

Edit: did it work? Had this reply written a while ago and forgot to hit enter

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-09-2013, 11:20 PM   #7
MFW
Inactive Account




Join Date: Mar 2013
Posts: 7
Original Poster
Battery Removal Worked

Removing the battery worked. It was fully charged so just waited 30 secs and replaced it.
Thanks again all
06-07-2013, 08:38 AM   #8
Inactive Account




Join Date: May 2013
Location: Manchester, CT
Posts: 11
I couldn't turn off my K30 after updating to the new firmware 1.04.everything went smooth and it updated very fast but the camera became unresponsive. I did the battery out and used another and evrything seems ok so far.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-30, k-50, pentax k30, pentax k50, process
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
anti-shake update stopped working krema Pentax Q 8 11-11-2014 05:12 PM
HELP! K-01 e-dial stopped working dstructor Pentax K-01 19 04-11-2013 08:59 PM
K-5 rear display stopped working nbu Troubleshooting and Beginner Help 10 04-07-2013 02:24 AM
ZX-5 - AF stopped working all of a sudden dgaies Pentax Film SLR Discussion 11 08-11-2011 05:33 PM
Pentax 60-250 AF Stopped Working MattMoore Pentax SLR Lens Discussion 23 06-16-2011 06:29 AM



All times are GMT -7. The time now is 12:29 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top