Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-13-2013, 08:00 PM   #1
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Live view only focus

I'm the proud new owner of a K30 and have bought a couple of lenses to go with the kit I bought (body and 18-135).
I posted in the slr lens forum about my dilema with a Tamron 70-300 not locking a focus after 100mm when using the view finder.
I tried today and found that the lens/camera combo seems to lock on in Liveview.

Is this a body, lens, firmware, or setting issue? I'm leaning towards lens, since this is the only lens (so far) to have this problem.

05-13-2013, 08:09 PM   #2
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
First, make sure you have the latest firmware.
05-14-2013, 04:13 AM   #3
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
I went to 1.4 about a week before the Tamron arrived.
05-14-2013, 07:29 AM   #4
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,875
It might be the lens. Is its AF ring okay? How are its contact pins? Can you focus manually with focus peaking? Does it work better when the camera battery is fully charged?
Also, are you sure its the AF and not some other problem?
You might also want to search the forum for that lens name, maybe others have expressed similar problems, though I can't remember any off the top of my head

05-14-2013, 09:23 AM   #5
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Two things come to mind - clean the contacts on both the lens and camera and make certain that the lens is seated properly. If it stops after you have zoomed to a certain point you may be twisting the lens in the mount thereby making the contacts not align.
05-14-2013, 10:24 AM   #6
Veteran Member




Join Date: Mar 2007
Location: U.K.
Posts: 685
My Tamron 70-300 focuses dead accurate at all FLs on my K-30 if that helps. Every firmware has been the same.
05-14-2013, 12:38 PM   #7
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
I'll try cleaning the contacts. As near as I can tell the ring is OK.
Manual focus works great.
05-14-2013, 01:41 PM   #8
Veteran Member
Ken T's Avatar

Join Date: Mar 2008
Location: California, USA
Posts: 537
Have you checked Focus Mode and Focus Point setting ?

05-14-2013, 01:43 PM   #9
Senior Member




Join Date: Dec 2012
Location: Kanata, ON
Photos: Albums
Posts: 130
QuoteOriginally posted by JerD Quote
I'm the proud new owner of a K30 and have bought a couple of lenses to go with the kit I bought (body and 18-135).
I posted in the slr lens forum about my dilema with a Tamron 70-300 not locking a focus after 100mm when using the view finder.
I tried today and found that the lens/camera combo seems to lock on in Liveview.

Is this a body, lens, firmware, or setting issue? I'm leaning towards lens, since this is the only lens (so far) to have this problem.
Check the limit switch and make sure it is engaged properly
05-25-2013, 03:40 PM   #10
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
So far, I can't get the problem corrected. Perhaps just a glitch in the matrix
07-22-2013, 06:55 PM   #11
Junior Member




Join Date: Nov 2012
Location: Chicago SE Burbs
Posts: 32
Original Poster
I've tried all the above, but no luck. Any other ideas?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, focus, k-30, k-50, lens, pentax k30, pentax k50, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5-II focus confirmation in Live View? russell2pi Pentax K-5 3 02-11-2014 12:28 PM
live view focus thegreatswalmi Pentax K-5 5 03-21-2013 05:32 AM
K5iis Live view focus Shelton Pentax K-5 9 02-23-2013 01:18 PM
I can only get live view atomic Pentax K-r 7 02-20-2012 11:08 AM
K20 Live View Focus Problem nimbus109 Pentax DSLR Discussion 3 08-21-2011 10:52 PM



All times are GMT -7. The time now is 10:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top