Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-01-2013, 05:20 PM   #1
Senior Member




Join Date: May 2013
Location: Lima-Peru
Photos: Albums
Posts: 114
Problems with new k 30.

Hi, my pentax k 30 arrived today, i was trying it (its my first dslr) and in every mode exepct auto the pictures look complete (or almost) black, the exposure is at -5, i try to correct it but i can't, i am pressing the button next to the green one and using the dial to change the exposure, but everytime i set a new one it goes back to -5.

Am i doing something wrong?

07-01-2013, 05:40 PM   #2
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 930
Go to Menu and do a Factory Reset to Default. It should clear whatever settings were set earlier. After that see if it happens again.
07-01-2013, 05:58 PM   #3
Senior Member




Join Date: May 2013
Location: Lima-Peru
Photos: Albums
Posts: 114
Original Poster
I think it had to do with the shutter speed, the aperture and the iso, i put a higher iso, slower shutter speed and 3.2 aperture and now it's fine, i think it was my mistake and the camera was telling me i needed to change thoose things (shutter speed, aperture and iso)
07-01-2013, 09:16 PM   #4
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 930
Which mode are you in?

07-02-2013, 04:58 AM   #5
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
After resetting to factory defaults set the mode dial to Auto (green). This should sort your problem out. If it doesn't you might read the manual one last time before you give the camera back.
07-02-2013, 11:08 AM   #6
Senior Member




Join Date: May 2013
Location: Lima-Peru
Photos: Albums
Posts: 114
Original Poster
It was my fault, the k-30 is working fine.
Thanks

Last edited by carlosodze; 07-02-2013 at 12:18 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
exposure, k-30, k-50, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 SD card problems. abarbarian Troubleshooting and Beginner Help 25 01-20-2014 05:37 PM
K-30 freeze with new firmware 1.01 EstimatedEyes Pentax K-30 & K-50 10 08-14-2013 03:15 AM
Problems with PDCU4(.35) & K-30 Hoggy Digital Processing, Software, and Printing 15 02-05-2013 05:07 AM
Problems with my K-30 cynthiaspiers Troubleshooting and Beginner Help 19 02-04-2013 12:17 PM
Pentax K-30 problems. Mr. A.S. Pentax K-30 & K-50 33 01-25-2013 09:11 AM



All times are GMT -7. The time now is 11:44 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top