Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-02-2013, 02:45 PM   #1
Junior Member
ticoun's Avatar

Join Date: Feb 2012
Location: Québec, Canada
Posts: 43
Stop Down metering on K-30

I bought a K-30 last week to replace my old and outdated *ist DL2, but I am now completely lost. I want to use my manual lenses (Two M series lenses, and a Sigma DG series lens I often use with a manual Vivitar 2x teleconverter.) but I can't figure out how to use the stop down metering. I did figure out how to program the RAW/Fx button to Optical Preview, but when I press on it with a manual lens it doesn't stop down the lens. I have tried programming the green button with the unclear instructions from the user manual but nothing seems to work. I can't even select the M mode with a manual lens on. I have updated my camera software to V. 1.04 if it can make any difference.

09-02-2013, 02:49 PM   #2
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,863
Did you set Using Aperture Ring to Permitted? It's in the Custom menu.
09-02-2013, 02:51 PM   #3
Junior Member
ticoun's Avatar

Join Date: Feb 2012
Location: Québec, Canada
Posts: 43
Original Poster
QuoteOriginally posted by boriscleto Quote
Did you set Using Aperture Ring to Permitted? It's in the Custom menu.
Yes I have. It's actually the first thing I did when I got the camera.
09-02-2013, 02:51 PM   #4
Moderator
Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 9,650
Make sure you have set the "allow aperture use" in custom menu 4. last adjustment #22. You should now just be able to press the green button to get your correct metering.

EDIT I type too slow.

09-02-2013, 03:31 PM   #5
Senior Member
bluenose's Avatar

Join Date: Jan 2012
Location: S. Ontario
Posts: 227
Here is a link that may also help. Using K-30 With Older Lenses | Ricoh Imaging Support

Regards
09-02-2013, 03:34 PM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,030
QuoteOriginally posted by ticoun Quote
I bought a K-30 last week to replace my old and outdated *ist DL2, but I am now completely lost. I want to use my manual lenses (Two M series lenses, and a Sigma DG series lens I often use with a manual Vivitar 2x teleconverter.) but I can't figure out how to use the stop down metering. I did figure out how to program the RAW/Fx button to Optical Preview, but when I press on it with a manual lens it doesn't stop down the lens. I have tried programming the green button with the unclear instructions from the user manual but nothing seems to work. I can't even select the M mode with a manual lens on. I have updated my camera software to V. 1.04 if it can make any difference.
You need to set up the green button properly. See this guide & video:
https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-02-2013, 03:39 PM   #7
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,258
Using Older Lenses on PENTAX K-30 | Ricoh Imaging Support

It doesn't mention stop-down metering with the DOF preview so perhaps this doesn't work on the K-30. It does give instructions how set the green button.
09-02-2013, 03:41 PM   #8
Junior Member
ticoun's Avatar

Join Date: Feb 2012
Location: Québec, Canada
Posts: 43
Original Poster
QuoteOriginally posted by Adam Quote
You need to set up the green button properly. See this guide & video:
https://www.pentaxforums.com/forums/pentax-lens-articles/110657-how-use-meter...k-x-k-7-a.html
I did the same as in the video, but when I turn the mode dial to M, it goes in TAv mode instead, even with a DA series lens.

09-02-2013, 03:59 PM   #9
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
QuoteOriginally posted by ticoun Quote
I did the same as in the video, but when I turn the mode dial to M, it goes in TAv mode instead, even with a DA series lens.
Turn off auto-ISO.
09-02-2013, 04:06 PM   #10
Junior Member
ticoun's Avatar

Join Date: Feb 2012
Location: Québec, Canada
Posts: 43
Original Poster
QuoteOriginally posted by elliott Quote
Turn off auto-ISO.
And now it works perfectly.
Thanks a lot for the help everyone.
09-02-2013, 04:22 PM   #11
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,863
I should have mentioned auto-iso, but the last time I mentioned that bug I got yelled at by someone...

Auto-ISO should turn itself off when a manual lens is mounted and the camera is set to M. Every other Pentax DSLR works this way but the K-30 inherited its firmware from the K-01...
09-02-2013, 06:45 PM   #12
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,415
QuoteOriginally posted by boriscleto Quote
I should have mentioned auto-iso, but the last time I mentioned that bug I got yelled at by someone...

Auto-ISO should turn itself off when a manual lens is mounted and the camera is set to M. Every other Pentax DSLR works this way but the K-30 inherited its firmware from the K-01...
So that is the explanation! I don't own a K30, but I remember a flurry of "my K-30 will not work with vintage glass" threads a couple of weeks back. I suspected auto-iso at the time, but since I don't have specific knowledge of the K-30, I kept my mouth shut.


Steve
09-03-2013, 04:53 AM   #13
Veteran Member




Join Date: Jul 2009
Location: Ottawa, Canada
Posts: 342
QuoteOriginally posted by ticoun Quote
And now it works perfectly.
Thanks a lot for the help everyone.
Wait, are you saying that now you see a meter reading when doing DOF preview via the Raw/Fx button with an M series lens?

So far, I've only been able to get the green button to set my exposure with an M series lens. I haven't been able to get a meter reading using DOF preview ( see thread about missing something with the green button ).

Cheers, R
09-03-2013, 07:41 AM   #14
Junior Member
ticoun's Avatar

Join Date: Feb 2012
Location: Québec, Canada
Posts: 43
Original Poster
QuoteOriginally posted by arkav Quote
Wait, are you saying that now you see a meter reading when doing DOF preview via the Raw/Fx button with an M series lens?

So far, I've only been able to get the green button to set my exposure with an M series lens. I haven't been able to get a meter reading using DOF preview ( see thread about missing something with the green button ).

Cheers, R
No, I can't get a meter reading during DOF preview, but that's not a problem for me. All I wanted was to be able to use the green button to do stop-down metering like the AE/L button did on my *ist DL2.
09-03-2013, 07:48 PM   #15
Pentaxian




Join Date: Jul 2013
Posts: 1,457
I just got my K30 today as a result of being a great buy for $499 and also the fact that my brand new k5IIs took a crap after only 10 days and is in warranty.
First thing I noticed was that green button sometimes stopped down in M and sometimes it didn't ? Now I see that if your set to Auto ISO it doesn't stop down ? Yup......went back and set it to 100 or 200 and it stops down like its supposed to again.....??? Not happy......finding a glitch after 1 hour......But wait....If its auto ISO it has to be that way , right ? There is NO aperture info/link on K and M lenses so using a variable ISO would be trouble except for wide open ! That's why it reverts to AV mode when set to M when using Auto ISO....Happy again...lol. Actually its still a glitch. When in M mode there should be no possible way to set a Auto ISO , it should be a manual selection only.

Last edited by Dlanor Sekao; 09-03-2013 at 08:00 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, figure, k-30, k-50, lens, lenses, pentax k30, pentax k50, series, stop
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
No stop down metering with pentax-m lenses (K-x) Aeldrhamir Pentax DSLR Discussion 10 01-23-2013 09:49 PM
6x7 Lenses on 645n & Stop-down Metering Trouble Dubesor Pentax Medium Format 4 02-04-2012 07:03 PM
Stop down metering on a PZ-1p blackcloudbrew Pentax Film SLR Discussion 2 11-03-2011 02:01 PM
Stop-down metering not working with extension tube on K-5 (works on K10d) Beau Troubleshooting and Beginner Help 3 09-13-2011 04:37 AM
Stop Down metering with K-5 jva59 Pentax K-5 8 03-29-2011 06:43 AM



All times are GMT -7. The time now is 08:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top