Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-06-2013, 06:04 PM   #16
Pentaxian




Join Date: Jan 2011
Location: New York
Posts: 3,010
QuoteOriginally posted by yangfilo Quote
I leave my dust cleaning set to clean every time the Camera is Powered up. (yes make a strange shake and sound). My question is "Will this wear parts out quicker than say just cleaning it once a month"?
Don't worry about it. There are so many other parts in the camera that some other part will probably fail before the dust removal and SR system.

12-08-2013, 05:09 AM   #17
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,062
QuoteOriginally posted by crewl1 Quote
Yes they all make the noise.
It is the shake reduction mechanism, the sensor is floating on its supports.
Nothing to worry about.
Enjoy your camera.
I like the way you describe the motion.
I think I will go wag my machine today.
That made my day Thanks!

(even the bigb sticker on the box does not help
12-14-2013, 12:36 AM   #18
Veteran Member




Join Date: Oct 2013
Posts: 402
My sony had shake reduction and it never made a rattling sound when moving it.
11-13-2016, 01:38 PM   #19
wtc
New Member




Join Date: Nov 2016
Posts: 1
Hi,

I know this is an older forum, but the question is still quite actual
Just got a used K50 camera from ebay (my first Pentax).
A cluching sound when wagging the camera - for me too, it doesn't matter if camera is on or off.
After some playing around - I finally found what it was, and this was NOT the image stabilization system. It was the battery!
Battery D-LI109 - at least in my unit - has ca. 0.5mm free room for movement to the sides, while lock switch looks ok. After opening the battery cover and holding the battery still, the clutching sound disappeared - once again, image stabilization system has no sound on my camera.
So question to you guys - can you check if it's the same for you?

11-13-2016, 01:44 PM   #20
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,944
QuoteOriginally posted by wtc Quote
Hi,

I know this is an older forum, but the question is still quite actual
Just got a used K50 camera from ebay (my first Pentax).
A cluching sound when wagging the camera - for me too, it doesn't matter if camera is on or off.
After some playing around - I finally found what it was, and this was NOT the image stabilization system. It was the battery!
Battery D-LI109 - at least in my unit - has ca. 0.5mm free room for movement to the sides, while lock switch looks ok. After opening the battery cover and holding the battery still, the clutching sound disappeared - once again, image stabilization system has no sound on my camera.
So question to you guys - can you check if it's the same for you?
The battery does have the slightest amount of wiggle room, but on my camera, the clip holds is tightly enough that it doesn't make any sound even when you shake the camera pretty hard.

I wouldn't be surprised if after a lot of use, the clip would wear out a bit and not hold the battery as tightly. You can probably put a piece of paper in between it and the battery if it's an annoyance.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Pentax DSLR makes a rattling noise - is it defective? Something is loose inside! Adam Maintenance and Repair Articles 4 01-18-2013 08:02 AM
One angle about the K5II I never hear... newmikey Pentax K-5 79 11-12-2012 10:04 AM
The sound you hear.... CMJRoss Pentax K-5 7 11-19-2011 07:51 AM
People Sorry dad, I can`t hear you Larsenio Post Your Photos! 6 10-07-2011 10:49 AM
If you want to see something creepy... sebberry Pentax K-5 3 06-22-2011 04:06 AM



All times are GMT -7. The time now is 02:23 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top