Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-16-2013, 07:40 PM   #1
New Member




Join Date: Dec 2009
Posts: 3
Firmware 1.05 Issue for K30

After upgrade, the horizontal and vertical level indicator stopped functioning. Is this a known problem with this firmware version ?
Finally I just downgrade again to 1.04 and everything works fine

10-16-2013, 07:42 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
This isn't a know issue as far as I'm aware. Are you sure the setting that enables the electronic level wasn't just reset?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-16-2013, 08:06 PM   #3
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 7,700
Fine on mine.
10-16-2013, 08:22 PM   #4
Site Supporter




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by jleonardi Quote
After upgrade, the horizontal and vertical level indicator stopped functioning. Is this a known problem with this firmware version ?
Finally I just downgrade again to 1.04 and everything works fine
How did you downgrade the firmware?

10-17-2013, 05:10 PM   #5
Veteran Member




Join Date: Oct 2013
Posts: 402
QuoteOriginally posted by IchabodCrane Quote
How did you downgrade the firmware?
Indeed. Is that even possible?
10-18-2013, 06:15 AM   #6
Veteran Member
treebeard's Avatar

Join Date: Nov 2008
Location: Windham, NH
Photos: Gallery | Albums
Posts: 795
QuoteOriginally posted by OldNoob Quote
Indeed. Is that even possible?
I have been on 1.05 since it came out and I have not had any issues with it.
10-21-2013, 06:39 PM   #7
New Member




Join Date: Dec 2009
Posts: 3
Original Poster
Thanks for the reply

Thanks all for the reply.
To answer the question about downgrade, the step is the same like upgrade.
10-23-2013, 11:21 AM   #8
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,464
I'd try the install a second time, making sure that the card you're using is freshly formatted in camera. It seems no one else here has reported any problems with the FW 1.05 install. My sense is that provides a slightly better low-lighting focusing capability compared to 1.04 with a slightly higher amount of slow focus hunt in extremely low light - instances where you got no AF response in the past. (This was based on some testing done when going from 1.04 to 1.05.)

10-25-2013, 07:07 AM   #9
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
Whats seems strange to me, is that firmware 1.05 is available on the Japan website, but the files are not found on the USA website, giving a dead link. Its as if the files were pulled due to a problem with the firmware.
10-25-2013, 07:40 AM   #10
Senior Member
bluenose's Avatar

Join Date: Jan 2012
Location: S. Ontario
Posts: 227
QuoteOriginally posted by tomwil Quote
Whats seems strange to me, is that firmware 1.05 is available on the Japan website, but the files are not found on the USA website, giving a dead link. Its as if the files were pulled due to a problem with the firmware.
When I clicked on your link the download page comes up with v1.04 at the top. Scroll down on that page and you will find v1.05

Regards
10-25-2013, 07:58 AM   #11
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
QuoteOriginally posted by bluenose Quote
When I clicked on your link the download page comes up with v1.04 at the top. Scroll down on that page and you will find v1.05
Have you actually clicked on the v1.05 links? I get "Not Found The resource could not be found", as if the files do not exist and have been pulled from the site.
10-25-2013, 08:29 AM   #12
Senior Member
bluenose's Avatar

Join Date: Jan 2012
Location: S. Ontario
Posts: 227
QuoteOriginally posted by tomwil Quote
Have you actually clicked on the v1.05 links? I get "Not Found The resource could not be found", as if the files do not exist and have been pulled from the site.
Sorry, I should have tried the actual download link instead of assuming that if it was there it would work.

Regards
10-25-2013, 03:18 PM   #13
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,464
In my experience, I would trust what's going on at HQ, not read much into what isn't properly linked at the Colorado outpost. If it had been offered and then pulled for a reason, the proper thing to do is explain - not just leave a dead link sitting there.
10-29-2013, 09:57 AM   #14
Junior Member
MaKettle's Avatar

Join Date: Jan 2008
Location: Lafayette Indiana
Posts: 28
What's going on with v1.05? I tried today to upgrade this version and still get the "resource could not be found" problem
10-29-2013, 10:53 AM   #15
Senior Member




Join Date: Jan 2009
Location: Watertown, NY
Posts: 267
QuoteOriginally posted by MaKettle Quote
What's going on with v1.05? I tried today to upgrade this version and still get the "resource could not be found" problem
Already installed v1.05 on mine try this link it's at the bottom of the page just make sure you download for the appropriate OS. I just tested the download to my desktop and it downloaded fine.

Latest K-30 Firmware Update : Software Downloads | RICOH IMAGING
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
firmware, k-30, k-50, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K30 freezing since firmware update 1.05 poziax Troubleshooting and Beginner Help 12 02-02-2014 05:00 PM
K5II V1.05 Firmware Update Problem moparjer Troubleshooting and Beginner Help 7 09-18-2013 01:11 AM
K-5 IIs firmware 1.03 improves tilt flash overexposure issue bjdavey Pentax K-5 11 03-11-2013 10:42 AM
Firmware updates for K30, K-01 and Q RKKS08 Pentax News and Rumors 4 10-29-2012 05:59 PM
Anyone noticed Pentax quietly update K200D firmware from 1.01.00.05 to 1.01.00.06? arm_jstp Pentax DSLR Discussion 10 09-23-2010 12:28 PM



All times are GMT -7. The time now is 01:15 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top