Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-02-2014, 09:45 AM   #46
Junior Member




Join Date: Apr 2014
Posts: 28
Well today I broke down and bought the Sigma 18-250. I'm on vacation at the beach this week and the hassle of carrying and changing lenes was enough to send me back to my room jump on my android and order it. There were even instances where I wanted to change lens and didn't because of the environment I was in at the time...No more and while I'm at it I'm getting an eye-fi card as well, any suggestions?

07-14-2014, 05:01 PM   #47
New Member




Join Date: Jun 2014
Location: Wildomar, CA
Photos: Albums
Posts: 5
Got to really put my new K-500 to use this past weekend and am very pleased. The crispness and colors in both moving and still objects really seemed to be so clear and defined compared to similar that I have taken in past years with my K100D. Not sure if it's just because of the difference in pixels or in the sensor or both. No post-processing other than I cropped a couple of the photos.









Attached Images
View Picture EXIF
PENTAX K-500  Photo 
View Picture EXIF
PENTAX K-500  Photo 
View Picture EXIF
PENTAX K-500  Photo 
View Picture EXIF
PENTAX K-500  Photo 
View Picture EXIF
PENTAX K-500  Photo 
08-09-2014, 04:14 PM   #48
New Member




Join Date: Apr 2014
Posts: 11
I recently bought a K-500 together with 18-55 kit lens. I like it, already went over the limits that the other (older) camera set, but there is an aspect related to it that can sometimes be annoying: it has some "sleep" mode, in which it enters immediately after I take a shot, or a few seconds after I navigated through the menus/taken shots. In this "sleep" mode, the display is turned off, and also the info which is displayed in the viewfinder when taking photos, is not shown. So it enters in this mode only when it is in standby mode, with the screen active, displaying shot parameters. It exits the sleep mode at any button press, or shutter half-press. I didn't find any setting for disabling this "feature". How could I get rid of it? A firmware update, maybe (it has have firmware 1.00)? I don't know yet if there is any warranty void because of this. Even with Auto Power Off set to Off, this still occurs. Ideas?

Last edited by z3n1th; 08-09-2014 at 04:43 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, impressions, k-30, k-50, k-500, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
Pentax K-500, first day impressions knaster Pentax K-30 & K-50 10 07-21-2013 04:08 AM
K-30 first impressions of a K-x user mee Pentax K-30 & K-50 10 03-02-2013 05:00 PM
K-30 First Impressions Coming from a K-x Sagitta Pentax K-30 & K-50 8 02-15-2013 01:50 AM



All times are GMT -7. The time now is 06:32 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top