Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-15-2013, 04:43 PM   #16
New Member




Join Date: Nov 2013
Posts: 14
Original Poster
Thanks for your reply.

Well, the white balance is not different, just a 1/10 speed difference and a purple tone difference on the white parts... When you watch the picture the difference is only coming from the different speed. The point is that at any speed, the purple is obvious on the K-500 (without cropping).


Last edited by juio; 11-16-2013 at 04:49 AM.
11-16-2013, 10:09 AM   #17
Veteran Member




Join Date: May 2012
Posts: 698
Something certainly is wrong there but it is most certainly not chromatic aberration.

I have a K-30, which is identical to the K-500 except for the weather sealing and different looks, and it does nothing of the sort so I would say your K-500 is most likely defective.

However before giving up on it try doing a factory reset as it could be simply some setting that is wrong.

After that, if the problem is still there please re-shoot those photos in Raw and post them (both with K-r and K-500). There may be some clues in the pictures and the exif data.
11-16-2013, 09:18 PM   #18
New Member




Join Date: Nov 2013
Posts: 14
Original Poster
QuoteOriginally posted by lister6520 Quote
Something certainly is wrong there but it is most certainly not chromatic aberration.

I have a K-30, which is identical to the K-500 except for the weather sealing and different looks, and it does nothing of the sort so I would say your K-500 is most likely defective.

However before giving up on it try doing a factory reset as it could be simply some setting that is wrong.

After that, if the problem is still there please re-shoot those photos in Raw and post them (both with K-r and K-500). There may be some clues in the pictures and the exif data.
Hello,

Yes, after having read many topics about chromatic aberrations, it seems it is not the problem. Unfortunately I've returned the K-500 and I don't have it anymore. Therefore ll' be taking pictures with my (good) old K-r, waiting for a good pentax kit...

I really can't understand this purple issue, As a Pentax user for more than 20 years I'm very disappointed. Maybe it was only my K-500 which was defective, I'll never know...

By the way I was really amazed by the pentaprism viewfinder, this is the functionnality I'll really miss as I use manual lenses (which are too hard to focus with the K-r's pentamirror).

I thank you all for your help.

Last edited by juio; 11-17-2013 at 06:11 AM.
11-20-2013, 04:35 PM   #19
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,223
You using Bright or Natural on your custom image settings on your K500 ?
Also to me it appears your Exposure seems different between the two. The K500 appears somewhat darker... Did you shoot both cameras at the same exact settings?

11-22-2013, 12:13 PM   #20
Veteran Member




Join Date: Jul 2010
Photos: Gallery | Albums
Posts: 573
I'm thinking it's a focus issue. Many times on one side of the field of focus you'll have purple fringing and on the other side you'll get green fringe. That lower example (kr I think) that looks blacker, definitely seems to have some green to the bottom line. The bottom picture here demonstrates what I mean.

Nikkor AF 85mm f/1.4 D (FX) - Review / Test Report - Analysis I think the k-r focuses more accurately, but slightly one way and the k500 less accurately and more the other way.
02-03-2014, 02:38 AM   #21
New Member




Join Date: Jan 2014
Posts: 9
Same thing here

Ive noticed the same thing. I recently purchased a k-500 and ive given my daughter my old k-r. Yesterday we were taking photos of ducks at a local park both using the same lens and the ca was terrible on the k500 yet fine on the kr. I assumed that there was an issue with my copy of the lens but after swapping them over i had the same issue. Is my k500 faulty or is this an issue with all k500?
Not happy about spending 350 on a downgrade.
Any1 else having issues?
02-04-2014, 06:23 AM   #22
New Member




Join Date: Jan 2014
Posts: 9
Its faulty

Sent some pictures to Clifton cameras where i bought the k-500 from and they in turn forwarded the images to pentax repair folks and they agree there is an issue with the sensor.
Not a lens issue. If it were it would not be visible with every lens i own and if it were the lenses the K-R would at least show SOME evidence of the problem, which it doesn't.
Will post example pics when i get 5.
Laters people.
08-29-2014, 12:49 PM   #23
New Member




Join Date: Nov 2013
Posts: 14
Original Poster
Hello Gary,

Did you keep your K500? Have you sent your k500 to pentax for repair?
Does it work fine now?

I may think of buying a k500 again if you confirm me you only got a defective model and that everything is ok now.

Thanks.

08-30-2014, 08:46 AM   #24
csa
Loyal Site Supporter
csa's Avatar

Join Date: Aug 2014
Location: Montana mountains
Posts: 8,348
This problem is troubling to me, as the K500 is the one I plan on purchasing in a few months. Anyone else here that does/does not have this problem? I'm assuming it could also be the same in the K50?
09-02-2014, 10:33 PM   #25
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,478
It seems to me that we are seeing a relatively minor lens issue. I see at least as much green fringe in the KR shot as purple fringe in the K500 shot. I wouldn't come to any strong conclusions until shooting more lenses and in a variety of situations. Oddly enough, in my newer bodies with 16mp sensors I have noticed a tendency of some older, good lenses sharpening up in ways I wouldn't expect, and some less expensive newer lenses showing more of their faults (even the primes). The 35mm lenses (including my FA) seem to have some fringing issues. I try to avoid anything more open than about f/4 with the FA35.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aberration, cameras, issue, k-30, k-50, k-500, k500, k500 chromatic aberration, kr, pentax k30, pentax k50, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chromatic aberration on a 77mm Limited? magic.pill Pentax SLR Lens Discussion 10 06-25-2013 01:04 PM
Chromatic aberration at close range jido Troubleshooting and Beginner Help 13 01-21-2013 12:57 PM
Tackling Lateral Chromatic Aberration Vote4Pedro Troubleshooting and Beginner Help 6 12-30-2012 07:16 PM
Chromatic Aberration!? and what to do with it marcusBMG Digital Processing, Software, and Printing 15 12-26-2012 02:50 PM
Linux chromatic aberration correction russell2pi Digital Processing, Software, and Printing 8 09-10-2012 05:45 AM



All times are GMT -7. The time now is 12:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top