Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-24-2013, 09:15 AM   #1
New Member




Join Date: Aug 2013
Posts: 7
k50 manual m42 lens

hi i am testing a helios 50mm f2 but i can't take a reading for speed shutter with the green key... i am not sure what can i do, i don't want take photos in Av mode i prefer M mode

any idea????


thanks

11-24-2013, 10:44 AM   #2
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Maybe this helps (not sure if you've read it already)

https://www.pentaxforums.com/forums/58-pentax-beginners-corner-q/110658-using...x-dslrs-f.html
11-24-2013, 11:48 AM   #3
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,863
Here is another thread about this:
https://www.pentaxforums.com/forums/54-pentax-lens-articles/110657-how-use-me...k-x-k-7-a.html
Basically, you need to go to menu, enable aperture ring (at the very end of menu), then you go into M mode and select the aperture on the lens. ISO should be constant (not auto iso), and when you press green button, the camera will stop down the lens to selected aperture, meter, and adjust the shutter speed. Any mode other than M will default to Av. Av mode will always shoot wide open, but it allows auto-ISO and it meters continuously (you don't need green button).
With the m42 Helios you mentioned, the camera cannot move the aperture at all. It is a preset aperture, so you need to lock it and close it yourself, by hand. This is a little tricky with the Helios, because the written number is actually the opposite of what you have selected. I suggest you look into the lens while stopping down to figure out which end is wide open and stuff. With this lens, you can just keep the camera in Av mode, focus wide open, and then stop down the lens and take a shot. The metering will be continuous, because Av. M mode only turns off auto-metering with this type of lens. Feel free to experiment with Sunny 16 and other exposure rules.
Always focus wide open (at f2.0 in your case) because DoF is thinnest at that aperture and the focusing should be most accurate.
11-24-2013, 12:21 PM   #4
Pentaxian
Kozlok's Avatar

Join Date: Jun 2012
Location: Albuquerque
Photos: Gallery
Posts: 1,790
My guess is the K50 firmware isn't working right. The K30 isn't. I wrote to Pentax about this, and they are aware. Not sure when they will fix it though! My suggestion is to write an e-mail to Pentax and complain.

Here's my thread on the subject: Super Tak Metering Problem

11-24-2013, 07:29 PM   #5
Site Supporter
6BQ5's Avatar

Join Date: Jun 2013
Location: Nevada, USA
Photos: Albums
Posts: 3,109
Green button is useless for me too. I just use Av mode and I have learned when/where to use exposure compensation. Use your histogram and select the right metering type to learn any exposure quirks. It sounds bad but it all works fine.
11-24-2013, 10:49 PM   #6
New Member




Join Date: Aug 2013
Posts: 7
Original Poster
the procedure( with the aperture ring and the green botton) works fine with K mount lens i have a auto chinon 50mm and works great, but i have this incredible Helios and in some sites i look that someone shortcut the contacts but i am not sure how to do that, i am want to break my new K50
02-01-2014, 11:02 PM   #7
New Member




Join Date: Aug 2013
Posts: 7
Original Poster
Hi i fix it..... i just put some aluminum tape in the base of the lens and it work's great if someone need help send me a pm
02-02-2014, 12:52 AM   #8
New Member




Join Date: Apr 2012
Posts: 16
QuoteOriginally posted by Kozlok Quote
My guess is the K50 firmware isn't working right. The K30 isn't. I wrote to Pentax about this, and they are aware. Not sure when they will fix it though! My suggestion is to write an e-mail to Pentax and complain.

Here's my thread on the subject: Super Tak Metering Problem

They know about it?


They have a funny way of showing it. They are telling me to send in my new K50 to the UK service centre to have this checked out!

02-02-2014, 07:53 AM   #9
Senior Member




Join Date: Dec 2013
Posts: 109
QuoteOriginally posted by fquito Quote
Hi i fix it..... i just put some aluminum tape in the base of the lens and it work's great if someone need help send me a pm
Huh how does putting aluminium tape help? Please enlighten me
02-02-2014, 09:23 AM   #10
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
It shorts the contacts on the camera. So now the camera thinks it's an K or M lens and you can use the green button metering. The other advantage is that you can use CIF.
03-13-2014, 07:37 PM   #11
New Member




Join Date: Aug 2013
Posts: 7
Original Poster
you can buy an aluminium tape...

---------- Post added 03-13-14 at 07:41 PM ----------

now i have another problem, how i can look the EV meter ?
03-13-2014, 09:49 PM   #12
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by alwaysjerricky Quote
Huh how does putting aluminium tape help? Please enlighten me
QuoteOriginally posted by sterretje Quote
It shorts the contacts on the camera. So now the camera thinks it's an K or M lens and you can use the green button metering. The other advantage is that you can use CIF.
The only hazard is that you may lose infinity focus if the tape has much thickness.


Steve
03-14-2014, 10:53 AM   #13
New Member




Join Date: Apr 2012
Posts: 16
QuoteOriginally posted by fquito Quote
you can buy an aluminium tape...


I can, but I shouldn't have to.
I didn't have to with K200d or *ist DL2.
Pentax tell me this should work without aluminium tape.
03-14-2014, 11:04 AM   #14
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by Fluke Quote
Pentax tell me this should work without aluminium tape.
How did they tell you that? Email? User manual?
03-14-2014, 05:09 PM   #15
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by Fluke Quote
Pentax tell me this should work without aluminium tape.
Pentax is telling you without knowledge.


Steve
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-30, k-50, k50, k50 manual m42, m42, mode, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a manual m42 mount lens with a stuck aperture be fixed? Vantage-Point Pentax SLR Lens Discussion 3 09-15-2011 08:54 PM
How to fix a auto-only M42 lens so it becomes a manual one sterretje Pentax SLR Lens Discussion 5 05-16-2010 10:12 PM
Help K50/f1.2 lens quyi419 Pentax SLR Lens Discussion 22 07-08-2008 01:08 AM
Question About Auto/Manual Switch on Vivitar M42 Lens zx-m Pentax SLR Lens Discussion 2 06-11-2008 06:49 PM



All times are GMT -7. The time now is 06:22 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top