Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-02-2014, 11:41 AM   #1
Pentaxian




Join Date: Sep 2013
Location: Phoenix, AZ
Photos: Albums
Posts: 658
K30 pop up flash stopped working?

Anyone have any ideas how I can start getting it to work again? I'd like to have it working so I can trigger off camera strobes with it or in case I ever need a flash in an emergency. I have the latest firmware installed, and my Yongnuo 460ii flash will fire from the hot shoe just fine, but when I deploy the pop up flash I am not getting the flash symbol in the viewfinder and it won't flash anymore! Might I add that it will still intermittently work at times so the bulb is not burnt out, but it doesn't work 95% of the time now.


Last edited by stillshot2; 02-02-2014 at 04:25 PM. Reason: Added more info
02-02-2014, 12:12 PM   #2
Senior Member




Join Date: Nov 2012
Location: Dundee Illinois
Photos: Gallery
Posts: 103
My flash stopped working on my K-30 as well. When I try to use it the camera indicates not enough battery and shuts down, even with a fully charged battery. I have an external flash I use instead.
02-04-2014, 07:02 PM   #3
Pentaxian




Join Date: Sep 2013
Location: Phoenix, AZ
Photos: Albums
Posts: 658
Original Poster
That's not good to hear. My K30 still had a month left on its warranty so I sent it back in for replacement. Hopefully this isn't a problem with all K30's since I only used the flash probably less than 50 times. If it goes out again I suppose I will have to buy a hotshoe trigger like I eventually plan on doing anyways.
02-05-2014, 01:07 AM   #4
Veteran Member




Join Date: Oct 2013
Posts: 402
welcome to the world of the k-30

03-05-2014, 08:04 AM   #5
Senior Member
Lokusart's Avatar

Join Date: Sep 2013
Location: Algarve
Posts: 173
I've been reading many issues with the K-30 in particular, mine is now on service repair due to a weird problem with exposures. I think QC was lacking with this one. My camera is only 2 months old.


QuoteOriginally posted by OldNoob Quote
welcome to the world of the k-30
I know what you mean

Last edited by Lokusart; 03-05-2014 at 09:35 AM.
03-05-2014, 09:22 AM   #6
Pentaxian




Join Date: Sep 2013
Location: Phoenix, AZ
Photos: Albums
Posts: 658
Original Poster
Does the K50 have all these issues worked out? I hear it's basically a K30 in a new shell so I think I may have to wait for a good price on a used K3
03-05-2014, 09:33 AM   #7
Senior Member
Lokusart's Avatar

Join Date: Sep 2013
Location: Algarve
Posts: 173
QuoteOriginally posted by stillshot2 Quote
Does the K50 have all these issues worked out? I hear it's basically a K30 in a new shell so I think I may have to wait for a good price on a used K3
I haven't found so much people complaining with it as I found with the K-30, I hope they did it right with the K-50
03-05-2014, 09:37 AM   #8
Veteran Member
magkelly's Avatar

Join Date: May 2010
Photos: Gallery
Posts: 5,905
Sounds like what happened with the *ist DL's? I've seen two now, no flash, but the hot shoe works.

03-05-2014, 09:42 AM   #9
Senior Member
Lokusart's Avatar

Join Date: Sep 2013
Location: Algarve
Posts: 173
QuoteOriginally posted by magkelly Quote
Sounds like what happened with the *ist DL's? I've seen two now, no flash, but the hot shoe works.
that's very bad, specially on cameras that like to portray reliability. Not destroyed by environment but by itself
03-05-2014, 01:48 PM   #10
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by stillshot2 Quote
That's not good to hear. My K30 still had a month left on its warranty so I sent it back in for replacement. Hopefully this isn't a problem with all K30's since I only used the flash probably less than 50 times. If it goes out again I suppose I will have to buy a hotshoe trigger like I eventually plan on doing anyways.
By chance were you shooting in Green mode? In that mode, the flash will only fire if it thinks the image needs it regardless of whether you have deployed.
03-05-2014, 06:14 PM   #11
Pentaxian




Join Date: Sep 2013
Location: Phoenix, AZ
Photos: Albums
Posts: 658
Original Poster
QuoteOriginally posted by IchabodCrane Quote
By chance were you shooting in Green mode? In that mode, the flash will only fire if it thinks the image needs it regardless of whether you have deployed.


I only use manual mode, and even tried just about every mode before I sent it away. Hot shoe still worked fine though. Probably a faulty capacitor somewhere for the pop up flash. I never rely on a pop up flash but it makes me wonder how well the rest of the K30 is built. I switched from Sony to Pentax thinking that Pentax DSLR's were indestructible (and the fact Sony quit making OVF's) but now I'm not too enthusiastic hearing that the K30 may have other issues. The last thing I want to do right now is switch camera systems again!
03-06-2014, 05:11 AM   #12
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by stillshot2 Quote
I only use manual mode, and even tried just about every mode before I sent it away. Hot shoe still worked fine though. Probably a faulty capacitor somewhere for the pop up flash. I never rely on a pop up flash but it makes me wonder how well the rest of the K30 is built. I switched from Sony to Pentax thinking that Pentax DSLR's were indestructible (and the fact Sony quit making OVF's) but now I'm not too enthusiastic hearing that the K30 may have other issues. The last thing I want to do right now is switch camera systems again!
If it helps... I was one of the first to buy a K-30 in the summer of 2012 and apart from the rare lock-up, it's been rock solid.
03-11-2014, 04:57 AM   #13
New Member




Join Date: Mar 2014
Posts: 5
My popup flash stopped working too, I rarely use it but I was on a night carnaval and used it maybe 30 times before it refused to work...

Is there a manual service for the K-30, or a repair parts list we could use ?
03-11-2014, 05:31 AM   #14
Senior Member
Lokusart's Avatar

Join Date: Sep 2013
Location: Algarve
Posts: 173
QuoteOriginally posted by agukha Quote
My popup flash stopped working too, I rarely use it but I was on a night carnaval and used it maybe 30 times before it refused to work...

Is there a manual service for the K-30, or a repair parts list we could use ?
very bad when that happens, I see that flash issue is becoming a trend on the K-30.

Try contacting the people who sold you the camera, if it's still on warranty you better use it. Or send an email to Pentax asking for the best place to send the camera.
03-11-2014, 03:36 PM   #15
Site Supporter
RGlasel's Avatar

Join Date: Sep 2013
Location: Saskatoon
Photos: Gallery | Albums
Posts: 1,345
QuoteOriginally posted by stillshot2 Quote
it will still intermittently work at times so
If you take 20 shots in a row of the same scene without changing any settings, will the flash fire at least once? Can you get the flash to work (albeit intermittently) in some of the automated shooting modes? A repair depot can use that kind of information to help determine the cause of your problem, and it will help to prevent the situation where the repairperson changes a setting, it then works once or twice and the camera is returned to you without fixing anything.
QuoteOriginally posted by Lokusart Quote
I see that flash issue is becoming a trend on the K-30
I've had a K-30 for 20 months; taken it with me on a ski-hill, trekking in the jungle, the Caribbean in the summer, a football game in the winter, and have had zero problems. Anecdotal trends on an Internet discussion forum have no correlation to design flaws or quality control of anything. Every manufactured object has the potential to fail at any time. Looking for trends in random events does nothing to prevent such failures or to remedy them.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, k-30, k-50, k30 pop, pentax k30, pentax k50, pop, pop up flash
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r: built-in flash stopped working after using external flash wedge Troubleshooting and Beginner Help 7 01-12-2014 07:57 PM
K30 Pop Photo gallery images up schufosi777 Pentax K-30 & K-50 10 06-25-2012 12:14 AM
Pop up flash not working NaClH2O Pentax K-5 12 05-30-2012 07:58 AM
K20D Pop Up Flash Stopped Working phatty Pentax DSLR Discussion 1 03-10-2011 09:14 AM
*istDL DOF Preview not working & Slow flash pop up. auspentax Pentax DSLR Discussion 3 07-07-2010 07:07 AM



All times are GMT -7. The time now is 01:16 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top