Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-06-2014, 04:18 PM   #1
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Problem With K30 Firmware 1.06 Update

Okay, I've been a bit lazy and haven't updated the firmware to the latest versions until today. I just successfully updated my K-5 and K-01 without a problem. But it just doesn't seem to be happening with my K-30.

I successfully downloaded file fwdc215b to my computer (a Mac) and then transferred it to a SDHC card that was formatted in the camera. I properly ejected the card from the computer, installed it in the camera and turned the camera on. But when I go to setup tab and firmware option in the menu, it shows the camera has firmware 1.00 (yes, I've been bad with the K30, the camera I use the least often) and there is no option to update to a new version.

I've tried reformatting the card and going through this procedure five times. I have downloaded the file from both the link on Pentax Forums and directly from the Ricoh Pentax site. And, yes, I used the Mac version. Has anyone had this problem? Any suggestions?


Last edited by Biro; 04-06-2014 at 04:37 PM.
04-06-2014, 04:38 PM   #2
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
You've unzipped the file before moving it to your SD card?

You're not mentioning going through the firmware update process either. (hold menu while power up with unzipped bin file on the root of the SD card). It should give you a "firmware update successful" if it works.

My K5 won't update unless it has a decent charge in the battery, how is your K-30 battery?
04-06-2014, 04:47 PM   #3
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,190
Sorry just came to add that it worked fine on my K-30

Good luck with yours, as above, check all the basics too
04-06-2014, 04:50 PM   #4
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
QuoteOriginally posted by fgaudet Quote
You've unzipped the file before moving it to your SD card?

You're not mentioning going through the firmware update process either. (hold menu while power up with unzipped bin file on the root of the SD card). It should give you a "firmware update successful" if it works.

My K5 won't update unless it has a decent charge in the battery, how is your K-30 battery?
That's not the process for the K30... that's the process for the K5, which is different. And I can't even go through the firmware update process. There is no option to do so when I go to the firmware options page in menu. But I have fresh lithium-ion batteries in the camera. Perhaps I must have the Li-109 in it instead? That still doesn't sound right because the K-5 and K-01 will present the update selection screen to you. If the battery is too low, you'll get a message that is the case.


Last edited by Biro; 04-06-2014 at 05:05 PM.
04-06-2014, 05:03 PM   #5
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
Have you tried re-downloading the zip file? or try another SD card?

You probably read it already but this is what the update help file has to say when the options aren't available:

"*If firmware file is not saved to SD card correctly, this screen will not be displayed."
04-06-2014, 05:21 PM   #6
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
QuoteOriginally posted by fgaudet Quote
Have you tried re-downloading the zip file? or try another SD card?

You probably read it already but this is what the update help file has to say when the options aren't available:

"*If firmware file is not saved to SD card correctly, this screen will not be displayed."
Yes, I've tried a second card. Either there's something wrong with the file (not likely since others have successfully used it) or there's something wrong with the camera. I'm going to have to contact Ricoh Pentax. I've never had a problem updating the firmware on any camera before.
04-06-2014, 05:30 PM   #7
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
one last thing you could do is try to update to V1.01 (if you can find it) and work your way up to 1.06
04-06-2014, 06:56 PM   #8
Pentaxian
ScooterMaxi Jim's Avatar

Join Date: Jul 2009
Location: Minnesota
Posts: 1,501
Off hand, I would try two possible issues. If possible, go the Windows route. Second, I'd be curious about the two SD cards. If they both happen to be Sony cards - well, the K-30 and the odd Sony architecture do not get along.

By the way, getting away from the K-30 1.0 firmware will make a world difference no matter what newer version you ultimately implement.

04-06-2014, 07:04 PM   #9
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
I appreciate all of the feedback. Both cards were SanDisk Extreme. I also tried to start with firmware version 1.01 - but all updates on the Ricoh Pentax page take you to version 1.06. This is strange. I've never had firmware update problems before. I've send Ricoh Pentax a message via their customer service page. Good thing the camera is still under warranty. And I have an extended warranty.
04-06-2014, 08:05 PM   #10
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
I remember reading not that long ago here on the forum someone had problems updating his K-01... It turned out he only needed to rename the file name... Maybe try getting rid of the B at the end of the file (fwdc215.bin)

Always worth a try...
04-06-2014, 10:04 PM   #11
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,190
I try to use smaller slower older basic cards also, if that's of any use?
04-06-2014, 10:35 PM   #12
Veteran Member




Join Date: Mar 2007
Location: U.K.
Posts: 685
Are you copying the fwdc215b.bin file directly to the root of the SD card? It won't work if you have it in any folder.
04-07-2014, 04:09 AM   #13
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
Original Poster
QuoteOriginally posted by SteveB Quote
Are you copying the fwdc215b.bin file directly to the root of the SD card? It won't work if you have it in any folder.

I'm pretty sure I am. I completely formated the card in the camera before downloading the file. It worked perfectly with my K-5 and K-01 only minutes earlier. Perhaps I should try renaming the file or trying with the Windows version of the file. But that'll have to wait until tonight.
04-07-2014, 01:53 PM   #14
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
unzip it and put it in the root of the card .that means no folder

---------- Post added 04-07-14 at 04:55 PM ----------

one more thought maybe you downloaded a corrupt file try downloading it again.
04-07-2014, 02:52 PM   #15
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
QuoteOriginally posted by Biro Quote
I completely formated the card in the camera before downloading the file. It worked perfectly with my K-5 and K-01 only minutes earlier.
Another stupid question but did you get rid of the other *.bin files (the ones for the K5 and K01)?

Maybe the K-30 doesn't like seeing more than one bin
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, computer, firmware, k-30, k-50, k30, k30 firmware, option, pentax k30, pentax k50, software, switch, update
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K30 freezing since firmware update 1.05 poziax Troubleshooting and Beginner Help 12 02-02-2014 05:00 PM
Firmware Update V1.06 for K-5II/K-5IIs Class A Pentax News and Rumors 46 10-27-2013 04:45 PM
K30 firmware update houseofstyles Pentax K-30 & K-50 3 07-20-2013 06:39 AM
firmware update for 06, is there one? volosong Pentax Q 12 04-18-2013 01:53 AM
Anyone noticed Pentax quietly update K200D firmware from 1.01.00.05 to 1.01.00.06? arm_jstp Pentax DSLR Discussion 10 09-23-2010 12:28 PM



All times are GMT -7. The time now is 05:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top