Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-15-2014, 03:20 PM   #1
Junior Member




Join Date: Nov 2013
Posts: 45
K-30 weird problem

Hi there,

Today, I wanted to change the lens on my k-30 that I realized a weird noise. It seems that quite a bulky part inside the camera is moving to the left and right. When I rotate the camera left-side up the then right-side up, I can hear a noise and I can even feel that something is moving. This is not something normal, I guess. When I select the "mirror up" option from the sensor cleaning menu item, the part doesn't move anymore, So, it seems that it must be something related to mirror. The camera takes photos with no issue!

Have you ever had such a problem or do you have any idea about it?

Thanks.

05-15-2014, 03:23 PM   #2
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,618
https://www.pentaxforums.com/forums/120-general-technical-troubleshooting/941...ntax-dslr.html
05-15-2014, 03:34 PM   #3
Junior Member




Join Date: Nov 2013
Posts: 45
Original Poster
Thank you Parallax for the quick response. But I am not convinced yet

This is quite a heavy part and something that I have never noticed before. The moving is such apparent that if it was so from the beginning (about 6 month ago that I bought the camera), I should have realized it before, shouldn't I? Can it be a fault with the camera then?
05-15-2014, 03:36 PM   #4
Senior Member
delegopa's Avatar

Join Date: Apr 2013
Posts: 244
As seen in the Link above the noise is due to the Shake Reduction Technology. This got me wondering too, when I began using my K-30.
It is also the Pentax signature sound leading lots of worried fresh Pentaxians to this forum

05-15-2014, 04:19 PM   #5
Junior Member




Join Date: Nov 2013
Posts: 45
Original Poster
Thanks delegopa. Now, I am better
05-15-2014, 05:34 PM   #6
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
Be worried if you don't hear/feel it when the camera is off


05-15-2014, 06:05 PM   #7
Veteran Member
JimC1101's Avatar

Join Date: Aug 2010
Location: Fremont, Ca
Photos: Albums
Posts: 393
Ok but why does his mirror lock up for cleaning not work ? If you choose mirror lock up, it should go up unless your batteries are too low but you will get a warning notice from inside your LCD. If it were not for the fact that you said you can not raise your mirror, I would think SR also, but if I were you, I would check it, without lens on the cam, look at the mirror and see if it is going up when in sensor cleaning option occurs.
05-15-2014, 06:41 PM   #8
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
Are you sure that's what the OP said?

05-15-2014, 06:47 PM   #9
Veteran Member
JimC1101's Avatar

Join Date: Aug 2010
Location: Fremont, Ca
Photos: Albums
Posts: 393
Well, when he said he selected mirror up, the part doesn't move anymore. I could be wrong but he seems to be saying that his mirror is not moving in MLU.




"When I select the "mirror up" option from the sensor cleaning menu item, the part doesn't move anymore, So, it seems that it must be something related to mirror. The camera takes photos with no issue!
05-15-2014, 10:01 PM   #10
Junior Member




Join Date: Nov 2013
Posts: 45
Original Poster
QuoteOriginally posted by JimC1101 Quote
Well, when he said he selected mirror up, the part doesn't move anymore. I could be wrong but he seems to be saying that his mirror is not moving in MLU.

"When I select the "mirror up" option from the sensor cleaning menu item, the part doesn't move anymore, So, it seems that it must be something related to mirror. The camera takes photos with no issue!
Sorry for the confusion. Actually, the mirror up works fine. When the mirror is up, the movement is stopped. That was why I guessed the noise might be related to mirror, which was a wrong guess. I think, when the mirror is up, the shake reduction systems locks the sensor to prevent sensor movements while cleaning it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-30, k-50, mirror problem, noise, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 battery problem KnightGirl Troubleshooting and Beginner Help 7 09-07-2013 07:56 PM
k-30 focus problem mtkang Pentax K-30 & K-50 19 06-02-2013 12:49 PM
Weird problem with my K-5 treebeard Pentax K-5 13 03-02-2013 08:02 AM
My k-30 have problem? mengazaa Pentax K-30 & K-50 19 11-10-2012 06:42 AM
Weird AF/shutter release problem (K-10D) nostartnoend Pentax DSLR Discussion 3 12-06-2011 08:19 PM



All times are GMT -7. The time now is 10:20 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top