Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-30-2014, 04:24 PM   #16
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
QuoteOriginally posted by Tako Kichi Quote
Try formatting the card in the camera, the K-30 may not like the formatting done by another camera.

If you have shots on the card from the other camera save them to your computer first before formatting!

OK. I am trying to go through the manual here. How do I format?

---------- Post added 05-30-14 at 07:32 PM ----------

I went to Setup Menu 3 > Format, and selected Format but it still give me the same error. It just won't format.

Memory Card Error

05-30-2014, 04:33 PM   #17
Site Supporter
Tako Kichi's Avatar

Join Date: May 2013
Location: SW Ontario, Canada (ex-pat Brit)
Posts: 1,013
The instructions for SD card formatting are on page 219 in the manual.

---------- Post added 30th May 2014 at 19:59 ----------

QuoteOriginally posted by haviet Quote
I went to Setup Menu 3 > Format, and selected Format but it still give me the same error. It just won't format.

Memory Card Error
Are you sure you haven't accidentally moved the 'write protect' slide on the card? See this site for info on how to check for memory card errors.

Simple Fixes for SD "Memory Card Locked" or "Memory Card Error" |Do It Yourself Digital Camera Repair
05-30-2014, 05:11 PM   #18
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
QuoteOriginally posted by Tako Kichi Quote
The instructions for SD card formatting are on page 219 in the manual.

---------- Post added 30th May 2014 at 19:59 ----------



Are you sure you haven't accidentally moved the 'write protect' slide on the card? See this site for info on how to check for memory card errors.

Simple Fixes for SD "Memory Card Locked" or "Memory Card Error" |Do It Yourself Digital Camera Repair

Yes, I just followed the instrucions on p.219 of the manual.

And no, the card is not locked

I just plugged this SD card into my PC and it reads the card perfectly.

I even reformatted the card from my PC, and try to insert it back into the camera after formatting and still give me the same error.

This is the first time I ever encounter anything like this. Very strange.

---------- Post added 05-30-14 at 09:00 PM ----------

The camera fw is 1.0. Not sure if that could be an issue

---------- Post added 05-30-14 at 09:01 PM ----------

And I can't update fw if it doesn't read the card.
05-30-2014, 06:40 PM   #19
Site Supporter
RGlasel's Avatar

Join Date: Sep 2013
Location: Saskatoon
Photos: Gallery | Albums
Posts: 1,244
I would suggest getting a different SD card to try. I could tell you to get a brand new class 10 card, check the Interface setting (pg 229 in the manual), etc. but I just finished swapping out my regular card with an 8 year old 1GB card, without turning the camera off, changing the USB setting to PTP and back to MSC, and it didn't miss a beat. It's more important to verify that the SD card isn't the problem, and you can worry about burst rates and such once you have the camera working.

For updating firmware, Pentax recommends using a different memory card anyway, so perhaps that's another reason to try another memory card.

05-30-2014, 06:43 PM   #20
Banned




Join Date: Feb 2013
Posts: 390
I had that problem as well with PNY cards. Updating the f/w helped, it still happens once in a blue moon but usually shutting the camera down and waiting a few seconds for it to shut off, then giving it a couple of seconds before I try anything after turning it back on again will clear it, that or re-inserting it. My Transcend and SanDisk cards, though older, have not given me any errors at all. I have a vague memory of a discussion on this forum about Pentax cameras preferring certain brands of cards. Try a different brand , see if that helps.
05-30-2014, 07:19 PM   #21
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
At this point, it's got to be some sort of compatibility things with Pentax, and I can understand that. This card works with my PC, it works with my other camera. But it just won't work with Pentax. It's a Sony class 10 card that is 2 months old. My Android tablet seems to prefer Scandisk brand for some reasons, so I am not suprise if Pentax works well with certain particular brands of SD.

I am going to order a Lexar Professional 600x card and see if that brand works.
05-30-2014, 08:48 PM   #22
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
Problem solved.

I was able to find an old Sandisk 2GB laying around. I use this card to do the fw update. The camera seems to read this card just fine.

After updating to fw 1.06, it now can read my Sony 32Gb SD card. Everything is working.
05-30-2014, 09:03 PM   #23
Site Supporter
Tako Kichi's Avatar

Join Date: May 2013
Location: SW Ontario, Canada (ex-pat Brit)
Posts: 1,013
Glad you got it fixed, it was starting to make me scratch my head as the problem went on.

05-30-2014, 09:12 PM   #24
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
Lol. Little things like this can make you scramble for hours. I guess it was probably the old fw that couldn't handle the newer sdhc cards.

---------- Post added 05-31-14 at 12:19 AM ----------

Glad I didn't have to buy another SDHC card. Now I can use some of that money to order myself a prime lens. DA 35mm f2.4. The prime lens should be here by Tuesday.
05-31-2014, 12:06 PM   #25
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
Custom Image?

What does everyone use? I just started using Natural, but this setting my my RAW images a little muted. I am thinking I should set it to Portrait since I mainly shoot kids and family.

I just wish LR5 allows me to play more with these settings in Camera Calibration, but they're not available.
05-31-2014, 03:21 PM   #26
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,221
QuoteOriginally posted by haviet Quote
Custom Image?

What does everyone use? I just started using Natural, but this setting my my RAW images a little muted. I am thinking I should set it to Portrait since I mainly shoot kids and family.

I just wish LR5 allows me to play more with these settings in Camera Calibration, but they're not available.
Those settings do not work with Raw files only Jpeg... Raw image may seem dull as the camera doesn't apply any sharpening, noise reduction or color processing to the image but will have greater bit depth and more color information to work with than if you were to use jpeg. You will need to adjust for any of that with your processing software.

If you use Adobe bridge first, if you have it, prior to opening a jpeg in Lightroom. By using Control R on a jpeg in bridge it will open in Adobe ACR and will have almost the same adjustments as on a raw image but with less color info and bit depth to work with.
05-31-2014, 03:36 PM   #27
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
QuoteOriginally posted by Oldbayrunner Quote
hose settings do not work with Raw files only J

Thanks Oldbayrunner.

Do you know why in LR5, under Camera Calibration I have only two options (Standard and Embedded)?
05-31-2014, 03:59 PM   #28
Site Supporter
RGlasel's Avatar

Join Date: Sep 2013
Location: Saskatoon
Photos: Gallery | Albums
Posts: 1,244
QuoteOriginally posted by haviet Quote
under Camera Calibration I have only two options
You have some manual options. Below Profile: Embedded or Standard, there are sliders for Shadows, Red Prmary, Green Primary and Blue Primary. You can save your manual settings as a Develop preset to be applied to all of your shots from that camera. It seems to also be possible to import custom camera calibrations, so if someone points you to custom profiles for the K-30 you could try that, if you consistently don't like Adobe's standard profile for the K-30. If you want to adjust the hue and saturation for some pictures, but not all, then you might want to use the other tools instead of continually changing your camera profile. The standard profile is set using colour targets at specific colour temperatures, and most of my own efforts to adjust colour have ended badly, so I don't use this feature myself.
05-31-2014, 04:17 PM   #29
Forum Member




Join Date: May 2014
Posts: 70
Original Poster
Thanks RG.

I was used to seeing more options under the Camera Calibration with my Olympus m43 camera. Besides Adobe, Standard, Embedded, I would also see Vibrant, Potrait, Natural, Muted, etc.

I am curious why I only have two options with Pentax camera.
06-01-2014, 03:55 AM   #30
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,221
Here this explains it pretty well Adobe Photoshop Lightroom 4 * Adjust the color calibration for your camera

Some cameras will add different profile adjustments others won't. With Pentax I find switching from Adobe Standard to Embedded usually suffices. However you can create or find additional camera profiles using DNG Profile editor Camera raw, DNG | Adobe Photoshop CC

I don't use Lightroom as I have always used Photoshop CS and recently changed from CS6 to Photoshop CC so I am more used to working in ACR.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, error, flickr, format, fw, k-30, k-50, lens, manual, memory, page, pc, pentax, pentax k30, pentax k50, pm, post, review, sd, sd card, sdhc, settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Pentax k-30 owner awesome 63 Welcomes and Introductions 12 12-03-2013 05:46 PM
New K-30 owner tjo7558 Welcomes and Introductions 4 09-23-2013 01:12 AM
New K-30 owner Anna2324 Welcomes and Introductions 6 08-07-2013 03:53 AM
New K-30 owner here tylerherring Welcomes and Introductions 2 12-27-2012 05:27 AM
New K-30 owner from Calgary BurningChrome Welcomes and Introductions 10 10-12-2012 04:16 PM



All times are GMT -7. The time now is 06:59 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top