Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-29-2014, 11:30 AM   #1
Veteran Member
JimC1101's Avatar

Join Date: Aug 2010
Location: Fremont, Ca
Photos: Albums
Posts: 393
No tally light with AF.C ?

I was using my K-30 last night and when in AF.S in a dark area, the tally light, focus assist (green) light for those who do not know it, was illuminated as expected. When I changed to continuous (AF.C), no tally light. I can understand that it would not continue to illuminate when changing in continuously focusing but was surprised that it did not illuminate when I first focused. I guess this is to be expected.

05-29-2014, 11:43 AM   #2
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
Green focus assist lamp comes on with AF.S and AF.C with the K-50. Odd it's not working with the K-30.
05-29-2014, 11:58 AM   #3
Site Supporter
K(s)evin's Avatar

Join Date: Sep 2010
Location: Colorado
Posts: 268
A 'tally light" is the red light that comes on above the lens of a camera (video/film) to indicate either that it is 'live' or recording. The light which comes on during focussing of your dslr is called a focus assist light.
05-29-2014, 12:10 PM   #4
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
On my K-30 AF assist does not turn on when in AF-c mode. AF-s mode it lights up.
Firmware is 1.05

05-29-2014, 12:14 PM   #5
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
Bug then?
05-29-2014, 12:16 PM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
Do you mean the green hexagon? That is the focus confirm and only lights up when focus is attained. In dim light or with a "flat" subject, that state may never happen.

Or do you mean the focus assist LED on the front of the camera? I just checked it on my K-3 and sure enough, the assist LED did not shine in AF-C mode, leading to the case in the paragraph above. I suppose they leave it turned off to conserve batteries?


Steve

---------- Post added 05-29-14 at 12:23 PM ----------

According to the manual for my K-3, low light focus assist is a feature of AF-S mode only. The same is true for the K-30 and K-50. So, no...not a bug.


Steve

Last edited by stevebrot; 05-29-2014 at 12:30 PM.
05-29-2014, 12:32 PM   #7
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
QuoteOriginally posted by stevebrot Quote
low light focus assist is a feature of AF-S mode only. The same is true for the K-30 and K-50. So, no...not a bug.
Not true for the K-50.
Do you think my post above was made without my actually checking!?
05-29-2014, 12:36 PM   #8
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by Steve.Ledger Quote
Not true for the K-50.
Do you think my post above was made without my actually checking!?
I have the K-50 manual in front of me as I type. Do you think I would post without checking?

Of course, as we all know, behavior sometimes changes with a firmware update, so it is possible that the K-50 manual does not reflect the behavior with current firmware. I would check against the most current firmware, but I don't have access to my friend's K-50 at present.


Steve

05-29-2014, 12:46 PM   #9
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
While the green AF assist led lights up in all modes on the K-50 when the AF set to Continuous, the K-7 needs to be in Green Mode for the AF assist to light up in AF.C
Might be the same for the K-30 and certainly likely for the K-5
05-29-2014, 01:00 PM   #10
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
The K-30 AF assist light only works in AF-S mode. It does not come on even when selecting a scene mode that would drive it to use AF-C.
05-29-2014, 02:05 PM   #11
Veteran Member
OregonJim's Avatar

Join Date: Mar 2009
Location: Willamette Valley, Oregon
Posts: 1,329
QuoteOriginally posted by stevebrot Quote
I have the K-50 manual in front of me as I type. Do you think I would post without checking?

Of course, as we all know, behavior sometimes changes with a firmware update, so it is possible that the K-50 manual does not reflect the behavior with current firmware. I would check against the most current firmware, but I don't have access to my friend's K-50 at present.


Steve
I just checked with my wife's K-50. Latest firmware (1.02). The focus assist lamp does come on in both AF.S and AF.C.
05-29-2014, 02:18 PM   #12
Veteran Member
JimC1101's Avatar

Join Date: Aug 2010
Location: Fremont, Ca
Photos: Albums
Posts: 393
Original Poster
Looking at some of the replies on here, I did a quick check on my K-30. In Auto and Scene mode, I tried portrait, the AF light does illuminate in AF.C. All other modes, it does not illuminate. Interesting, and wonder why it works on these two modes.
05-29-2014, 02:27 PM   #13
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by JimC1101 Quote
Looking at some of the replies on here, I did a quick check on my K-30. In Auto and Scene mode, I tried portrait, the AF light does illuminate in AF.C. All other modes, it does not illuminate. Interesting, and wonder why it works on these two modes.
I think you're mistakenly assuming the camera is in AF.C. In both Auto (green) mode and Portrait scene mode, the camera overrides the focus switch and operates exclusively as AF.S.

Try going to P mode and then check if the AF assist light illuminates in AF.C.
05-29-2014, 03:37 PM   #14
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,294
QuoteOriginally posted by IchabodCrane Quote
I think you're mistakenly assuming the camera is in AF.C. In both Auto (green) mode and Portrait scene mode, the camera overrides the focus switch and operates exclusively as AF.S.
Not for the K-7.
In green mode the AF Assist lights up in both modes and AF.C is working as AF.C not AF.S
05-29-2014, 05:15 PM   #15
Pentaxian




Join Date: Sep 2012
Photos: Gallery | Albums
Posts: 1,728
QuoteOriginally posted by Steve.Ledger Quote
Not for the K-7.
In green mode the AF Assist lights up in both modes and AF.C is working as AF.C not AF.S
Does the AF assist light stay on for as long as the shutter button is half-pressed... such as for a minute perhaps?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
assist, expected, focus, k-3, k-30, k-50, light, light with af.c, mode, pentax k30, pentax k50, steve
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3's AF.C with Focus priority. skyer Pentax K-3 18 12-11-2014 05:44 PM
AF.C (Focus-prority) with the AF button skyer Pentax K-5 17 04-29-2013 02:20 PM
Would you rather take the best low-light AF APS-C or another lousy AF FF? LeDave Pentax DSLR Discussion 23 09-10-2012 11:54 PM
Why no AF assist light with manual lenses? GabrielFFontes Pentax DSLR Discussion 7 07-06-2012 08:12 AM
PnS camera's focal length do not tally with exif? raider Pentax Compact Cameras 9 02-12-2009 12:57 AM



All times are GMT -7. The time now is 07:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top