Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-09-2014, 03:39 AM   #1
New Member




Join Date: May 2014
Posts: 22
Pentax K50 mirror flopping

Hi,

I have seen quite some posts for other models mirror flopping, but none for K50?

I have purchased it end of January 2014.
It exhibited mirror flopping problem, quite soon after the purchase, but only once and it was resolved after power off/on cycle.
I attributed it to cold February weather and happily used camera till last Saturday
when, well on quite warm, but not really hot weather, started with mirror flopping problem that does not stop

I can shoot in live view, but otherwise it is unusable, the viewfinder is dimmed, and it even does not autofocus, and sometimes does not power off.

Anybody else with K50 mirror flopping?

Tx
Rgds
Fila

PS Still under warranty it goes for reparation ASAP

06-09-2014, 05:41 AM   #2
Pentaxian




Join Date: Aug 2013
Photos: Gallery
Posts: 1,038
You're the first one that I know who has experienced it. I suggest that you document it properly and report the issue to your dealer.
06-09-2014, 06:20 AM   #3
Site Supporter
k0og's Avatar

Join Date: Nov 2008
Location: Rolla, Missouri
Photos: Gallery | Albums
Posts: 646
Another Mirror Flop Report

I bought my daughter a K-50 in December - she is shooting pro now and wanted an upgrade to her K200D. In the last month or two, she started experiencing mirror flop/sticking. It happens with several different lenses that work fine on her K200D. I cleaned the contacts on body and lenses and upgraded her firmware, but it's still happening. She found that if she quickly dismounts and remounts the lens, she can continue shooting for a few more shots, then it sticks again. Powering it off and back on does not fix the problem. Only dismounting/remounting the lens seems to fix it.

I'm afraid she will have to send it back for repair/replacement. She LOVES her K-50, but the problem is interfering with her work. She does a lot of photos of little babies and kids, and in that fast-moving environment I'm sure she is missing some shots. At least she has a K200D for backup.

-Joe-

Last edited by k0og; 06-24-2014 at 06:23 AM.
06-09-2014, 11:47 AM   #4
New Member




Join Date: May 2014
Posts: 22
Original Poster
QuoteOriginally posted by totsmuyco Quote
You're the first one that I know who has experienced it. I suggest that you document it properly and report the issue to your dealer.
What would constitute proper documentation?
Is the following video OK:
?

---------- Post added 06-09-14 at 08:52 PM ----------

QuoteOriginally posted by k0og Quote
I bought my daughter bought a K-50 in December - she is shooting pro now and wanted an upgrade to her K200D. In the last month or two, she started experiencing mirror flop/sticking. It happens with several different lenses that work fine on her K200D. I cleaned the contacts on body and lenses and upgraded her firmware, but it's still happening. She found that if she quickly dismounts and remounts the lens, she can continue shooting for a few more shots, then it sticks again. Powering it off and back on does not fix the problem. Only dismounting/remounting the lens seems to fix it.
I am itching to try to "solve" it somehow, but keeping in this state should allow proper diagnostic, so I do not try anything.

QuoteOriginally posted by k0og Quote
I'm afraid she will have to send it back for repair/replacement. She LOVES her K-50, but the problem is interfering with her work. She does a lot of photos of little babies and kids, and in that fast-moving environment I'm sure she is missing some shots. At least she has a K200D for backup.
It is very annoying, even if she has a backup. It surely has to go back to service

Tx
Rgds
Fila

06-09-2014, 01:03 PM   #5
Site Supporter
k0og's Avatar

Join Date: Nov 2008
Location: Rolla, Missouri
Photos: Gallery | Albums
Posts: 646
Fila,

Your video is exactly the problem hers experiences. However, it is erratic. The problem is a little different than the "mirror flop" problem I think the K5 and K3 have in that they repeatedly cycle the mirror many times per second. In this case, as your video demonstrates, the mirror and shutter seem to just get "stuck" and prevent taking a picture.

She had a photo shoot yesterday and told me she had no problems with it. She has one this afternoon, so we'll see if it is still good. I suggested that she send it in immediately since it is still under warranty. I have grandpa duty with her kids while she is doing the photo shoot, so I will see her and ask how it went when I take the grandkids back home to her later.

Try the following to see if it temporarily solves your problem:

Turn off the camera (remove the battery if you must). Then remove the lens (she does not even have to completely remove it, but just releases the latch and rotates it in the mount, then latches it back in position). Then turn the camera back on and it will probably work normally - at least for a while.

-Joe-

QuoteOriginally posted by Fila Quote
What would constitute proper documentation?
Is the following video OK:...

---------- Post added 06-09-14 at 08:52 PM ----------
06-09-2014, 04:59 PM   #6
Pentaxian




Join Date: Aug 2013
Photos: Gallery
Posts: 1,038
For documentation purposes, I would suggest that you document your complaints with your dealer. Mark or copy your camera's serial number since there may be a trend in the manufacturing batch which may have some troublesome parts or may need some software upgrade. To prevent further damage, it would also be wise not to use your camera. As some K-3 owners said, they had some debris on there sensor.

As I have commented in the other thread, the K-5 had this problem. Lately others have said that other older models had the same problem though not as serious as the K-3. Now, the current models are experiencing the same problem. I wonder why they never addressed this. If you can have your unit replaced with a new one I recommend you do so. I really hope Pentax/Ricoh will put an end to this problem. This is really disappointing.
06-09-2014, 05:02 PM   #7
Veteran Member




Join Date: Jun 2011
Location: Utah
Posts: 342
Hi, Fila. Sorry to hear about this. The issue seems to be affecting several models, although you're the first K-50 owner I've seen post about it. As far as I know, no DIY solution is available. (The aperture mechanism had to be replaced on mine last year because of this issue.) I'd definitely recommend submitting it for a warranty repair. Also, please check it carefully when you get it back. I tested mine in the dealer's shop after they got it back from CRIS (the US repair facility), and the mirror flopped--quite literally--on the first shutter press. Back it went...

In my case, the problem was exacerbated by M42 (i.e., contact-free) lenses, as well as shooting with no lens attached. You might try suggesting this approach to the repair folks as a means of diagnosis. In any case, good luck!
06-09-2014, 06:07 PM   #8
Site Supporter
k0og's Avatar

Join Date: Nov 2008
Location: Rolla, Missouri
Photos: Gallery | Albums
Posts: 646
I just saw my daughter, and her shoot (a set of 3-month-old twin boys) went perfectly with no hangups or mirror-flops from her K-50. I suggested that she always wipe the contacts on the lens and camera whenever she changes lenses and send it in for repair immediately if it happens again. I'll let you know here if she learns any more about her problem.

-Joe-

06-10-2014, 04:24 AM   #9
New Member




Join Date: May 2014
Posts: 22
Original Poster
Thanks everybody,
I contacted the service and it will be there tomorrow,
but then it goes to France for reparation (I live in Belgium)

I let you know how it goes ...

Rgds
Fila

---------- Post added 06-10-14 at 01:26 PM ----------

QuoteOriginally posted by totsmuyco Quote
I really hope Pentax/Ricoh will put an end to this problem. This is really disappointing.
Indeed very
06-10-2014, 04:34 AM   #10
Site Supporter
k0og's Avatar

Join Date: Nov 2008
Location: Rolla, Missouri
Photos: Gallery | Albums
Posts: 646
Fila,

Please let us know what the ticket says was done to your camera when it is returned. I'm very curious about what parts they service or replace.

Thanks.
-Joe-

QuoteOriginally posted by Fila Quote
Thanks everybody,
I contacted the service and it will be there tomorrow,
but then it goes to France for reparation (I live in Belgium)

I let you know how it goes ...

Rgds
Fila

---------- Post added 06-10-14 at 01:26 PM ----------



Indeed very
06-10-2014, 05:57 AM   #11
New Member




Join Date: May 2014
Posts: 22
Original Poster
QuoteOriginally posted by k0og Quote
Fila,

Please let us know what the ticket says was done to your camera when it is returned. I'm very curious about what parts they service or replace.

Thanks.
-Joe-
Sure
Tx
Rgds
Fila
06-10-2014, 05:49 PM   #12
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,108
QuoteOriginally posted by totsmuyco Quote
You're the first one that I know who has experienced it.
My thoughts as well. Sorry that both the OP and kOog's daughter are having this problem. As noted above, this problem is dissimilar to both the mirror issues on the K-3 and previous mirror-flop issues on K-5 series and K-30. Hopefully this is something that is both rare and addressable by a firmware patch.


Steve
06-11-2014, 09:27 AM   #13
New Member




Join Date: May 2014
Posts: 22
Original Poster
QuoteOriginally posted by Fila Quote
I contacted the service and it will be there tomorrow,
Camera delivered to the service center, and as Murphy says, it started working as soon as it got there
It will still go to France to have mirror checked, but who know what, if anything, will be done.
Very friendly people at Belgian service were sympathetic to my problem, but they said that such endemic problems can be difficult to repair
I let you know what happens.
Tx
Rgds
Fila
06-11-2014, 10:22 AM   #14
Site Supporter
k0og's Avatar

Join Date: Nov 2008
Location: Rolla, Missouri
Photos: Gallery | Albums
Posts: 646
Steve,

I upgraded her K-50 to the latest firmware but that did not fix it as I got it to hang up after the update. So, at least the latest firmware does not fix the problem with my daughter's camera. However, it recently started working properly and it's been good the last few days. It was an erratic problem before I upgraded the firmware, and unfortunately I expect her to have the problem again. I'm hoping that Fila will get a definite answer from the repair service about what they did to repair it, and I can tell my daughter to include that information when she sends hers in for warranty repair.

One thing I did NOT try that I just thought of is to reset the settings to factory defaults. I'll suggest that my daughter try that next time she has a problem.

-Joe-

QuoteOriginally posted by stevebrot Quote
My thoughts as well. Sorry that both the OP and kOog's daughter are having this problem. As noted above, this problem is dissimilar to both the mirror issues on the K-3 and previous mirror-flop issues on K-5 series and K-30. Hopefully this is something that is both rare and addressable by a firmware patch.


Steve
06-11-2014, 11:58 PM   #15
New Member




Join Date: May 2014
Posts: 22
Original Poster
QuoteOriginally posted by k0og Quote
I upgraded her K-50 to the latest firmware but that did not fix it as I got it to hang up after the update.
For the record I was not on the latest firmware V1.02 (PENTAX REAR CONVERTER), but on the previous V1.01.
Fila
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
adapter, backup, batteries, battery, camera, drop, eneloops, firmware, k-30, k-50, k-r, k200d, k50, lens, lenses, mine, mirror, pentax, pentax k30, pentax k50, pentax k50 mirror, pm, post, power, shots, weather
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax k50 body WILLIAM HUBBARD Sold Items 5 04-09-2014 10:41 AM
Mirror Flopping - How Much To Repair Pentaxiac Pentax K-5 3 08-17-2013 01:30 PM
Here's another mirror flopping issue minahasa Pentax K-r 0 07-23-2012 10:30 AM
Mirror flopping when metering w/ green button and old m42 lens Philoslothical Troubleshooting and Beginner Help 15 10-22-2011 05:06 PM



All times are GMT -7. The time now is 06:42 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top