Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-24-2014, 12:38 PM   #1
Forum Member
sewerynthegreat's Avatar

Join Date: Feb 2014
Location: Warsaw
Photos: Albums
Posts: 65
K-500 shutter acting weird with Pentax F 35-70

Hey guys I have got real sticker.
I just bought Pentax F 35-70 and was enjoying it when suddenly my K-500 shouter started acting weird, it became not as noisy as normal : ) i.e. it became weirdly quiet and “slow”. It appeared like shouter even when using fast shouter speed like 1/5000, it sounded like it was not more than 1/50 of a second.
I switched lenses and it got OK so I came back to F 35-70 but after few shots it started again. At some point of trials mirror have stayed in some weird position blocking light on viewfinder. I switched lenses and after few shots it backed to its appropriate position.
So help me guys because I have no idea what is going on. Is it fault of my “new” lens Pentax F 35-70? Or my K-500 lost his mind? Are there any known compatibility issues whit older lenses?
I see there are some issues with mirror flopping which are similar but not the same to what I am experiencing, can it be caused by the same problem?

06-24-2014, 12:43 PM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
Doesn't sound like the typical mirror flop since this one is brought on by the lens and goes away when another lens is used.
Try cleaning the contacts to see if it helps.
Is the aperture lever bent? Is it getting stuck somehow? Is there something from the lens protruding into the mirror box?
06-24-2014, 01:14 PM   #3
Forum Member
sewerynthegreat's Avatar

Join Date: Feb 2014
Location: Warsaw
Photos: Albums
Posts: 65
Original Poster
Thanks for an answer.
Sound changes while using the same lens, for few (usually one) shots it sounds like every other lens and then suddenly sound changes.
I also managed to take twenty-forty pictures with this lens before sound started to change and problem started to appear.
The aperture lever looks perfectly fine just like on my Pentax F 80-200mm which works OK with my K500. So I believe nothing is protruding into the mirror box.
I cleaned sticks and even tried to use lens without A setting but problem repeats... Frankly it gets worse now after literally one shot mirror takes weird position and camera hangs (earlier I was able to take at least few shots)
06-24-2014, 01:19 PM   #4
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
Last thing I can suggest is check to make sure batteries are full. Maybe that lens makes the whole system work harder and you are getting a voltage drop?

06-24-2014, 01:32 PM   #5
Forum Member
sewerynthegreat's Avatar

Join Date: Feb 2014
Location: Warsaw
Photos: Albums
Posts: 65
Original Poster
Thank for all the help
I tried it It didn’t help. I also upgraded firmware.
Tomorrow (we have 10 pm in Poland) I will go with this lens to local camera service and I will ask for advice or/and I will call to Pentax service.
Frankly I am starting to believe there must be something wrong with the lens (all other are working perfectly fine).
I will get you know what happens in case anyone else will have the same problem.

Thanks again.
06-25-2014, 07:31 AM   #6
Forum Member
sewerynthegreat's Avatar

Join Date: Feb 2014
Location: Warsaw
Photos: Albums
Posts: 65
Original Poster
It seems it was the lens fault, according to service there were probably short circuit in lens which caused the problem.
It seems likely, camera was receiving some crazy input from lens and was acting accordingly to receive data.
Seller from whom I bought the lens was surprised when I told him what I have experienced. He said lens was working fine with his k-x, so I am sending the lens back. He also said that in the past he also experienced similar problems with some other lens…
06-25-2014, 08:41 AM   #7
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
Glad you got it figured out and were able to return it. Best of luck in your future lens purchases.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
guys, issues, k 50, k 500, k-30, k-5, k-50, k-500, lenses, mirror, mirror flopping, pentax, pentax f 35-70, pentax k30, pentax k50, position, shots, shouter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: FS: Pentax K-5ii+F 35-70+F 80-200+Extras tele_pathic Sold Items 6 06-29-2014 08:20 AM
Pentax SMC F 35-70 or the AF 35-135mm for K-x? smileyz1gin Welcomes and Introductions 3 03-05-2014 10:09 AM
K500 acting weird and freezing salb Troubleshooting and Beginner Help 4 10-08-2013 05:27 PM
For Sale - Sold: Pentax A 35-70 F/4, K-X (SOLD), Pentax F 24-50 (SOLD), zbrueningsen Sold Items 4 08-21-2013 04:36 AM
Battery acting weird loffen90 Troubleshooting and Beginner Help 2 03-20-2009 09:51 AM



All times are GMT -7. The time now is 07:01 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top