Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2015, 05:25 PM   #16
Forum Member




Join Date: Jan 2009
Location: Salisnury, Canada
Posts: 68
So was this problem clearly identified, is there a way to check what is the culprit?

I purchased my K50 in May 2014, so I am past warranty. Some 2 weeks ago I shot couple of pictures and all heavily underexposed, almost black. I started playing with exposure compensation and then all of sudden everything worked. Trying to shoot today, same problem, all dark, after dozen exposures or so, all good again. Turned off and on, still working fine. Let it sit for a while, turned on and the same problem again, all shots black. I am dreading the cost of repair and time without camera for Christmas...

I recall, I had something similar long time ago with K100d, luckily during a warranty then. The symptoms were however bit different and it turned out to be faulty sensor.

12-01-2015, 06:22 AM   #17
New Member




Join Date: Oct 2015
Posts: 2
Waiting...

I managed to get my receipt from Amazon. I called Pentax and they seemed matter of fact ( i.e., likely this is a widespread issue) about the problem and simply gave me the address to return it for repair. I did so via UPS on November 2nd. The package arrived on the 9th at their facility. So far I have heard nothing and no idea when it will be returned. So likely no camera for the holidays. I intend to call them this week and try to get an update.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, jessops warranty, k-30, k-50, k50, k50 sensor, pentax k30, pentax k50, repair, sensor, sensor function, settings, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K50 Sensor Mount Issue/Problem? RCDREAMS Troubleshooting and Beginner Help 10 10-20-2014 01:06 PM
Pentax k-30 sensor problem? TomCotton Troubleshooting and Beginner Help 13 06-17-2014 01:29 AM
Sensor stains on my K50? ikonographics Pentax K-30 & K-50 12 05-27-2014 11:47 AM
K50 (and 30) sensor same as K5 or not? Kona Pentax K-30 & K-50 13 09-01-2013 12:09 PM
Sensor Problem kirstenincanada Pentax DSLR Discussion 17 04-28-2010 10:07 AM



All times are GMT -7. The time now is 07:13 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top