Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-21-2014, 05:19 AM   #1
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
K-50 Lens Question

I have an old SMC Pentax-A 50mm f2.0, manual focus, of course. I have used it a couple of times and in one case noticed that it was reported in the exif as "35mm." Last night I was preparing to copy some old slides; when I attached the lens a dialog popped up on the screen asking me to enter the focal length. I, of course, entered it as the correct 50mm. I assume the camera firmware recognized it as an unknown lens but why not the first time I used it?

11-21-2014, 05:36 AM   #2
Junior Member
Tony Lens's Avatar

Join Date: Nov 2014
Posts: 26
This dialog is showing up every time i use my M lens. Im not sure why you havent seen it the first time.
11-21-2014, 06:05 AM   #3
Pentaxian




Join Date: Nov 2011
Photos: Gallery | Albums
Posts: 3,615
QuoteOriginally posted by dakight Quote
I assume the camera firmware recognized it as an unknown lens but why not the first time I used it?
The camera asks for the focal length in order to be able to make the shake reduction work correctly,
since it has to translate gyroscope angles into pixel shifts.

If you don't have shake reduction on when you attach the lens, it won't bother to ask,
and will just write the previously entered focal length into the EXIF.
11-21-2014, 06:49 AM   #4
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
Original Poster
I don't remember changing the SR setting, but it's possible since I've been playing with the settings and trying to learn the camera.

11-21-2014, 07:02 AM   #5
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,285
SR is also turned off if you set timed delay and some other shooting modes so no need to actually change the SR setting for this to happen.
11-21-2014, 07:27 AM   #6
Pentaxian
schnitzer79's Avatar

Join Date: Jul 2013
Photos: Albums
Posts: 986
whenever i attach on a manual lens, depending on what mode I have it (one of my user modes have SR off), i check the menu just to make sure.makes it easier for me later on when grouping my photos.
I had some dirty contacts once (i think thats what it was), and SR was ON but no focal length confirmation on startup.
11-21-2014, 07:40 AM   #7
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
Original Poster
I wondered about dirty contacts. It's certainly possible because I bought the lens used and it has been stored until yesterday. It's asking everytime now
11-21-2014, 09:43 AM   #8
Pentaxian




Join Date: Sep 2013
Photos: Albums
Posts: 817
Is it on the 'a' aperture setting?

11-21-2014, 10:06 AM   #9
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,948
QuoteOriginally posted by dakight Quote
I have an old SMC Pentax-A 50mm f2.0, manual focus, of course. I have used it a couple of times and in one case noticed that it was reported in the exif as "35mm." Last night I was preparing to copy some old slides; when I attached the lens a dialog popped up on the screen asking me to enter the focal length. I, of course, entered it as the correct 50mm. I assume the camera firmware recognized it as an unknown lens but why not the first time I used it?
The SR setting is what gets saved in the EXIF, so that's strange!

There's an EXIF field called "35mm focal length", so perhaps you're misinterpreting that?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-21-2014, 12:55 PM   #10
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,137
Original Poster
QuoteOriginally posted by Adam Quote
The SR setting is what gets saved in the EXIF, so that's strange!

There's an EXIF field called "35mm focal length", so perhaps you're misinterpreting that?
That's entirely possible. I'm still feeling my way around.
11-21-2014, 01:18 PM   #11
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,167
QuoteOriginally posted by dakight Quote
Last night I was preparing to copy some old slides; when I attached the lens a dialog popped up on the screen asking me to enter the focal length. I, of course, entered it as the correct 50mm. I assume the camera firmware recognized it as an unknown lens but why not the first time I used it?
It only asks for the focal length when the camera is turned on, though you can set it at any time.


Steve
11-21-2014, 02:31 PM   #12
Pentaxian
ChristianRock's Avatar

Join Date: Jul 2013
Location: Marietta, GA
Photos: Gallery | Albums
Posts: 4,047
Sometimes I'll turn on my camera and immediately do a half press of the shutter button to be able to use the green button for metering. As soon as you do that half-press, all options (including entering the FL for SR) are gone. It'll assume whatever was entered previously (or maybe 35mm is the factory default).
Also, if you don't enter a FL after a few seconds, the option also goes away and it sticks with whatever it had as default.
My guess is either you pressed the half shutter, or turned it on and didn't pay attention to the screen for a few seconds, and the option was gone.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, course, k-30, k-50, lens, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto focus question for K-50 Dewman Pentax K-30 & K-50 23 12-06-2014 07:47 PM
Using K Mount Manual Lens on K-30, K-50? Relativity Pentax K-30 & K-50 11 07-08-2014 04:05 PM
Another K-50 versus K-30 question seventysixersfan Pentax K-30 & K-50 25 12-23-2013 03:41 PM
K-50 focusing speed with DA 55-300mm and battery question Clarkey Pentax K-30 & K-50 3 09-08-2013 07:46 AM
Noob question: Should any K-mount AF lens work on K-01? harioharima Pentax K-01 3 02-12-2013 03:14 PM



All times are GMT -7. The time now is 05:17 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top