Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-08-2015, 11:15 AM   #1
Senior Member




Join Date: Jul 2014
Posts: 111
K50 - froze up, would not shut off

We took my new K-50 on a vacation trip, it worked beautifully. Got home and was previewing and deleting some photos before the download and the camera froze up in review mode. I tried a couple things with no luck so I decided to just shut it down..... it did nothing. Finally, I removed the battery and it reset itself, but I am worried that this is the beginning on an issue that my be problematic. I read on this same site, a member who had this happen to 2 of his Pentax cameras with nothing found by the manufacturer upon their return for service. Has this happened to anyone else and should I be concerned?

01-08-2015, 11:20 AM   #2
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
My recollection is that this typically happens when the battery is not in the operating range for a charge.
01-08-2015, 11:23 AM   #3
Senior Member




Join Date: Jul 2014
Posts: 111
Original Poster
Thank you, I will pay attention to that and report back.
01-08-2015, 11:26 AM   #4
Site Supporter
severalsnakes's Avatar

Join Date: Jan 2013
Location: Shawnee, KS
Photos: Gallery
Posts: 1,500
I've had my K-30 for two years and it's done a similar thing a handful of times. No big deal. It hasn't become a larger issue for me, and the camera works perfectly. (For me, this has almost always happened with a third-party battery.)

01-08-2015, 12:57 PM   #5
Pentaxian
esrandall's Avatar

Join Date: Feb 2014
Location: Sumner, WA
Photos: Albums
Posts: 965
It will sometimes happen to my K-50 when going back and forth between AF and older MF lenses (like the M 50mm f/1.7). Like the others, I just pop the battery, and it's fine.
01-08-2015, 12:59 PM   #6
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
I would not worry too much. My K5 had a similar issue that it did not want to switch off. Happened once and never again.

It's just a software glitch.
01-08-2015, 03:33 PM   #7
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,178
It happened once to me shortly after I got the camera and I nearly had cardiac arrest! It was totally unresponsive to any kind of input. I popped the battery, put it back in and turned it on and it hasn't missed a beat since. It was shortly after that that I applied the firmware update. I have no idea if that made any difference or not but I figured it wouldn't hurt.
01-10-2015, 04:19 AM   #8
Veteran Member




Join Date: Mar 2007
Location: U.K.
Posts: 685
Is it still on the original firmware? There have been 2 updates since and they always state for each update "Improved stability for general performance".

01-10-2015, 08:50 AM   #9
Senior Member




Join Date: Jul 2014
Posts: 111
Original Poster
How would I know, and how do I update if it's not current?
01-10-2015, 11:07 AM   #10
Pentaxian
esrandall's Avatar

Join Date: Feb 2014
Location: Sumner, WA
Photos: Albums
Posts: 965
QuoteOriginally posted by nonstopnick Quote
How would I know, and how do I update if it's not current?
Pentax Firmware Update Guide - Tutorial Videos | PentaxForums.com
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-30, k-50, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-50 won't shut off or function without battery removal Sorver Troubleshooting and Beginner Help 10 08-12-2014 05:05 AM
K-5 froze up wiley old goat Troubleshooting and Beginner Help 9 02-28-2013 11:55 AM
AF540 Auto shut off tuggie76 Flashes, Lighting, and Studio 3 10-18-2011 11:20 AM
K-7 froze in video mode, now messed up dedmozaj Troubleshooting and Beginner Help 4 05-18-2011 04:26 PM
K-X made clunking, vibrating noise then froze up Olypentax Pentax DSLR Discussion 3 03-11-2010 11:43 AM



All times are GMT -7. The time now is 07:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top