Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-08-2015, 07:27 PM   #1
New Member




Join Date: May 2015
Posts: 5
Tamron lens stops responding K-30

Hey all,

I have been shooting on and off since High School, and I always prefer to have a Pentax SLR, if for no other reason I can reuse my older lenses. I have had my K-30 for a couple of years, and I have started to have an issue with my Tanron lens. I often have to shoot at long range, in low light, school gyms and auditoriums for my daughter's concerts and recitals. Within the last few months the AF will stop responding and the image gets darker through both viewfinder and saved image. If I release the lens and reseat it everything works fine for a bit. Has anyone else had a similar issue? My Pentax 18 - 55 never has an issue like this. I have a trip to India coming up in a few months and I am trying to decide if I need to replace the lens before I go. Thanks

05-08-2015, 07:43 PM   #2
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,518
It seems that the pb might be the lens. What lens? It will help PF members if you are more accurate.

Have you try to clean the lens contacts?

There might be other things to check but we cannot help without correct info.
05-08-2015, 07:49 PM   #3
New Member




Join Date: May 2015
Posts: 5
Original Poster
QuoteOriginally posted by hcc Quote
It seems that the pb might be the lens. What lens? It will help PF members if you are more accurate.

Have you try to clean the lens contacts?

There might be other things to check but we cannot help without correct info.
Sorry thought I had listed that... Tamron LD Di 70-300 mm
05-09-2015, 01:09 AM   #4
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,112
What about the aperture? Does the lever on the back of the lens move freely and does it return?

05-10-2015, 11:50 AM   #5
New Member




Join Date: May 2015
Posts: 5
Original Poster
The lever works fine, I just checked it, I have cleaned the contacts in the past with a pencil eraser, would you suggest a different method hcc? Thanks.
05-10-2015, 11:47 PM   #6
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,112
QuoteOriginally posted by Styx115 Quote
The lever works fine, I just checked it, I have cleaned the contacts in the past with a pencil eraser, would you suggest a different method hcc? Thanks.
And the blades in the lens?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
image, issue, k-30, k-50, lens, months, pentax, pentax k30, pentax k50, school, tamron lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 + Tamron 28-75, focus seems off ChooseAName Troubleshooting and Beginner Help 11 07-09-2014 06:04 AM
K-30 or Tamron 70-200. ramseybuckeye Troubleshooting and Beginner Help 14 01-17-2014 05:53 PM
K-30 stops responding mspoon Pentax K-30 & K-50 17 08-09-2012 07:42 AM
kx stops recording video after 30 seconds jupzchris Pentax DSLR Discussion 8 06-20-2010 06:00 AM



All times are GMT -7. The time now is 08:05 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top