Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-08-2015, 04:06 PM   #1
Site Supporter
skid2964's Avatar

Join Date: May 2008
Location: USA
Posts: 603
K-30 Failed today, I think it is the mirror...

I shoot Real Estate photography, my original K-30 went 60,000 actuations without an issue and is still working fine as my backup camera. My newer K-30 just failed with 9,000 actuations.
I was shooting bracketed shots today, all three shots turned out fine but the mirror seemed to clack more times than it should and seems to have stuck in approximately mid position. I took the lens off then back on and it worked a few more times then failed again. I swapped lenses with my old K-30 and the problem still persists so I am quite sure it is the body.

So, I have NEVER had a Pentax failure before! I guess I need to send this one in for repair... any tips for a first timer in this area? Do I need to figure out precisely what is wrong first? or just send it in and hope for the best?

06-08-2015, 04:15 PM   #2
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
clean contacts, decent battery, firmware, reset???
06-08-2015, 04:47 PM - 1 Like   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,141
QuoteOriginally posted by skid2964 Quote
I shoot Real Estate photography, my original K-30 went 60,000 actuations without an issue and is still working fine as my backup camera. My newer K-30 just failed with 9,000 actuations.
I was shooting bracketed shots today, all three shots turned out fine but the mirror seemed to clack more times than it should and seems to have stuck in approximately mid position. I took the lens off then back on and it worked a few more times then failed again. I swapped lenses with my old K-30 and the problem still persists so I am quite sure it is the body.

So, I have NEVER had a Pentax failure before! I guess I need to send this one in for repair... any tips for a first timer in this area? Do I need to figure out precisely what is wrong first? or just send it in and hope for the best?
If cycling the shutter doesn't help, it'll most likely need a repair. If you're covered under warranty then definitely go for it, otherwise I'd recommend replacing your camera with a new K-50 (~$300).

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-09-2015, 11:49 AM   #4
Site Supporter
skid2964's Avatar

Join Date: May 2008
Location: USA
Posts: 603
Original Poster
QuoteOriginally posted by Aaron28 Quote
clean contacts, decent battery, firmware, reset???
Battery was good, I think I am one firmware version off, will update...
I will also try the contacts because it seems to be OK while there is no lens attached.

---------- Post added 06-09-15 at 01:51 PM ----------

QuoteOriginally posted by Adam Quote
If cycling the shutter doesn't help, it'll most likely need a repair. If you're covered under warranty then definitely go for it, otherwise I'd recommend replacing your camera with a new K-50 (~$300).
I will try suggestions to get it fixed (it is no longer under warranty) and put it back into action but I did also go ahead and order a new K-50 last night... (B&H for $307 with free SD card)...
Will get this one fixed and make it my backup and give my other backup camera to one of the kids...


Last edited by skid2964; 06-09-2015 at 12:22 PM.
06-24-2015, 08:44 AM   #5
Pentaxian




Join Date: Jul 2013
Posts: 1,457
My Original K30 just failed yesterday....... 67421 Clicks........ Its the Aperture block Diaphragm Im afraid as it has all the classic symptoms. Never had even a glitch until 3 days ago. It wont be going for service as new low mileage ones with less than 1000 clicks are going cheaper on Fleabay.
Its ok because I have a new backup K30 and a new KS2 and a K3 so no biggie.
Just thought I would throw this out there as far as Mileage comparisons on the K30 after 2 years and out of warranty now. I abused the hell out of this camera so Im very pleased......its going on Ebay for a parts camera.
07-23-2015, 08:02 AM   #6
Pentaxian
mgvh's Avatar

Join Date: Sep 2010
Location: MD
Photos: Gallery | Albums
Posts: 855
HELP! My K-30 has 14,217 actuations. It's worked perfectly. Just now I was using a manual lens and things were working fine, but after a dozen shots, using the green button to meter started not to work. Then the battery died. Put in a new, fully charged battery and put on a DA 18-135 lens. The lens doesn't open. (I.e., it is very dark in the viewfinder. Completely dark when I tried Liveview.) Now the whole thing is acting funny. Sometimes it turns on, sometimes not. If it turns on, it sometimes won't turn off.
I have a K-x, and the aperture lever in the body seems to be fixed in a middle/bottom position. In this K-30, the aperture level is at the top position and can easily be moved up/down. So did something happen with the aperture lever?
After reading this thread, Adam, what does it mean to "cycle the shutter"? How do you do that?
Dlanor, what do you mean by "Aperture block diaphragm" problem and its classic symptoms?
Thanks for any help. (I have a big trip planned for Sunday, so this is not good timing...)
The camera is 2 years and 1 month old. I did buy the Adorama extended 2 year warranty, so I still have coverage.
07-23-2015, 08:08 PM   #7
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 1,070
quite possible on the aperture lever.....don't know for sure
07-25-2015, 04:27 PM   #8
Pentaxian




Join Date: Jul 2013
Posts: 1,457
QuoteOriginally posted by mgvh Quote
HELP! My K-30 has 14,217 actuations. It's worked perfectly.
Dlanor, what do you mean by "Aperture block diaphragm" problem and its classic symptoms?
Thanks for any help. (I have a big trip planned for Sunday, so this is not good timing...)
The camera is 2 years and 1 month old. I did buy the Adorama extended 2 year warranty, so I still have coverage.
I don't know ALL the symptoms but on mine I started getting dark , severely underexposed/overexposed , or even nearly black images.....Mine was out of warranty and it got sold on ebay for $36. I don't know for FACT that's what it was , but there is quite a bit of info about the diaphragm block failing and mine fit the picture. I wouldn't want it repaired by Precision Camera so my choice was to throw it in the garbage can , or get a newer used one. I paid $187 for one on ebay with 7 shutter actuations. Works fine and I hope it goes 67K actuations as I feel I got good mileage out of it !
Other symptoms were green button metering was way off , mirror would get stuck as well as actuating lever. I would take the lens on and off several times and it seemed to work for a few shots then do it again. It did it with several different lenses. It simply went all wacky ! I may have been premature on saying Aperture block diaphragm , but a quick search seemed to fit the symptoms. I only shoot manual lenses 99% of the time , so it was quite obvious when it started and I didn't think to test it with a modern lens like my 18-135mm.


Last edited by Dlanor Sekao; 07-25-2015 at 04:48 PM.
07-25-2015, 06:47 PM   #9
Pentaxian
mgvh's Avatar

Join Date: Sep 2010
Location: MD
Photos: Gallery | Albums
Posts: 855
Since I still had the warranty, I contacted Pentax/Ricoh, and they sent me to Precision Camera. Pentax/Ricoh said to fill out the form on the Precision website, but I had questions and called. I was able to talk to a customer service agent within a minute. She said not to use the web form but gave me directions to include personal info, camera, copies of invoice and extended warranty card. No payment needed at this time. I should call again a couple days after they get the camera to confirm matters, but I should be able to track online using phone number as a ref. number. I'll see how long it takes and if it was indeed the aperture control block...
09-24-2015, 08:10 PM   #10
Pentaxian
mgvh's Avatar

Join Date: Sep 2010
Location: MD
Photos: Gallery | Albums
Posts: 855
A follow up since I'm going to point to this thread when others encounter this aperture control block problem.
Symptoms can be varied including dark viewfinder, difficulty turning on/off, inaccurate exposures if the shutter does manage to fire, battery problems...

As you can read above, mine was still under warranty, so I sent it in to Precision Camera. (Cf. directions in post #3 above) I received it back in 11 days, but actually I sent was a different K-30. (i.e., different serial number) I'm not complaining. The one I sent in had over 14,000 actuations. The one they sent to me had less than 50.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
actuations, backup, battery, camera, contacts, firmware, k-30, k-50, pentax k30, pentax k50, shots, times, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New k-50 mirror jam I think?????? Sorver Troubleshooting and Beginner Help 2 06-14-2014 11:42 PM
I think I'm sold on the K-30 but which kit? blacknosugar Pentax K-30 & K-50 9 11-05-2012 07:38 AM
Is this what I think it is? Chex Pentax SLR Lens Discussion 12 04-15-2011 03:32 PM
I think Glenn Beck is in it for the money.. larryinlc General Talk 94 12-08-2009 03:51 PM
I think K-x is not Pentax. It's HOYA. Bunny Gear Pentax News and Rumors 29 09-19-2009 11:13 AM



All times are GMT -7. The time now is 02:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top