Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-11-2015, 10:22 AM   #1
Pentaxian
RoxnDox's Avatar

Join Date: May 2007
Location: Gig Harbor, Washington, USA, Terra
Photos: Gallery | Albums
Posts: 3,165
K-30 & lens issue (contacts?)

Took a trip down to the Oregon coast this past weekend, and I encountered a problem with the K-30 that I hope is simple to deal with... Attached is an example. Severely underexposed. It happened with both my 18-135WR (no previous issues) and my Promaster 70-300 zoom (also no issues like this). Sadly, I did not chimp enough to catch the problem, so I lost several really good shots of a lighthouse

I could only get the camera back to normal operations by removing the battery and turning it on, then off and replacing the battery. Did this with both the lithium and 4-AA adapter w/ Eneloops. Stupid me, I did not think to clean the contacts on the lenses or the body at the time. I have done that now, but haven't done any shooting since we got back.

Does this sound like a dirty contacts problem?

Jim

(and yes, I know shooting Raw would have helped...)


Last edited by RoxnDox; 10-10-2016 at 07:23 PM.
06-11-2015, 10:31 AM   #2
Loyal Site Supporter




Join Date: Aug 2011
Photos: Albums
Posts: 1,816
If you have tried to clean the contacts on the camera body and the problem is still there, it is very likely the aperture lever motor on the camera failed. The camera can not control the aperture, and the lens will close the aperture to F22 or alike even you set it at wide-open. Check the aperture during exposure. And sett the F to smallest aperture on camera at Av setting, you might get a correctly exposed image.
It is a relative common problem, I have seen that on my K-r and K30. K30 was purchased used and was returned, and K-r was converted to use M42 lenses only.
06-11-2015, 10:37 AM   #3
Pentaxian
RoxnDox's Avatar

Join Date: May 2007
Location: Gig Harbor, Washington, USA, Terra
Photos: Gallery | Albums
Posts: 3,165
Original Poster
Something to look for... I just cleaned the contacts this morning, I'll pop in a new SD card and start shooting a bunch of stuff to see if it happens again. It was intermittent to begin with, so we'll have to see... Thanks!

Jim
06-12-2015, 01:26 AM   #4
New Member




Join Date: Jul 2014
Posts: 24
Not sure if shooting raw would have helped with that shot. I had a k30, after about a year got the same problem. it would happen reasonably randomly but you'd get one of those at least one in 20 shots. more if i shot in portrait mode.

Theres a known problem in the k30's. The shutter box dies in them or something. mine was just out of warranty, i tried contacting pentax to see if they would do anything about it, (after googling i found lots and lots of people with the same problem) but in europe there is zero customer service from pentax. they didnt even reply. i sent an email to every email address i could find.

I ended up just buying a k3 instead. i was quoted about 175 to fix it by jssp in the UK.

(i also tried contacting pentax about a broken lens cap that came with my DA* 300 (amazon wanted me to return the whole lens but i didnt want to do that), again an email to every email address i could find on the uk website..... no reply)

of course it may very well be a dirty contacts problem... hopefully.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, contacts, issues, k-30, k-30 & lens, k-50, lens issue, pentax k30, pentax k50
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-30: Have a prime & kit lens - Looking for upgrade pingu Pentax SLR Lens Discussion 47 01-23-2015 11:25 AM
For Sale - Sold: Focusingscreens.com EE-S Screen for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 Aperturae Sold Items 6 10-06-2014 06:49 AM
For Sale - Sold: KatzEye Split-Prism Focusing Screen - for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 chickentender Sold Items 7 04-15-2014 08:35 PM
Pentax K-30 focus confirmation issue tpetris Pentax K-30 & K-50 10 12-28-2013 04:31 AM
Lens issue - Dirty contacts?..... UpNorth Troubleshooting and Beginner Help 4 07-24-2012 06:30 PM



All times are GMT -7. The time now is 12:19 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top