Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-12-2015, 07:38 AM   #1
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Aperture Issue with K-30?

I have a K-30 bought around Christmas 2012, has just over 7000 actuations. No issues at all until about a week ago, love the camera. But started getting very underexposed pictures while taking shots at my kid's little league game. Like all black when what should be normally exposed.

Swapped around lenses and pulled the battery, but switching in and out of live view seemed to fix it. When I got home and started my lightroom workflow most of my shots were about a stop underexposed.

Tried it again today and if anything it was worse. Had to crank up the ISO to 1600 or 3200 and very much overexpose to get reasonable shots in decent daylight/cloudy conditions. Exposure compensation didn't seem to help at all. Didn't change symptoms with different lenses (DA 55-300, plastic fantastic 35mm, or the 18-55 kit lens).

But just got home and threw on my old Auto Chinon all-manual lens with an aperture ring. Now it seems to be working fine, no obvious exposure problems with normal settings. So I'm assuming there is something going on with the aperture actuation in the body.

Anybody have a similar experience? Thoughts?

Also, went to the Ricoh site and their support page is blank aside from this text "We are fine tuning this area at the moment, please check back tomorrow!" Fun times. I'm guessing I'm going to be figuring out out-of-warranty repair options and whether a new K-50 (or K-3 II?) makes more sense.

09-12-2015, 08:06 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
You might check this thread: https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/229294-k...e-problem.html
09-12-2015, 08:18 AM   #3
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Original Poster
Thanks, it very much looks like an aperture control motor issue. Any thoughts on just sending the thing to Precision or K&H, since I'm long out of warranty? Looks like flat rates are standard, and this would cost ~$200.

It's tempting to move up to a new K-3 II but seems a little crazy to not try to fix the K-30 I'm very happy with. Well, at least before this issue.

---------- Post added 09-12-15 at 10:19 AM ----------

Oh, and a little more investigation of the issue. Put on my Rokinon fisheye with an aperture ring, and it's extremely dark on Auto, but exposes fine using the ring.
09-12-2015, 08:40 AM   #4
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
I don't have a k-30 but there have been a lot of posts on this issue. You might contact Precision or KEH and see if you can get a quote rather than standard rates, you might have to send it in for that though. Another possibility would be to check used k-30 prices and see if that is less than the cost of repair.

k-3II is the new flagship and would be a large step up in a lot of areas, but is still priced at a premium, you might also look at used k-3 or k-5IIs. The only difference between k-3 and k-3II that makes much difference for me is the GPS. If you don't need that look at new or used k-3 instead. k-5IIs is also a very nice camera with similar sensor to k-30 but 14bit, no AA filter and IMHO better build quality.

09-12-2015, 08:44 AM   #5
Site Supporter
loco's Avatar

Join Date: Mar 2011
Location: Virginia
Photos: Gallery | Albums
Posts: 2,844
My K-30 had the same issue, but it was still under the extended warranty, so I got it fixed. It worked fine after the fix from Precision. However, I have since upgraded to a K-3 (just a couple months ago), keeping the K-30 as my backup. The K-3 is amazing. And priced right. If you don't need the GPS, maybe consider the K-3 if you can get it at a great price now.
09-12-2015, 09:35 AM   #6
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Original Poster
QuoteOriginally posted by jatrax Quote
I don't have a k-30 but there have been a lot of posts on this issue. You might contact Precision or KEH and see if you can get a quote rather than standard rates, you might have to send it in for that though. Another possibility would be to check used k-30 prices and see if that is less than the cost of repair.

k-3II is the new flagship and would be a large step up in a lot of areas, but is still priced at a premium, you might also look at used k-3 or k-5IIs. The only difference between k-3 and k-3II that makes much difference for me is the GPS. If you don't need that look at new or used k-3 instead. k-5IIs is also a very nice camera with similar sensor to k-30 but 14bit, no AA filter and IMHO better build quality.
It seems that both Precision and KEH have moved to a flat-rate model, unless the price is higher than the flat rate. In any case, it looks like used K-30s are in the $350 range, while the flat-rate repair cost is a little over $200.

I don't think I want or need the GPS, so I'd look at the K-3. But for now I think I'm going to go the repair route.
09-12-2015, 12:00 PM   #7
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,843
QuoteOriginally posted by ThorSanchez Quote
It seems that both Precision and KEH have moved to a flat-rate model, unless the price is higher than the flat rate. In any case, it looks like used K-30s are in the $350 range, while the flat-rate repair cost is a little over $200.

I don't think I want or need the GPS, so I'd look at the K-3. But for now I think I'm going to go the repair route.
KS-1 on Ebay and Amazon is running close to $300 for body only. It won't give you WR or Wireless P-TTL control but it does just about everything else and it's a 20MP with no AA filter. Pretty neat camera from what I hear.
09-13-2015, 06:33 AM   #8
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Original Poster
QuoteOriginally posted by UncleVanya Quote
KS-1 on Ebay and Amazon is running close to $300 for body only. It won't give you WR or Wireless P-TTL control but it does just about everything else and it's a 20MP with no AA filter. Pretty neat camera from what I hear.
WR was one of the features that pushed me to Pentax, so I'd like to stick with a WR body. Nice to have a little peace of mind when out photographing sports or hiking.

09-13-2015, 09:01 PM   #9
Forum Member
Bertminator's Avatar

Join Date: Feb 2014
Posts: 80
Yup, I agree it's the aperture motor. My K-50 did the same thing shortly before the warranty expired on it. First photos on burst would be dark then after a moment of stopping, the burst shots, the next photos were just fine. I hope that the repair I had done lasts longer than the original motor, if not I may have to spend more money on a Canon DSLR, although that would break my heart.
09-16-2015, 11:05 PM   #10
icy
Senior Member




Join Date: Jun 2011
Location: Si Gn city, Việt Nam
Photos: Gallery | Albums
Posts: 185
pentax/Ricoh has a very good strategy to get customer's money =))
09-30-2015, 05:04 PM   #11
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Original Poster
Update. I sent it to KEH, and they sent it back and told me they can't repair it. Only Precision can. So... off to Precision and we'll see how that goes.
10-10-2015, 09:41 AM   #12
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 982
Mine was doing the same thing after not using it for a while. A few days of using it in burst mode solved the problem. I GUESS IF YOU DONT USE IT OFTEN ENOUGH IT wants to seize up a little. SO the moral of the story try using it for a few days in burst mode before you send her away. good luck
10-22-2015, 11:17 PM   #13
Forum Member




Join Date: Oct 2013
Posts: 77
I'm having the issue. Purchased this just a little over 2 years ago.
This is utter BS.
I emailed Pentax about this. If they can't do anything about this BS, I can 100% honestly say never going to buy Pentax or even speak nicely about the brand ever again.
10-25-2015, 06:26 AM   #14
Site Supporter




Join Date: Dec 2012
Photos: Albums
Posts: 177
Original Poster
QuoteOriginally posted by loco Quote
My K-30 had the same issue, but it was still under the extended warranty, so I got it fixed. It worked fine after the fix from Precision. However, I have since upgraded to a K-3 (just a couple months ago), keeping the K-30 as my backup. The K-3 is amazing. And priced right. If you don't need the GPS, maybe consider the K-3 if you can get it at a great price now.
How long did the repair take at Precision? Mine has been awaiting parts for 2+ weeks.
10-25-2015, 07:41 AM   #15
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,843
QuoteOriginally posted by ThorSanchez Quote
How long did the repair take at Precision? Mine has been awaiting parts for 2+ weeks.
Mine took... a long time. First they didn't acknowledge it was there. They claimed it had never been delivered. Then I supplied a tracking number that showed it had been delivered. They "found" it a day later. Then there was literally no information - and suddenly an email saying it was being shipped back.

It has worked ever since to their credit.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, aperture issue, exposure, home, issue, k-30, k-50, lens, lenses, pentax k30, pentax k50, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 Aperture control and battery problem mgvh Troubleshooting and Beginner Help 10 10-21-2016 06:56 AM
K-30 Auto aperture not working tylerherring Troubleshooting and Beginner Help 6 04-03-2014 06:33 AM
Aperture ring with manual lens on K-30 Tsuken Pentax K-30 & K-50 12 11-30-2013 09:19 PM
Aperture not changing with K-30 and SMC Pentax-M 1:1.7 50 mm SLR lens kenbobblehead Troubleshooting and Beginner Help 7 10-28-2013 07:48 PM
Can I use the manual aperture ring on an SMC 50mm f/1.7 with a K-30? someguy42 Pentax SLR Lens Discussion 10 05-25-2013 12:49 PM



All times are GMT -7. The time now is 11:58 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top