Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-16-2015, 04:02 AM   #1
Senior Member




Join Date: Jun 2011
Location: Si Gn city, Việt Nam
Photos: Gallery | Albums
Posts: 185
k-30: randomly getting black output images

My friend has a K-30. He often put this camera in his box quite a long time (possibly 1 or 2 months) without using it.

The camera used to work fine. Its shutter counter is about 7000. Recently, it randomly captures (nearly) total black images.

For example, at daylight and taking image at f/2.4, iso 100, 1/200s, the output is nealry black (On a good K30, the output is very good at the same condition.) If I continously take some 2 or 5 more images, the outputs become good then. But letting the camera relax some hours, the problem happens again.

Any ideas why this happens and how to fix it?

Thanks a lot!

09-16-2015, 05:00 AM   #2
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,707
I had a problem like this on my K-r, it was random. I sent it in to Pentax, it took them ages said they couldnt find the issue (or maybe didnt look). They sent me a new one.

Maybe you can send it in if you have warranty or check a service center?
09-16-2015, 05:25 AM   #3
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,329
Are you sure its not the SD card?

You can try the following steps, or just go directly to warranty service (if you still have it):
a) fully charge battery, leave it outside of camera for some hours
2) make sure lens mount and camera mount are both clean
c) make sure the shutter/mirror box is clean of dust and particles
d) reset camera to factory defaults
e) update firmware to the latest one

These steps can sometimes fix odd little problems. But other than that, I have no idea what exactly could be causing your problem, so i have no more specific answers. Good luck
09-16-2015, 05:37 AM   #4
Site Supporter
loco's Avatar

Join Date: Mar 2011
Location: Virginia
Photos: Gallery | Albums
Posts: 2,836
Sounds like another bad aperture control block. Send it in for repair.

09-16-2015, 05:39 AM   #5
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
It's a known K-30 problem....

https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/229294-k...e-problem.html
09-16-2015, 11:15 AM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
QuoteOriginally posted by icy Quote
My friend has a K-30. He often put this camera in his box quite a long time (possibly 1 or 2 months) without using it.

The camera used to work fine. Its shutter counter is about 7000. Recently, it randomly captures (nearly) total black images.

For example, at daylight and taking image at f/2.4, iso 100, 1/200s, the output is nealry black (On a good K30, the output is very good at the same condition.) If I continously take some 2 or 5 more images, the outputs become good then. But letting the camera relax some hours, the problem happens again.

Any ideas why this happens and how to fix it?

Thanks a lot!
I would first make sure that you're using a high-quality (i.e. UHS-I compatible) card that's recently been formatted. Then, if actual underexposure rather than file corruption turns out to be causing the issue, the camera may need to get a new shutter.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-16-2015, 01:50 PM   #7
New Member
Intrance's Avatar

Join Date: Dec 2014
Posts: 15
I hope you don't mind me joining in on this thread... I am at 7050 shutter count and I am having this exact same issue, though seemingly with only one lens. Unfortunately, it is one of my favorites, the Sigma 30mm F1.4 Art... Are you seeing these kind of results as well;

Same settings on both... Manual Exposure, ISO 800, 1/30, F1.4




This one is even stranger when you come across it at first... The darker image is with a wider aperture in the settings. You can barely see the glint of the metal base of the lamp in the second one.
Manual Exposure, ISO 800, 1/30, F2.0 (light) vs F1.4 (dark).

09-16-2015, 06:59 PM   #8
Site Supporter
virusn3t's Avatar

Join Date: Jul 2014
Posts: 582
My camera just begin with this problem (K30 +9k shutter count), its the lever that open the aperture, i put the Raw/Fx button to optical preview DoF and have to press that button like 5-7 tome until start to give the actual aperture, the im good to go, idk how much time will be effective until stop working this way

09-16-2015, 11:00 PM   #9
icy
Senior Member




Join Date: Jun 2011
Location: Si Gn city, Việt Nam
Photos: Gallery | Albums
Posts: 185
Original Poster
Thank you all for your replies.

I'm in Vietnam, and the local service refuses to repair this kind of issue. Investing another camera seems to build another deam!
09-16-2015, 11:42 PM   #10
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by icy Quote
Thank you all for your replies.

I'm in Vietnam, and the local service refuses to repair this kind of issue. Investing another camera seems to build another deam!
Yip, the k-30 is a nice looking and handling camera, but I had a lot of regrets buying it. Luckily the problems with it caused me to go for a K-5iis, which had come down nicely in price by the time I bought it. I will never buy at the beginning of a camera cycle again, wait at least a year to see if problems start showing, and decide then...
09-17-2015, 03:48 AM   #11
icy
Senior Member




Join Date: Jun 2011
Location: Si Gn city, Việt Nam
Photos: Gallery | Albums
Posts: 185
Original Poster
QuoteOriginally posted by altopiet Quote
Yip, the k-30 is a nice looking and handling camera, but I had a lot of regrets buying it. Luckily the problems with it caused me to go for a K-5iis, which had come down nicely in price by the time I bought it. I will never buy at the beginning of a camera cycle again, wait at least a year to see if problems start showing, and decide then...
Great tip. But my friend wouldn't be happy with his K-30 now. And I am also praying for my own k30
09-17-2015, 05:09 AM   #12
Site Supporter
loco's Avatar

Join Date: Mar 2011
Location: Virginia
Photos: Gallery | Albums
Posts: 2,836
Always get the Pentax extended warranty if available. It really is great for peace of mind. Inexpensive and it paid for my repair in full.
The K-30 is a fantastic camera otherwise.
09-17-2015, 11:01 AM   #13
New Member
Intrance's Avatar

Join Date: Dec 2014
Posts: 15
I have just sent a request for repair under warranty to the shop I bought it at, even though mine is older than two years. Consumer rights here say that a product that fails before an expected lifespan is still subject to warranty. And I do believe that a camera that fails on 7000 clicks when used normally is definitely faulty. I bought it expecting it to last me at least a year or 4-5.
09-19-2015, 03:48 AM   #14
icy
Senior Member




Join Date: Jun 2011
Location: Si Gn city, Việt Nam
Photos: Gallery | Albums
Posts: 185
Original Poster
QuoteOriginally posted by altopiet Quote
Yip, the k-30 is a nice looking and handling camera, but I had a lot of regrets buying it. Luckily the problems with it caused me to go for a K-5iis, which had come down nicely in price by the time I bought it. I will never buy at the beginning of a camera cycle again, wait at least a year to see if problems start showing, and decide then...
What is the best camera to buy at the moment? K30, k50 or a K3?

---------- Post added 09-19-15 at 05:49 PM ----------

QuoteOriginally posted by Intrance Quote
I have just sent a request for repair under warranty to the shop I bought it at, even though mine is older than two years. Consumer rights here say that a product that fails before an expected lifespan is still subject to warranty. And I do believe that a camera that fails on 7000 clicks when used normally is definitely faulty. I bought it expecting it to last me at least a year or 4-5.
My friend bought the camera from the 2nd market in Vietnam , and it didn't include any warranty support. It's too risky!
09-19-2015, 05:01 AM   #15
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by icy Quote
What is the best camera to buy at the moment? K30, k50 or a K3?
K-50 is basically the same camera as the K-30, just a different looking body with a few extras....If I had the money, I would rather go for the K-3, just get an extended warranty, as it seems to have some problems of it's own https://www.pentaxforums.com/forums/172-pentax-k-3/254464-k3-crazy-mirror-sic...ours-here.html
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, images, k-30, k-50, output, pentax k30, pentax k50, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-30 pictures are getting Dark islamnassar Pentax K-30 & K-50 21 07-12-2016 01:08 PM
K-50 Images Underexposed (Black) aikilink Pentax K-30 & K-50 11 07-08-2015 05:23 AM
Getting K-3; Sell my K-30 or keep it? Sdenby Pentax DSLR Discussion 22 12-31-2014 02:34 AM
K-30 Live View and Menu Randomly Switching to shooting mode Parker Visitors' Center 5 02-11-2014 09:54 PM
Nature Getting used to my new K-30 TonyTurley Post Your Photos! 7 12-21-2013 06:29 PM



All times are GMT -7. The time now is 11:55 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top