Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-19-2016, 12:53 PM   #16
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,199
You guys sound like perfect consumers.


Agree on Pentax being distant from their problem. Sure other brands have issues too, not just Pentax, but it's how a company deals with it that counts.

01-20-2016, 12:51 AM   #17
Forum Member




Join Date: May 2015
Posts: 58
Original Poster
QuoteOriginally posted by androjoker Quote
I was thinking about k-s2 too, But I spent about 500 euros two years ago to buy my k-30.
But I'm disappointed in Pentax and I'm also thinking about selling Pentax lenses and going to a mirrorless system, like Fuji or Olympus.
My second camera is Olympus M10. I could not see a difference between two photos of the same taken by each camera up to ISG 800 ( may add 1600), Have not tested above 1600. M10 is a very nice camera!
Leo
01-20-2016, 11:25 AM   #18
Forum Member




Join Date: May 2015
Posts: 58
Original Poster
QuoteOriginally posted by androjoker Quote
I was thinking about k-s2 too, But I spent about 500 euros two years ago to buy my k-30.
But I'm disappointed in Pentax and I'm also thinking about selling Pentax lenses and going to a mirrorless system, like Fuji or Olympus.
As I have a not functioning K-30. After K-30 I am back to Pentax with KS2. I also have for 1.5 years Olympus M10. Use it very often. Probably should purchase second M10 or M10 II body.,
Leo
01-24-2016, 03:45 AM   #19
New Member




Join Date: Jan 2013
Posts: 5
repaired

So they changed the aperture motor (at least what they said) and fixed the K-30 for 100 USD. Honestly I expected to cost more.

They gave me 2 months warranty for the changed part. I am thinking of selling it now...

01-24-2016, 11:28 PM   #20
Forum Member




Join Date: May 2015
Posts: 58
Original Poster
K-30 Fix....

QuoteOriginally posted by Backo1 Quote
So they changed the aperture motor (at least what they said) and fixed the K-30 for 100 USD. Honestly I expected to cost more.

They gave me 2 months warranty for the changed part. I am thinking of selling it now...
I have K-30 with a failed aperture motor. Can you post the link and/or phone how to reach this shop? I would like to fix and keep my K-30.
Thanks in advance!
Leo

Last edited by photolady95; 02-20-2016 at 05:03 PM. Reason: removed email to protect your privacy and keep spammers out
01-25-2016, 07:57 AM   #21
Senior Member




Join Date: Aug 2011
Location: Silicon Valley California
Photos: Gallery
Posts: 122
QuoteOriginally posted by nucleon Quote
I have K-30 with a failed aperture motor. Can you post the link and/or phone how to reach this shop? I would like to fix and keep my K-30.
Thanks in advance!
Leo
PS just in case my email: nucleonbge@gmail.com
Hello nucleon
Ricoh Imaging Americas Corporation - Service & Repair
Click above link and they will give you instruction on shipping your camera out for repair.

Rick
01-26-2016, 11:42 PM   #22
Forum Member




Join Date: May 2015
Posts: 58
Original Poster
QuoteOriginally posted by Hinomaru Quote
Hello nucleon
Ricoh Imaging Americas Corporation - Service & Repair
Click above link and they will give you instruction on shipping your camera out for repair.

Rick
Does anyone knows what is the price to replace the fail Aperture Motor Block repair?
Thank you.
Leo
02-06-2016, 05:56 PM   #23
Moderator
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 9,755
Mine started acting up two weeks ago. I fixed it the first time by removing the battery and leaving it out for about 20 minutes. Changed lenses also from using an all manual lens to an auto with no aperture ring. Today, it started with the black frame again. And nothing I did would fix it this time. I was using a lens with an aperture ring but no A setting.

I just checked with Ricoh service and they want $206 to fix it. I can buy a brand new K-50 for just under $300. I think this is what I'm going to do.

02-06-2016, 07:22 PM   #24
Senior Member




Join Date: Aug 2011
Location: Silicon Valley California
Photos: Gallery
Posts: 122
QuoteOriginally posted by photolady95 Quote
Mine started acting up two weeks ago. I fixed it the first time by removing the battery and leaving it out for about 20 minutes. Changed lenses also from using an all manual lens to an auto with no aperture ring. Today, it started with the black frame again. And nothing I did would fix it this time. I was using a lens with an aperture ring but no A setting.

I just checked with Ricoh service and they want $206 to fix it. I can buy a brand new K-50 for just under $300. I think this is what I'm going to do.
Well, I had my K-50 (it only had 1200 shutter count & practically new) luckily fixed under warranty with the same problem. I believe both K-30 - & K-50 use the exact same Diaphragm Control Block assembly. I'm crossing my fingers that the newly replaced part won't fail but time will tell. There are quite a number of K-30 and K-50 getting the black frame problem when reading various forums. I think it was a bad design and hopefully Pentax/Ricoh will change to a better one on future models. Looks like K3 & K3II isn't affected so their design of their Diaphragm Control Block is without problem.

Rick
02-07-2016, 02:39 AM   #25
Moderator
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 9,755
My K-30 was not under warranty, I bought it used from a forum member three years ago and it had 30,000 + actuations on it. I thought about a K3 or K3ll but don't have the funds for either of those. I'll take my chances on a brand new K-50 with warranty.
02-08-2016, 12:19 PM   #26
Pentaxian
richandfleur's Avatar

Join Date: Mar 2014
Location: Palmerston North, New Zealand
Photos: Albums
Posts: 1,199
You can still use the K-30/K-50, just not to get the camera to meter or change the aperture.


Future examples include:


video only camera
macro tubes
timelapse
old school manual mode only


All of which require the lens to have a manual aperture ring. So either old school film manual, or a lot of Tamron lenses have these also for example.
02-08-2016, 01:41 PM   #27
Moderator
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 9,755
QuoteOriginally posted by richandfleur Quote
old school manual mode only
This how I was shooting, how I always shoot. Fully manual, in M mode. The LCD is blank, or black and there is no data showing at all. Photos taken are black, so no, I can't use the camera in this situation.

The lens I was using is an all manual with aperture ring. Not even an A setting. It's a Tamron, 90mm f2.8 but not the digital one, it's the all manual one.

And I've changed my mind about buying a k-50, I'm going to get the K-30 fixed.

Last edited by photolady95; 02-20-2016 at 05:07 PM.
02-20-2016, 04:33 PM   #28
Forum Member




Join Date: Oct 2013
Posts: 77
QuoteOriginally posted by photolady95 Quote
This how I was shooting, how I always shoot. Fully manual, in M mode. The LCD is blank, or black and there is no data showing at all. Photos taken are black, so no, I can't use the camera in this situation.

The lens I was using is an all manual with aperture ring. Not even an A setting. It's a Tamron, 90mm f2.8 but not the digital one, it's the all manual one.

And I've changed my mind about buying a k-50, I'm going to get the K-30 fixed.
I've heard the K50 model can have the same issue.
Thats why I'm not even trying for the K50.
I'm trying to avoid the build quality of K30/K50 all together right now.

Last edited by photolady95; 02-20-2016 at 05:08 PM.
02-20-2016, 05:06 PM   #29
Moderator
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 9,755
I'm hoping if they fix the K-30, it will be with better parts.
02-20-2016, 06:45 PM   #30
Forum Member




Join Date: Oct 2013
Posts: 77
QuoteOriginally posted by photolady95 Quote
I'm hoping if they fix the K-30, it will be with better parts.
Do they grantee that it won't happen again ? Like a warranty of some sorts?
Mine developed the issue around 7,000 actuation. Literally developed 3 months after my warranty expired.
I'm shopping around for K3s right now. Hoping to land something in the price range of 350-400. Saw one guy selling his for 350. rest are going around 450-500 ish. I dont' get why people spend 500.... for a used K3 when they can buy a new one with warranty for $600.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
black frame, camera, clicks, firmware, fix, frames, hour, k-30, k-30 black frame, k-50, k30, k50, leo, minutes, pentax k30, pentax k50, shutter, ver
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k-30: randomly getting black output images icy Pentax K-30 & K-50 17 10-22-2015 11:36 PM
Pentax K-3 Black Frame Noise Reduction? sethman2010 Pentax K-3 6 02-24-2015 05:07 PM
Black at the top right of the frame? ZombieArmy Troubleshooting and Beginner Help 9 09-05-2014 07:19 PM
For Sale - Sold: Pentax K-30 Kit Black lewis44 Sold Items 2 04-30-2014 05:15 PM
K-3 black frame StarDust Pentax K-3 2 01-29-2014 07:28 AM



All times are GMT -7. The time now is 12:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top