Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-15-2021, 11:59 PM   #376
Site Supporter
Site Supporter




Join Date: Dec 2020
Posts: 25
QuoteOriginally posted by fgpinarli Quote
Thank you, I appreciate The info
FWIW....the repair done on my K-30 by the people at PC35, which apparently involved grinding, has worked well for over a year.

01-16-2021, 01:33 AM   #377
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2015
Posts: 1,448
QuoteOriginally posted by rlmartidale Quote
FWIW....the repair done on my K-30 by the people at PC35, which apparently involved grinding, has worked well for over a year.
Double posting! You already posted this in another thread! Why?

Anyway:

I'd advice this adress only in real emergency, the way how they grind the plunger is particularely bad
Check this thread for further details:
Solenoid problem return plus sound - PentaxForums.com

and carefully study:
Why you shouldn't file/sand the plunger of the green Chinasolenoid but replace it - PentaxForums.com
01-16-2021, 08:09 PM   #378
Site Supporter
Site Supporter




Join Date: Dec 2020
Posts: 25
I will certainly speak up if it fails....
03-07-2021, 09:46 AM - 1 Like   #379
Site Supporter
Site Supporter
bobphoenix's Avatar

Join Date: Apr 2013
Location: Norwich, Connecticut
Photos: Gallery | Albums
Posts: 350
Not to flog a dead horse but...

I picked up a k-30 from a charity auction site two days ago and last night I finally unboxed it.
This morning (when there was abundant light...) I started to fool around with it... The first thing I did was to reset all the settings and user options, format an SD card, then update the firmwear.
I also changed the "Aperture Ring" setting to enable, fitted an 18-55 DAL WR lens on it and took some pictures on auto...
They looked under exposed by an EV of -5 or Shutter speed double the correct exposure with lens stopped down to f22.

Now, I am still confused, because I've conducted the test from the beginning of this sticky thread, using an "F" lens with an "A" aperture, a Pentax "DAL" lens (setting the shutter speed and aperture in the camera) and a completely manual SMC lens (SMC 50mm 1.4) and the results are all over the place.

If I read the test instruction correctly... if I have the aperture block failure, the "A" lens will give me dark image in "A" mode, but near normal image with an aperture selected, (if all other settings are correct for the image.)

Then I did the same test with my manual 50mm... (I had no auto mode to compare)

Then I manually set up the camera with the crop sensor lens that is made for the K-30. (a DAL 18-55mm).

Here are the results (all images are marked with the lens and settings.

So, after looking at these images, my question is... am I dealing with the "aperture block failure" with this camera?






Correct exposure


Deliberately underexposed.




This is the settings the cameras computer told the camera to set the aperture, speed and ISO.


Last edited by bobphoenix; 03-07-2021 at 08:35 PM.
03-07-2021, 09:53 AM   #380
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2015
Posts: 1,448
Thats how you test it and then know for sure:
Detection of aperture block/diaphragm-block failure/stuck solenoid K-30, K-50, K500 - PentaxForums.com

So the F-lens is ideal for it.

And then ... because it is most likely ABF:
Manual solenoid replacement Pentax K30 / Discharge flash-condenser / Solenoid choice - PentaxForums.com
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, aperture block failure, block, camera, change, couple, dark frame, date, diagnosis, failure, issue, k-30, k-50, lens, lenses, pentax, pentax k30, pentax k50, people, repair, shutter, step, test, tutorial, unit, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 or K-50 on TV fgaudet Pentax DSLR Discussion 22 11-09-2014 08:14 PM
For Sale - Sold: Focusingscreens.com EE-S Screen for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 Aperturae Sold Items 6 10-06-2014 06:49 AM
Pentax K-30 Problems. Won't turn on. steezylistic Troubleshooting and Beginner Help 8 07-13-2014 10:45 AM
K-500 or K-30/50 Rayak Pentax K-30 & K-50 6 06-11-2014 01:15 AM
For Sale - Sold: KatzEye Split-Prism Focusing Screen - for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 Eyewanders Sold Items 7 04-15-2014 08:35 PM



All times are GMT -7. The time now is 08:54 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top