Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-05-2016, 04:15 PM   #151
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
OK update, the shutter mechanism controls itself. In other words it has two powerful electronic magnets the open and shut the shutter. one shutter opens and the other on follows it. So the mirror motor controls the mirror and the aperture and that magnet we were all looking at triggers all of it. so if you have dark frames it means your shutter is going.T he good news is it is a cheap part. Ithink one of the rubber dampers fell into it and jammed it so I am in the mood to rebuild this beast also. OK further edit I had to rebuild this shutter mechanism and exercise the the daylights out of it.


Last edited by niceshot; 07-05-2016 at 05:39 PM.
07-05-2016, 07:00 PM   #152
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
shutter block rebuild

ok here are some shots of a shutter rebuild the first picture is how it shouldn't look, the rest are progress and the last is finished
Attached Images
View Picture EXIF
PENTAX K-30  Photo 
View Picture EXIF
PENTAX K-30  Photo 
View Picture EXIF
PENTAX K-30  Photo 
View Picture EXIF
PENTAX K-30  Photo 
07-05-2016, 08:19 PM   #153
Veteran Member
IgorZ's Avatar

Join Date: Aug 2015
Location: Ottawa
Posts: 734
QuoteOriginally posted by niceshot Quote
ok here are some shots of a shutter rebuild the first picture is how it shouldn't look, the rest are progress and the last is finished
Thanks for posting this. No more black frames I hope?
07-06-2016, 02:23 AM   #154
ase
New Member




Join Date: Jul 2016
Posts: 6
Does anybody know the failure rate? 1 over 100, 1000, 10000, etc? Thanks

07-06-2016, 03:33 AM   #155
Senior Member
Nuno Almeida's Avatar

Join Date: Sep 2014
Location: Aveiro
Posts: 142
QuoteOriginally posted by niceshot Quote
ok here are some shots of a shutter rebuild the first picture is how it shouldn't look, the rest are progress and the last is finished
Good job, and how are the results coming?
07-08-2016, 06:32 PM   #156
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
Ok I have rebuilt the aperture control block today and found out what cause the problem. their is a spring inside the aperture control box that becomes un sprung and causes it not to engage. I have also replace the mirror motor
07-08-2016, 08:43 PM   #157
Veteran Member
IgorZ's Avatar

Join Date: Aug 2015
Location: Ottawa
Posts: 734
QuoteOriginally posted by niceshot Quote
Ok I have rebuilt the aperture control block today and found out what cause the problem. their is a spring inside the aperture control box that becomes un sprung and causes it not to engage. I have also replace the mirror motor
Does it work properly now?
07-10-2016, 07:59 AM   #158
Senior Member




Join Date: Feb 2016
Posts: 184
QuoteOriginally posted by niceshot Quote
Ok I have rebuilt the aperture control block today and found out what cause the problem. their is a spring inside the aperture control box that becomes un sprung and causes it not to engage. I have also replace the mirror motor
You mean that spring gets off its hook on one end? There is one of the Russians who said to have solved the problem by relocating a spring. Here is what he said:
"moved the magnet down in the slot and adjusted the spring on a lever that is circled in white in the photo above. He said that the spring should be in a little groove at the end of the L-shaped lever"
You think you might be talking about the same spring?

07-10-2016, 08:08 AM   #159
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
QuoteOriginally posted by JoseFF Quote
You mean that spring gets off its hook on one end? There is one of the Russians who said to have solved the problem by relocating a spring. Here is what he said:
"moved the magnet down in the slot and adjusted the spring on a lever that is circled in white in the photo above. He said that the spring should be in a little groove at the end of the L-shaped lever"
You think you might be talking about the same spring?
yes the spring inside the aperture block . but the only way to get to it is to completely dissemblance the camera also whilist there replace the mirror motor and the shutter block for good measure.
07-10-2016, 08:36 AM   #160
Senior Member




Join Date: Feb 2016
Posts: 184
QuoteOriginally posted by niceshot Quote
yes the spring inside the aperture block . but the only way to get to it is to completely dissemblance the camera also whilist there replace the mirror motor and the shutter block for good measure.
What did you do with the spring? Replace it? Or relocate it?
07-10-2016, 08:50 AM   #161
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
QuoteOriginally posted by JoseFF Quote
What did you do with the spring? Replace it? Or relocate it?
Relocate it , what is does is engage the cogged gear and locks it up , the test is if you push the lever and it doent stop the white geat from turning then the spring isn't strong enough
07-10-2016, 08:59 AM   #162
Senior Member




Join Date: Feb 2016
Posts: 184
QuoteOriginally posted by niceshot Quote
Relocate it , what is does is engage the cogged gear and locks it up , the test is if you push the lever and it doent stop the white geat from turning then the spring isn't strong enough
Could you show a picture of it?
07-10-2016, 09:41 AM   #163
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
yes i will here https://www.pentaxforums.com/forums/189-repairs-warranty-service/325334-k-30-k-50-ap
07-10-2016, 11:40 PM   #164
New Member




Join Date: Feb 2016
Posts: 4
Hello
I put this "solution" in another thread, I hope that someone will help.
I too have after just over two years occurred the same problem.
I read in Spain pentaxforum of a user who discovered that using AA batteries go well exposed photos from the first shot.
I have an adapter for AA batteries, I've tried and so far goes perfectly.
As you can read, the problem is typical of Pentax k30, k50 and k500.
I hope it helps.
Greetings.


https://www.pentaxforums.com/forums/151-pentax-k-30-k-50/264514-pentax-k-30-p...ng-dark-2.html
Problema con exposimetro K30 - Pentaxeros.com
07-11-2016, 01:58 AM   #165
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 967
QuoteOriginally posted by ludpi Quote
Hello
I put this "solution" in another thread, I hope that someone will help.
I too have after just over two years occurred the same problem.
I read in Spain pentaxforum of a user who discovered that using AA batteries go well exposed photos from the first shot.
I have an adapter for AA batteries, I've tried and so far goes perfectly.
As you can read, the problem is typical of Pentax k30, k50 and k500.
I hope it helps.
Greetings.


https://www.pentaxforums.com/forums/151-pentax-k-30-k-50/264514-pentax-k-30-p...ng-dark-2.html
Problema con exposimetro K30 - Pentaxeros.com
//// Yes that might help it the beginning but in the end, the camera will still fail. there are two problems one the aperture block motor gets tired, 2 the shutter mechanism fails to fire or gets jammed as it did on mine.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, aperture block failue, block, block failue repair, camera, cameras, cost, details, failue repair solution, failure, forum, k-30, k-50, k-50 aperture block, mount, nikon, pentax k30, pentax k50, plate, post, repair, results, russian, translator, union, warranty
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: KatzEye Focus Screen for K-3 (K-3, K-5, K-5II, K-7, K-30, K-50, K-500), New or LN fwcetus Sold Items 15 05-07-2016 08:01 PM
Why A K-S1 Instead Of The K-50 / K-30? I'm A Pentaxian Pentax K-S1 & K-S2 71 12-24-2015 03:50 AM
Wanted - Acquired: Wanted K-30/K-50/K-500/K-r 12345 Sold Items 13 09-12-2015 09:51 AM
For Sale - Sold: Focusingscreens.com EE-S Screen for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 Aperturae Sold Items 6 10-06-2014 06:49 AM
For Sale - Sold: KatzEye Split-Prism Focusing Screen - for K-3, K-5, K-5II, K-7, K-30, K-50 & K-500 chickentender Sold Items 7 04-15-2014 08:35 PM



All times are GMT -7. The time now is 01:05 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top