Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-27-2016, 09:43 PM   #1
Senior Member
grog85361's Avatar

Join Date: Dec 2010
Location: Phoenix Arizona
Photos: Gallery
Posts: 211
K30 stuck at F40???

I came across two K30's on ebay from the same seller, claiming that both are stuck at f40 no matter what he tries to set it to. I asked the seller if he was mistaking the viewfinder display for f4.0, his response was: "I too doubt that the lens actually goes to f/40, it's just that I get my only good exposures, when the in-camera read-out indicates an f/40."

It is strange, too , that he has two K30's with that show this "malfunction." Perhaps the decimal point doesn't show in the viewfinder display? I didn't pursue further questions, like what the exif was showing, nor ask for a sample image. I find it rather odd. What do you think?

About Mint Appearing Pentax K30 That Does not Work Right Read 027075218109 | eBay

About Mint Appearing Pentax K30 That Does not Work Right Read in Box 027075218109 | eBay

07-27-2016, 10:23 PM   #2
Site Supporter




Join Date: May 2016
Posts: 500
Is he using the same broken lens on both of them?
07-27-2016, 11:31 PM   #3
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,750
Perhaps the aperture control block is bad and it always stops all the way down. If he sets the camera to f40 the other exposure factors will be correct. Just a thought.
07-28-2016, 07:29 AM   #4
Loyal Site Supporter




Join Date: Apr 2008
Location: Upstate NY, USA
Posts: 256
I would certainly think these are both aperture block failures. I don't know what lens was being used to evaluate the problems but I am not familiar with too many lens that will stop all the way down to F40. I did experiment quickly with my K-30. Using M mode and a manual lens (no A setting), it is possible for the viewfinder display to show "40 F--". The 40 in this case is really the shutter speed but that was the closest I could get to an F40 display.

07-28-2016, 07:41 AM   #5
mee
Site Supporter




Join Date: May 2010
Posts: 5,664
aperture control block is my guess too.

That or this K-30 is in Ferrari mode.
08-01-2016, 08:37 AM   #6
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,102
QuoteOriginally posted by mee Quote
aperture control block is my guess too.

That or this K-30 is in Ferrari mode.
Lol XD my fails sometimes....have started to use it with M lenses and works +- good XD but it's black unlike Ferrari

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
display, ebay, k-30, k-50, k30, mint, pentax, pentax k30, pentax k50, seller, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Machinery F40 Motorsports Sailor Post Your Photos! 4 09-25-2015 08:22 AM
K30 getting stuck in preview adwb Pentax K-30 & K-50 17 04-13-2014 11:44 PM
M42 Adaptall stuck in K30!?!?! NomNamNom Troubleshooting and Beginner Help 7 03-14-2014 07:41 AM
k30 stuck on a setting chashub Troubleshooting and Beginner Help 5 07-17-2013 12:14 PM
Pentax DA 18-55 F40 gabymarian Pentax SLR Lens Discussion 9 04-08-2009 06:03 PM



All times are GMT -7. The time now is 11:51 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top