Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-14-2017, 01:55 AM - 1 Like   #91
Senior Member




Join Date: Mar 2013
Location: Middle of Siberia
Photos: Gallery
Posts: 157
Original Poster
QuoteOriginally posted by Jeff Lopez Quote
How did you cut the Super Me screen? I have the same screen but I hvent cut it yet
It's rather simple, but time-consuming.
I've measured the original FS with a caliper, marked the necessary rectangle in the middle of Super Me screen with a felt-tip pen, roughly cut the screen with an edge cutter, and then fine-tuned the screen to the right size with my wife's nail file

06-14-2017, 09:25 AM   #92
Senior Member




Join Date: Mar 2013
Location: Middle of Siberia
Photos: Gallery
Posts: 157
Original Poster
Experiment with K-01 has failed.
The camera became crazy after installing the firmware from K-50, and it seems to be impossible to revert it to the original firmware.
06-14-2017, 02:50 PM   #93
New Member




Join Date: Apr 2016
Location: Tirana
Posts: 19
sorry to hear that, too bad!
06-18-2017, 09:26 PM   #94
Veteran Member




Join Date: Dec 2016
Posts: 459
QuoteOriginally posted by ABel Quote
It's rather simple, but time-consuming.
I've measured the original FS with a caliper, marked the necessary rectangle in the middle of Super Me screen with a felt-tip pen, roughly cut the screen with an edge cutter, and then fine-tuned the screen to the right size with my wife's nail file
Did that and it works great! now it focuses right on spot matching the green focus led..Thanks Abel..

06-18-2017, 11:03 PM   #95
Senior Member
iheiramo's Avatar

Join Date: Nov 2016
Location: Espoo
Photos: Albums
Posts: 282
QuoteOriginally posted by iheiramo Quote
Has anybody tried how well K30/50 upgrade work with Toshiban FlashAir 32GB card?

EDIT: Not important anymore. I upgraded the camera and orded the card. 16GB instead of 32GB as they were out of stock, but 16 is enough for me.
I upgraded to the K50 firmware. K30 works well with it. Might be a little faster now, but not sure as I don't have second body to compare. Nothing negative so far.

FlashAir works and does what I wanted it to do and that is to have a preview of a shot on a better and larger screen than the one on the camera. Apparently the camera does not need to support EyeFi for FlashAir to work.
07-04-2017, 11:17 PM   #96
Veteran Member
madbrain's Avatar

Join Date: May 2008
Location: San Jose, CA
Posts: 808
Thanks for the firmware. I applied it my K-30 and it worked fine.

I was hoping for some video improvements, but alas, contrary to what was quoted earlier , video recording does not stop at "4GB or 25 minutes, whichever comes first". In the highest quality, I'm limited to 16min38s.
The resulting MOV file is 2.6GB. So, neither the 25 minutes nor 4GB were hit. The countdown started from 16min39s right from pressing the shutter in video mode
Guess this is nothing new, just broken video as usual for Pentax.

I have yet to shoot stills. Need to restore my settings into the camera now besides date/time.
07-06-2017, 01:27 PM   #97
Veteran Member




Join Date: May 2008
Location: London, UK
Posts: 464
This thread is very interesting as I have a K-30 (and also a K-3 II, which may "come into the equation" as well), mainly for days out and holidays, and an original 55-300 but that combo proves to have "too slow" AF for many things.

Therefore I'm considering the "K-40" upgrade, but also getting the 55-300 PLM version of that lens and so would like to know if anyone has yet tried that combo?

Thanks in advance for any input.

Last edited by jeallen01; 07-06-2017 at 01:43 PM.
07-14-2017, 07:52 AM   #98
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,153
I think I have found somthing..k30 ha now a TTL flash lag(pre-flash and then after a half a sec the main flash). Like the K3. KS-2 works still instantly

noinon..it was red eye preflash.. if you use flash exclusively wireless adn then you put in the camera..no problems!


Last edited by AldaCZ; 07-14-2017 at 08:03 AM.
07-26-2017, 09:34 AM   #99
New Member




Join Date: Sep 2012
Posts: 13
QuoteOriginally posted by AldaCZ Quote
I think I have found somthing..k30 ha now a TTL flash lag(pre-flash and then after a half a sec the main flash). Like the K3. KS-2 works still instantly

noinon..it was red eye preflash.. if you use flash exclusively wireless adn then you put in the camera..no problems!
Do you find that using an external flash?
Using my k30 integrated flash, works fine.
07-26-2017, 09:39 AM   #100
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,153
QuoteOriginally posted by Chosa Quote
Do you find that using an external flash?
Using my k30 integrated flash, works fine.
I had red eye reduction on I used Metz 52 via a pair of Cactus V6 2

It's all fine!
07-27-2017, 01:02 PM   #101
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,254
Just updated to the 1.10 fw on my K30 and all seems to work great, I don't have a PLM lens but it works with my DA 33-300 and DA 18-135 just great, no problems with my FA lenses or DA primes, glad I stumbled across this tread, I will leave it loaded to see if I can see any AF improvements
07-27-2017, 03:49 PM   #102
Pentaxian




Join Date: Sep 2013
Location: Phoenix, AZ
Photos: Albums
Posts: 660
Is it possible to use the K50 firmware file on the Ricoh website to update a K30? What is different about the link to the file in this thread?
07-27-2017, 04:55 PM   #103
Pentaxian
hnikesch's Avatar

Join Date: May 2009
Location: Michigan, USA
Photos: Albums
Posts: 1,254
QuoteOriginally posted by stillshot2 Quote
Is it possible to use the K50 firmware file on the Ricoh website to update a K30? What is different about the link to the file in this thread?
No the firmware has to be altered to load on the K30
07-31-2017, 10:30 AM - 2 Likes   #104
Junior Member




Join Date: Jun 2009
Posts: 33
QuoteOriginally posted by ABel Quote
Experiment with K-01 has failed.
The camera became crazy after installing the firmware from K-50, and it seems to be impossible to revert it to the original firmware.
PM me. I can perhaps help to get it restore.
08-10-2017, 07:59 AM   #105
Senior Member




Join Date: Mar 2013
Location: Middle of Siberia
Photos: Gallery
Posts: 157
Original Poster
QuoteOriginally posted by protocold Quote
PM me. I can perhaps help to get it restore.
The owner of that bricked K-01 has fortunately repaired the camera via Ricoh service.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, eye-fi, firmware, k-30, k-30 firmware, k-50, kaf4, lens, menu, pentax k30, pentax k50, settings, support, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30&k-50 firmware bschriver11 Pentax K-30 & K-50 2 02-20-2016 10:40 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
K50 firmware running on a K30? Brownie4u Pentax DSLR Discussion 17 07-18-2013 11:19 AM
For Sale - Sold: K-5, 16-50,50-135,65-250, Sigma 17-50, 50 1.4, 50 1.8, Tamron 90 2.8, Flashes virarfast Sold Items 8 04-04-2013 02:30 PM
For Sale - Sold: SMC Pentax-A 50's: 50/2.8 Macro, 50/1.4, 50/1.7, 50/2 arpaagent Sold Items 14 01-16-2009 08:06 PM



All times are GMT -7. The time now is 05:25 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top