Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-05-2017, 02:39 PM - 1 Like   #1
New Member




Join Date: Aug 2017
Posts: 23
K-50 MF selector issue

I just bought a Pentax K-50 this past week, Trying to figure it all out. I do not have any auto focus lenses I got the standard DA L kit lenses 18-55 and 50-200. The issue I am having is the selector for the AF.s, C, MF, will not switch into the MF position. It goes back and forth between the AF.s and C positions but not the MF. I have tried to move it to that position with no lens in place, with the kit lenses in place, and with my older pentax manual lenses and still it cannot be switched into MF on the selector. In the display in the back while taking pics the setting displayed is always showing MF, I assume that this is due to the camera recognizing the fact that there is no auto focus lens installed, Is this normal? Am I missing something? or is there a problem that needs to be repaired? please help me out if you can. Just getting restarted in photography after a 20 year break.. Thanks

08-05-2017, 03:03 PM   #2
amateur dirt farmer...
Loyal Site Supporter
pepperberry farm's Avatar

Join Date: Dec 2014
Location: probably out in a field somewhere...
Photos: Gallery | Albums
Posts: 12,034
the DA L 18-55 and 50-200 are auto-focus lenses

if the switch will not move to the MF position, you may want to inquire from the seller if this was a known issue or not...
08-05-2017, 03:06 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,545
QuoteOriginally posted by Refotog156 Quote
I just bought a Pentax K-50 this past week, Trying to figure it all out. I do not have any auto focus lenses I got the standard DA L kit lenses 18-55 and 50-200. The issue I am having is the selector for the AF.s, C, MF, will not switch into the MF position. It goes back and forth between the AF.s and C positions but not the MF. I have tried to move it to that position with no lens in place, with the kit lenses in place, and with my older pentax manual lenses and still it cannot be switched into MF on the selector. In the display in the back while taking pics the setting displayed is always showing MF, I assume that this is due to the camera recognizing the fact that there is no auto focus lens installed, Is this normal? Am I missing something? or is there a problem that needs to be repaired? please help me out if you can. Just getting restarted in photography after a 20 year break.. Thanks
The 18-55 and 50-200mm kit lenses are both auto focus.

If the switch is set to AF but no AF lens is mounted, it's normal for the display to indicate MF.

However, it is not normal for the camera to fail to activate MF when that setting is selected on the switch, regardless of the lens used. Similarly, if the switch physically refuses to go into the MF setting, this would indicate a mechanical failure in the AF drive shaft and I would go ahead and get the body exchanged (or repaired under warranty).

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-05-2017, 05:25 PM - 1 Like   #4
New Member




Join Date: Aug 2017
Posts: 23
Original Poster
thamks

QuoteOriginally posted by Adam Quote
The 18-55 and 50-200mm kit lenses are both auto focus.

If the switch is set to AF but no AF lens is mounted, it's normal for the display to indicate MF.

However, it is not normal for the camera to fail to activate MF when that setting is selected on the switch, regardless of the lens used. Similarly, if the switch physically refuses to go into the MF setting, this would indicate a mechanical failure in the AF drive shaft and I would go ahead and get the body exchanged (or repaired under warranty).


Adam thanks. The swithch physically won't move to the MF position, and the display constantly reads MF in the upper right where the auto focus status is supposed to be, even though the switch is in the AF.s position. Also if the DA l lenses are both auto focus then there must be a problem as neither of the lenses are activated by the camera to focus. I will contact the seller as it is under warranty

08-05-2017, 05:58 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,545
QuoteOriginally posted by Refotog156 Quote
Adam thanks. The swithch physically won't move to the MF position, and the display constantly reads MF in the upper right where the auto focus status is supposed to be, even though the switch is in the AF.s position. Also if the DA l lenses are both auto focus then there must be a problem as neither of the lenses are activated by the camera to focus. I will contact the seller as it is under warranty
Then I'd say the camera is definitely broken, let us know how the repair goes.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af.s, focus, issue, k-30, k-50, k-50 mf selector, kit, lens, lenses, mf, pentax k30, pentax k50, position, selector
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dial mode selector spare part B3rty Repairs and Warranty Service 3 08-31-2016 12:11 PM
"Click" in between "C" and "MF" mode on focus selector? K-50 maxwolfie Pentax K-30 & K-50 3 01-29-2015 04:19 AM
Pentax 67 shutterspeed selector screws jossbomal Troubleshooting and Beginner Help 2 08-21-2012 12:48 AM
Shutter selector issue Technomage Troubleshooting and Beginner Help 2 08-13-2011 02:50 PM
K-7 AF-C and Auto AF selector raider Troubleshooting and Beginner Help 6 11-08-2010 06:00 AM



All times are GMT -7. The time now is 04:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top