Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-11-2020, 03:38 AM   #1
New Member




Join Date: Aug 2017
Posts: 8
K-50: Shutter stuck closed mirror stuck in upper position after power failure

I experimented with powering the Pentax K-50 from USB Power using a DC-DC step-up converter to reach 6.4 V.

Unluckily I did not think of adding a buffer condensator.

So, I tested the camera in B-mode everything worked fine but when I released the shutter, the camera made a continuous beeping sound (likely from shutter, or magnet, not from speaker, I think) and I could not switch it of.

Mirror stuck in upward position.


After adding normal batteries I could switch it on again. I heard 2 short beeps (again from shutter I think) and the menu was there. But the nmirror stays in upper position and the shutter won't open. Neither for normal shooting or live view nor for sensor cleaning.

So I seems I let the shutter-mirror system get stuck in a problematic state which can not recover on its own.

Is there any way to reset the mirror-shutter system w/o taking the camera apart ?

Is there a way when the camera is taken apart to reset the whole machanical system ?

I would be very grateful for some hints on how to fix this problem.

Thank you very much in advance.

05-11-2020, 05:42 AM   #2
Senior Member




Join Date: Aug 2017
Posts: 263
QuoteOriginally posted by aaron_r Quote
I experimented with powering the Pentax K-50 from USB Power using a DC-DC step-up converter to reach 6.4 V.

Unluckily I did not think of adding a buffer condensator.

So, I tested the camera in B-mode everything worked fine but when I released the shutter, the camera made a continuous beeping sound (likely from shutter, or magnet, not from speaker, I think) and I could not switch it of.

Mirror stuck in upward position.


After adding normal batteries I could switch it on again. I heard 2 short beeps (again from shutter I think) and the menu was there. But the nmirror stays in upper position and the shutter won't open. Neither for normal shooting or live view nor for sensor cleaning.

So I seems I let the shutter-mirror system get stuck in a problematic state which can not recover on its own.

Is there any way to reset the mirror-shutter system w/o taking the camera apart ?

Is there a way when the camera is taken apart to reset the whole machanical system ?

I would be very grateful for some hints on how to fix this problem.

Thank you very much in advance.
Unfortunately, the beeps indicate that you have system failure, it is not a power failure. The system failure is the result of your experiment. Perhaps you can try to reset the system to its original settings. But I fear that the beeps announced some unpleasantness regarding the further use of your camera.
05-11-2020, 05:56 AM   #3
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
QuoteOriginally posted by AfterPentax Quote
Unfortunately, the beeps indicate that you have system failure, it is not a power failure. The system failure is the result of your experiment. Perhaps you can try to reset the system to its original settings. But I fear that the beeps announced some unpleasantness regarding the further use of your camera.
Hm, that would be a pitty ... do you mean the factory reset or is there another way to also reset the mechanics ?
05-11-2020, 06:37 AM   #4
Loyal Site Supporter
Loyal Site Supporter
BigMackCam's Avatar

Join Date: Mar 2010
Location: North-East of England
Posts: 14,951
I had something similar happen just once with my K-3, a few years ago. In my case, the mirror was stuck half way up after I took the battery out during the infamous "shutter flap" problem. I was able to gentle pull the mirror into the down position, cycled the power off and on again, and it worked just fine after that.

I don't know if this is the same as your problem, but it may be worth a try (at your own risk, of course).

05-11-2020, 06:48 AM   #5
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
QuoteOriginally posted by BigMackCam Quote
I had something similar happen just once with my K-3, a few years ago. In my case, the mirror was stuck half way up after I took the battery out during the infamous "shutter flap" problem. I was able to gentle pull the mirror into the down position, cycled the power off and on again, and it worked just fine after that.

I don't know if this is the same as your problem, but it may be worth a try (at your own risk, of course).
Thanks for the hint. Unluckily, this doesn't work for me : (
05-11-2020, 07:08 AM   #6
Pentaxian
Medex's Avatar

Join Date: May 2013
Posts: 425
does Live View still works?
05-11-2020, 07:15 AM   #7
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,014
You could try looking at the *istD series and K10D service manuals available on the Pentax Hacks website. The *istD manuals show how to set the timing on the mirror box gears. It's a major tear down to remove the diaphragm control block involving un-soldering. And the mechanisms between the *istD, K10D and K-30/50 are different so none of the timing marks or gear train maybe the same.

Removing the diaphragm control block involves a major tear-down including un-soldering. The service manuals will give you an idea of the work needed. The aperture and mirror box apparatus a different between the *istD, K10D and K-30/50 so none of the gear timing positioning may cross-over between models.

The service manual for the K-30/50 manual can be found online for a fee. It does not include the service software, interface cables and special tools so isn't of much use otherwise.
05-11-2020, 07:44 AM   #8
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
QuoteOriginally posted by Medex Quote
does Live View still works?
Nope, the cam tries but the shutter stays closed.

05-11-2020, 07:46 AM   #9
Senior Member




Join Date: Aug 2017
Posts: 263
QuoteOriginally posted by aaron_r Quote
Hm, that would be a pitty ... do you mean the factory reset or is there another way to also reset the mechanics ?
I meant the factory reset. It are the "beeps" that worry me.
05-11-2020, 09:00 AM   #10
Pentaxian
Medex's Avatar

Join Date: May 2013
Posts: 425
QuoteOriginally posted by aaron_r Quote
Nope, the cam tries but the shutter stays closed.
Then could be you damaged shutter charge motor.
Anyway try to power on your camera, choose Bulb mode 30 s, press the shutter, then quickly remove the battery and insert it quickly again.
05-11-2020, 10:00 PM   #11
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
QuoteOriginally posted by Medex Quote
Then could be you damaged shutter charge motor.
Anyway try to power on your camera, choose Bulb mode 30 s, press the shutter, then quickly remove the battery and insert it quickly again.
Will try that, thanks.
Actually, this beep sounds really sound like a died small electric motor.
05-16-2020, 11:18 PM - 1 Like   #12
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
😄 I had luck. It was "only" a broken shutter charge gear. I got the complete shutter charge system changed and now the cam is fine.

It was not due to my experimental power supply. Just happended in that moment by accident ...

Thanks for your interest and help : )
06-02-2020, 05:24 AM   #13
Site Supporter
Site Supporter




Join Date: Apr 2015
Location: Winterthur
Posts: 893
Do you by any chance have any photos of this work?
6 Days Ago   #14
New Member




Join Date: Aug 2017
Posts: 8
Original Poster
QuoteOriginally posted by photogem Quote
Do you by any chance have any photos of this work?
Sorry photogem, I do not have any photos.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-30, k-50, mirror, pentax k30, pentax k50, position, power, reset, shutter, switch, system
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax LX shutter stuck in the cocked position Robert_1 Troubleshooting and Beginner Help 13 05-14-2019 02:57 PM
K-30 mirror doesn't return fully to default position after aperture solenoid repair RayeR Pentax K-30 & K-50 6 03-18-2019 02:54 AM
Mirror stuck up, shutter stays closed LordVan Repairs and Warranty Service 5 01-04-2018 08:29 AM
Pentax MG - Stuck winder lever & Closed Shutter Mirror bloodorang3 Troubleshooting and Beginner Help 2 04-20-2017 03:24 PM
645 mirror stuck in up position gawan Pentax Medium Format 3 11-21-2011 03:38 PM



All times are GMT -7. The time now is 10:19 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top