Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-16-2021, 11:42 AM   #1
New Member




Join Date: May 2021
Posts: 2
Problems through the viewfinder

I have a Pentax K-50 which has been trouble free for some years. I have now found that photograhs I take using the viewfinder are dark as if shot in low light. When I use the Live View option the picture has the correct level of exposure. I have tried to solve this (for example setting the camera back to default settings) but this has had no effect. Are there any suggestions as to how I can solve this (without having to get it professionally repaired)?

05-16-2021, 11:56 AM   #2
Loyal Site Supporter
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 2,122
faulty solenoid

I have the same problem with my K-30.
You need to replace solenoid in your camera , look at this , many useful links :

My beloved K-30 finally failed - PentaxForums.com
05-16-2021, 05:22 PM   #3
Site Supporter
Site Supporter




Join Date: Aug 2018
Location: Arkansas, USA
Posts: 1,123
Aperture control block failure.

Dark exposure problems on K-30 or K-50? Discussion Thread - PentaxForums.com
05-16-2021, 06:31 PM   #4
Site Supporter
Site Supporter




Join Date: Jul 2019
Posts: 715
Unfortunately, what they said^. Fortunately the fix isn't too bad if you get a good solenoid (Japanese white one).

05-17-2021, 04:09 AM   #5
Senior Member




Join Date: Apr 2012
Location: Endeavour Hills, Victoria, Australia
Photos: Gallery
Posts: 174
Interesting that live view works. Is this still consistent with the aperture block issue?
05-17-2021, 05:41 AM   #6
Site Supporter
Site Supporter




Join Date: May 2018
Location: Berkshire
Posts: 55
It is consistent with the early stages of failure.

Live view holds the mirror up so only the solenoid has to operate during an exposure meaning it has all the power available. With an normal exposure the mirror is being lifted at the same time meaning the solenoid is sharing the power.
05-19-2021, 12:53 PM   #7
New Member




Join Date: May 2021
Posts: 2
Original Poster
Thanks for the information. So it seems to be a problem with both K30 and K50. Is this a problem with later Pentax cameras? Does thsi occur with other makes of camera?

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help, photography, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How difficult are K-3 III AF points to see through the viewfinder? Gray Pentax K-3 III 35 19 Hours Ago 02:33 PM
K70 will only autofocus and shoot in monitor mode, not through viewfinder snobrewer Troubleshooting and Beginner Help 8 02-06-2021 03:06 AM
Crack or mark visible through viewfinder Matty Pentax K-70 20 07-25-2019 06:31 AM
Abstract "Through and Through" ginnyfoos Post Your Photos! 2 07-30-2018 08:30 AM
Nature Through-and-through. pavpen Photo Critique 2 05-02-2014 04:22 PM



All times are GMT -7. The time now is 10:19 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top