Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-07-2014, 01:26 PM   #16
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
QuoteOriginally posted by normhead Quote
I just went out with my K-x and 60-250 4. The sun went in I didn't have great light, but decent light, and the AF on the K-x was extremely unreliable. I could coax it to work, but aiming at several targets, I had to manual focus to get it close before it would even lock focus. My guess is anything before a k-5 doesn't have the low light focusing capacity to take the one stop hit. I put the Tamron 90 2.8 and the issue was gone. My guess is there may be technical issues with the older bodies that have Pentax discouraging you from using the 1.4 with those bodies. Just too many lenses out there they might not work with.
Makes sense. Just like their disclaimers with several F5.6 lenses like the 560 AW. Better to just say "cannot support" than to say "support" and get complaints that certain combinations don't work.

03-07-2014, 02:18 PM   #17
Site Supporter
Cambo's Avatar

Join Date: Dec 2007
Location: Vancouver, BC
Photos: Gallery | Albums
Posts: 839
Strange...

Updated the firmware on my K5, but now when I push the 'Info' button, in the row of icons at the bottom, it says 'K3'...

YES I downloaded the right firmware....at least according to Adams post here.

Anybody else notice this?

Cheers,
Cameron
03-07-2014, 02:32 PM   #18
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 23,773
QuoteOriginally posted by Cambo Quote
Updated the firmware on my K5, but now when I push the 'Info' button, in the row of icons at the bottom, it says 'K3'...

YES I downloaded the right firmware....at least according to Adams post here.

Anybody else notice this?

Cheers,
Cameron
Rut roh.... how does the Camera work?
03-07-2014, 03:20 PM   #19
Veteran Member




Join Date: Apr 2010
Location: New Orleans
Photos: Gallery
Posts: 3,054
QuoteOriginally posted by Cambo Quote
Updated the firmware on my K5, but now when I push the 'Info' button, in the row of icons at the bottom, it says 'K3'...

YES I downloaded the right firmware....at least according to Adams post here.

Anybody else notice this?

Cheers,
Cameron
Free upgrade!

Did it replace the 'Pentax' stamped on the rear LCD with 'Ricoh?'

03-07-2014, 04:37 PM   #20
Pentaxian
thibs's Avatar

Join Date: Jun 2007
Location: Belgium
Photos: Albums
Posts: 5,161
QuoteOriginally posted by Ishpuini Quote
Awaldram's recent posts have given me some additional insights in this problem. The reason why SDM AF does not lock seems related to the wrong focal length causing the camera to issue wrong instructions to drive the lens' focus ring. This makes the AF miss the focus point repeatedly. Correct focal length being reported by the new TC would avoid the error.

Wim
That would explain it indeed although I thought the TC did that (changing the FL reporting) without the help of the camera firmware.
03-07-2014, 04:53 PM   #21
Pentaxian




Join Date: Apr 2007
Location: Romania
Posts: 8,427
QuoteOriginally posted by Cambo Quote
Updated the firmware on my K5, but now when I push the 'Info' button, in the row of icons at the bottom, it says 'K3'...

YES I downloaded the right firmware....at least according to Adams post here.

Anybody else notice this?

Cheers,
Cameron
The only way it could happen - to my knowledge - is if you have the "K3" white balance setting selected. I don't remember ever seeing the model number in the status screens...
Maybe you're joking?
03-07-2014, 04:55 PM - 1 Like   #22
Senior Member




Join Date: Oct 2013
Photos: Albums
Posts: 280
QuoteOriginally posted by Adam Quote
You can still use the TC on those older bodies, it just won't be recognized by the camera. It's bot surprising that Pentax has decided to end of life the older models, as that's just how it is
But the Joke is,i used the new converter with the the older firmware weeks ago,not with this new fw.
And it works fine,all exif are in the pictures.
420mm and 5.6.
This last firmware is not the first firmware for full converter use.
Maybe the old Cameraline is also working good,i think so.
Best regards
03-07-2014, 08:30 PM   #23
Forum Member
Craig66's Avatar

Join Date: Sep 2010
Location: Far South Coast. NSW. Australia
Posts: 82
QuoteOriginally posted by MadMathMind Quote
Some of the older bodies may not support the TC. Think SDM and pre-2007 bodies.
My K20 supports SDM 200F2.8 works fine.


TC will just have to wait.. If I get it at all. K3 is first on my wish list.


I was thinking of the TC with the DA*300F4 for surfing shots...


But that will have to wait now..

03-08-2014, 02:01 AM   #24
Pentaxian




Join Date: Sep 2006
Location: Antwerp, Belgium
Photos: Gallery
Posts: 1,008
QuoteOriginally posted by thibs Quote
That would explain it indeed although I thought the TC did that (changing the FL reporting) without the help of the camera firmware.
Indeed the TC does that regardless of the firmware. I thought your remark referred to the TC not making any difference compared tot earlier TCs with SDM lenses. Perhaps you were commenting on SDM in general?

Wim
03-08-2014, 08:40 AM   #25
Veteran Member




Join Date: Apr 2010
Location: New Orleans
Photos: Gallery
Posts: 3,054
My guess as to why a TC would need firmware support has to do with communication of differences in mechanical or electrical communications.

I.E. if AF system tells the screwdrive to spin 25 rotations to achieve focus on the bare lens it knows it needs to spin 32 times because of losses to the teleconverter or if it tells the SDM pins to provide a certain voltage for a certain amount of time, the time or voltage may vary to compensate for losses or latency.
03-08-2014, 11:51 AM   #26
Site Supporter




Join Date: Oct 2012
Location: North-East England
Posts: 73
I've tried the new tele with DA*300 and a 60-250, as well as comparing it to a kenko 1.5x with the SDM contacts. It was a little quicker to focus in low light, definitely sharper with the new TC than the kenko one and the colour shift was different between the two lenses. It even worked with a converted 560mm. This was on a K5II but without the recent software update. When I get chance, I'll sort out my pics. One key difference was that the new pentax TC showed the "new" focal length I was using, 300mm became 420mm etc. Quite fancy one, but I want to see what the proposed 70-210 and 135-380 might look like before I splash the cash.
03-08-2014, 12:37 PM   #27
Site Supporter
Spodeworld's Avatar

Join Date: Aug 2011
Location: New Joisey
Photos: Gallery | Albums
Posts: 1,190
No problems updating my K30 or K-01s. Really wonder if there is any performance difference outside of the update for the adapter.
03-09-2014, 05:28 PM   #28
Site Supporter
Cambo's Avatar

Join Date: Dec 2007
Location: Vancouver, BC
Photos: Gallery | Albums
Posts: 839
QuoteOriginally posted by Kunzite Quote
The only way it could happen - to my knowledge - is if you have the "K3" white balance setting selected. I don't remember ever seeing the model number in the status screens...
Maybe you're joking?
You're right, Kunzite. Thanks for this. K3 white balance was on.

Cheers,
Cameron
03-10-2014, 09:33 PM   #29
Forum Member




Join Date: Aug 2012
Posts: 58
So no support for the K30. This camera is not that old and should still be supported by Pentax.

Sorry, found it. Am now running 1.06 in the K30.

Last edited by jb0501; 03-10-2014 at 09:45 PM.
03-10-2014, 09:42 PM   #30
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,125
QuoteOriginally posted by jb0501 Quote
So no support for the K30. This camera is not that old and should still be supported by Pentax.
Support for the K30 is there, just not linked to directly from the OP. Dig a bit further and you'll find it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bodies, corrections, data, drive, firmware, firmware updates, functions, k-5, lens, pentax, pentax news, pentax rumors, screw, sdm, support, tc, teleconverter, updates
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet more questions about the Q firmware updates. jpzk Pentax Q 36 11-22-2012 02:52 PM
Firmware updates for K30, K-01 and Q RKKS08 Pentax News and Rumors 4 10-29-2012 05:59 PM
Firmware updates for Metz flashes... Catalana Pentax News and Rumors 18 03-02-2011 11:09 AM
Pentax Firmware updates artyfact Troubleshooting and Beginner Help 4 10-29-2010 10:27 PM
What are the checksums of for K10D/K100D firmware updates? mattdm Pentax DSLR and Camera Articles 12 08-09-2008 08:06 AM



All times are GMT -7. The time now is 07:17 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top