Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-08-2008, 09:14 AM   #1
New Member




Join Date: Feb 2007
Posts: 19
K10D - GX10 1.30 Firmware Debug menu via usb activation

K10D - GX10 1.30 Firmware Debug menu via usb activation.: Pentax SLR Talk Forum: Digital Photography Review


br
S.

05-08-2008, 09:29 AM   #2
Senior Member




Join Date: Jan 2007
Location: Carradale, Scotland
Posts: 289
Interest

I'll be watching this thread with interest. Thanks for posting
05-08-2008, 11:35 AM   #3
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
The guy claims that program wraps official Pentax DLL he got from some Pentax service man. All the communication with camera is done by that DLL.

If it's true it is quite safe to use it.
05-08-2008, 06:35 PM   #4
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,047
Safe DLL

QuoteOriginally posted by Edvinas Quote
The guy claims that program wraps official Pentax DLL he got from some Pentax service man. All the communication with camera is done by that DLL.

If it's true it is quite safe to use it.
... except that, by the time it gets passed around the internet a few thousand times, it is almost certain to pick up a virus or two. While I seriously doubt that there are any viruses that can attack the firmware in a K10D or K20D, once an infected DLL is called, it can do whatever it is that viruses do to your computer.

If you come across such a DLL, scan it six ways from sunday, with every antivirus program you can find, before you try to use it.

05-09-2008, 01:43 AM   #5
Veteran Member




Join Date: Sep 2007
Location: Melbourne
Posts: 602
Or download it now and keep it untouched for a few weeks. By that time any virus will become known to most anti-virus software and it will be detected.
05-09-2008, 02:10 AM   #6
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,249
At Russian Pentax forum a lot of people used it already. All work fine.
http://dednev.pisem.net/setup_gx10_dmctrl_1.1.exe

It also works with K100D super.
05-09-2008, 02:24 AM   #7
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
This could solve a few issues, thanks for posting.
05-09-2008, 11:20 AM   #8
Forum Member
Kentax's Avatar

Join Date: Dec 2007
Location: CA
Photos: Gallery
Posts: 98
interesting. just sent my camera in for repairs too..

05-09-2008, 06:07 PM   #9
Veteran Member
David's Avatar

Join Date: Jul 2007
Location: Sandy Bay, Tasmania, Australia
Photos: Albums
Posts: 344
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David
05-09-2008, 06:39 PM   #10
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,426
Download .dll

QuoteOriginally posted by ddhytz Quote
Or download it now and keep it untouched for a few weeks. By that time any virus will become known to most anti-virus software and it will be detected.
I'm not SURE this actually helps, but I have downloaded exe and dll files straight to a CD and out them away until I was certain they were OK.

Of course the file has to pass through your processing system, so if it wants to offload some trojan or malware it will do so on the way through to the CD.
05-09-2008, 09:30 PM   #11
Veteran Member




Join Date: Sep 2007
Location: Melbourne
Posts: 602
QuoteOriginally posted by David Quote
...
Anyone else experience this or is there any way to get rid of the header.
...
You need to disable the debug mode, see attachment
1. click 'connect camera'
2. click 'disable debug mode'
3. click 'confirm'
4. turn off camera and turn back on.
done.

Last edited by ddhytz; 03-06-2009 at 08:17 PM.
05-10-2008, 09:58 AM   #12
Veteran Member
Denis's Avatar

Join Date: Jan 2007
Location: St-Albert, Alberta, Canada
Posts: 333
QuoteOriginally posted by David Quote
BE CAREFUL I have used the software but have ended up with a permanent "Debug Mode" listing on my camera monitor with the Debug Mode menu items at the end of the Set Up listing on a separate page. Camera works fine in all modes and the Debug Menu items all work, but I can't get rid of the Debug Mode header.

Anyone else experience this or is there any way to get rid of the header.

I have reloaded 1.3 but to no avail. Is there an English language version of the software around?

David
It is a known problem if using Vista, fails in trying to turn debug mode off. If you have access to XP, it will solve the problem.

Denis
05-12-2008, 04:44 AM   #13
Forum Member




Join Date: Jun 2007
Location: Oman - Muscat
Photos: Albums
Posts: 57
For those interested with the Service Manual of Samsung GX-10. it can be found also on the web (info found on the same french forum thanks to them:
Pentax K10D - K20D


Manual presents all the steps to adjust SR/AF etc.
Very technical and requires a lot of equipment and software that we do not have...
So if you really want to have a look at it google : dscservicemanual
cheers,

Last edited by Mitch34; 05-12-2008 at 04:46 AM. Reason: URL did not show up first time
05-12-2008, 08:02 PM   #14
Veteran Member
David's Avatar

Join Date: Jul 2007
Location: Sandy Bay, Tasmania, Australia
Photos: Albums
Posts: 344
Thanks DDHYTZ, fixed the problem. It must have been the only click combination I did'nt try!!! While you are in the helpful mode what are the translations of the two message boxes that appear?

In any case my K10D AF was spot on, so it was all much ado about nothing.

Take Care

David
05-21-2008, 09:51 AM   #15
New Member
BeerCur's Avatar

Join Date: Aug 2007
Location: PA (OS Philly), USA
Posts: 14
Thanks

Wanted to say thank-you for alerting me to the availability of this program. Also wanted to pass along the site
- rarWebWorks Photography
Which gives a bit of detail how to use the debug menu for focusing issues.

FYI, I'm using negative 140 to "fix" my front focusing issues. I use 50 1.4 and 18-250 lenses and now both seem to provide an in-focus result.


My dog Jasmine 50 1.4. In focus at last.
Attached Images
View Picture EXIF
PENTAX K10D  Photo 

Last edited by BeerCur; 05-21-2008 at 10:02 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
debug, firmware, gx10, k10d, menu, pentax news, pentax rumors, usb
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debug menu for *ist DS v2.01+ jfsavage Pentax DSLR Discussion 6 12-13-2012 01:52 PM
K10D Firmware 1.3 Debug Mode Unleashed! RiceHigh Pentax DSLR Discussion 148 10-01-2010 01:48 PM
Debug menu access for the K100DS? Nachodog Pentax DSLR Discussion 3 04-14-2010 02:27 PM
K10d-debug menu-IR possible? Bokeh Pentax DSLR Discussion 6 05-17-2008 05:54 PM
K100D Super Debug menu joelw135 Pentax DSLR Discussion 9 10-18-2007 04:23 AM



All times are GMT -7. The time now is 08:03 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top