Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-31-2016, 02:41 AM   #196
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,939
QuoteOriginally posted by AdrianM Quote
...my newly remounted Sigma 70-200 f2.8 just freezes the camera.
You should have asked for a firmware update for your 70-200.

There are certainly copies that work just fine with a K-1.

Hopefully your model can be updated. If you provide Sigma with the serial number of your lens, they should be able to tell you whether it can be updated.

08-31-2016, 03:25 AM   #197
Pentaxian
Edgar_in_Indy's Avatar

Join Date: May 2010
Location: Indiana, USA
Photos: Gallery
Posts: 2,555
QuoteOriginally posted by Class A Quote
You should have asked for a firmware update for your 70-200.

There are certainly copies that work just fine with a K-1.

Hopefully your model can be updated. If you provide Sigma with the serial number of your lens, they should be able to tell you whether it can be updated.
I think that when I've sent lenses to Sigma's US headquarters in the past for service, they check and update firmware as a matter of routine.
08-31-2016, 04:42 AM   #198
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,600
QuoteOriginally posted by AdrianM Quote
Sigma 70-200 f2.8
Which version - OS, or HSM II?

My HSM II worked fine before it went to CRK for the fix, and worked fine on the K-1 when it came back.
08-31-2016, 11:41 PM   #199
Loyal Site Supporter
AdrianM's Avatar

Join Date: Aug 2008
Location: Ipswich, Queensland, Australia
Photos: Gallery | Albums
Posts: 547
QuoteOriginally posted by rawr Quote
Which version - OS, or HSM II?

My HSM II worked fine before it went to CRK for the fix, and worked fine on the K-1 when it came back.
It is the HSM II version of the 70-200. Still awaiting a response.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
apo, body, camera, cameras, claim, dg, f/2.8, fa, forum, hsm, k-1, k-mount, lens, lenses, mount, oem, pentax, pentax news, pentax rumors, post, products, repair, sigma, sigma ceo, tamron, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ability to use old K mount lenses on K1 is losing poll! barondla Pentax DSLR Discussion 49 03-31-2016 07:50 AM
K1 pics new update with da lenses this time zmohie Pentax News and Rumors 766 02-13-2016 04:49 PM
Sigma usb dock to suit sigma 'a', 's' & 'c' pentax mount lenses i_trax Pentax Price Watch 4 09-16-2014 03:50 PM
Adapter to use pentax lenses on nikon mount zmohie Pentax SLR Lens Discussion 6 03-11-2013 01:42 PM
Wrong Identification of Lens when attached to K-5 stl09 Pentax SLR Lens Discussion 15 02-29-2012 09:25 AM



All times are GMT -7. The time now is 02:19 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top