Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-13-2019, 05:32 AM   #16
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 11,704
QuoteOriginally posted by Paul the Sunman Quote
Can we just move on from this? It works. He just didn't give it enough time to finish.
Yep. Lightroom was estimating 55 seconds processing time per image for me, but the exported images were finished much quicker than that.

Anyone who has used DxO PhotoLab's 'PRIME' noise reduction feature will know how slow image processing can sometimes be be in RAW processors. FWIW, this new feature of Lightroom's works quicker than 'PRIME', so it's pretty easy to live with.

02-13-2019, 07:55 AM - 1 Like   #17
Site Supporter
Site Supporter
lsimpkins's Avatar

Join Date: Feb 2013
Location: SE Pennsylvania
Photos: Gallery
Posts: 355
QuoteOriginally posted by Paul the Sunman Quote
Can we just move on from this? It works. He just didn't give it enough time to finish.
The Adobe forums are filled with comments from people who have that same issue, and have followed Adobe's advice to give it more time. https://forums.adobe.com/thread/2594466
One of the keys seems to be hardware related. I just built a new machine with i7 9700k and overclocked Nvidia GTX 1060 (6GB) and the function runs fine on my K-3 dng files.

On the other hand, the new function does not seem to produce more than a very minor improvement on the images I have used it on. Two more caveats - you need to be running ver. 1809 of Windows 10 and the function does not work on tiff files - so use it before sending the image to Photoshop.
02-13-2019, 10:08 AM - 2 Likes   #18
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 11,370
QuoteOriginally posted by Paul the Sunman Quote
It says 20 sec for me on a mac pro, but hangs at about 80% done. No further progress after 5 minutes.

UPDATE: Ha, it's done. A new enhanced version is there. It's not black. Perhaps jatrax's black image was just a placeholder before the file had been written; it takes way longer than advertised.

Damned if I can see any enhancements! The file was enlarged from 50 MB to 177.5 MB though.
If nothing else, the size was enhanced.
02-13-2019, 10:47 AM   #19
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 11,933
QuoteOriginally posted by zapp Quote
was your Image black from the beginning?
No it was not
QuoteOriginally posted by Paul the Sunman Quote
Can we just move on from this? It works. He just didn't give it enough time to finish.
Sorry, no it does NOT work on my install. I have tried about a dozen images from K-3II and from K-1. All "enhance detail" runs result in a completely black image. I have waited 20 minutes and the result is the same: all black image. Also, the 'preview' is all black, clicking on the preview to show the 'original' shows the original image.

Not sure what is wrong with mine, obviously it works for some. I will do some more testing tonight.

02-14-2019, 04:53 AM   #20
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2015
Location: Avalon Peninsula, Newfoundland
Photos: Gallery | Albums
Posts: 630
QuoteOriginally posted by reh321 Quote
What 'raw development' software does support pixel shift? {I was under the impression that is not common}
Silkypix (newer versions, anyway) and DCU, of course.

And RawTherapee too, I think.

Last edited by jgnfld; 02-14-2019 at 05:14 AM.
02-14-2019, 09:07 AM   #21
Site Supporter
Site Supporter




Join Date: Apr 2008
Location: North Wales
Posts: 265
QuoteOriginally posted by jatrax Quote
No it was not
Sorry, no it does NOT work on my install. I have tried about a dozen images from K-3II and from K-1. All "enhance detail" runs result in a completely black image. I have waited 20 minutes and the result is the same: all black image. Also, the 'preview' is all black, clicking on the preview to show the 'original' shows the original image.

Not sure what is wrong with mine, obviously it works for some. I will do some more testing tonight.
It doesn't work for me either - just a pure black photo.
02-14-2019, 09:44 AM   #22
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2015
Photos: Gallery | Albums
Posts: 728
QuoteOriginally posted by jatrax Quote
Ok, the "enhance detail" function is located under Photos>enhance details. I selected a Pentax DNG file and used the enhanced function on it. The estimated time to "enhance" was shown as 40 seconds. Clicked the button and waited. The computer created a new DNG with the term 'enhanced' appended to the file name. The image is completely black, and a second test resulted in the same black image.

I then tried to convert the Pentax DNG (version 1.2) into an Adobe DNG (version 1.4). The conversion worked fine but a test with the enhance detail function again resulted in a black image.

So I conclude @Spodeworld's conclusion was correct and Pentax was left out. Puzzling to me as it is supposed to work on a DNG file.

---------- Post added 02-12-19 at 04:12 PM ----------



Did you do anything different to the file? Was it shot in DNG? What camera?
Shot in DNG on a K-1ii with a Tamron lens, processed in Lr on a 2015 MBP with AMD Radeon R9 M370X 2048 MB. Didn't do anything to the file.

Last edited by Oakland Rob; 02-14-2019 at 09:57 AM.
02-14-2019, 09:49 AM   #23
Pentaxian




Join Date: Apr 2007
Location: Romania
Posts: 12,339
QuoteOriginally posted by woodworm Quote
It doesn't work for me either - just a pure black photo.
Maybe a compatibility issue with your GPU?

02-14-2019, 09:56 AM   #24
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2015
Photos: Gallery | Albums
Posts: 728
QuoteOriginally posted by jgnfld Quote
Silkypix (newer versions, anyway) and DCU, of course.

And RawTherapee too, I think.
Yes; Rawtherapee (check the long thread hereabouts).

And Adobe (just not dynamic pixel shift, and the Enhance function doesn't work on pixel shift).
02-14-2019, 09:58 AM   #25
Site Supporter
Site Supporter




Join Date: Apr 2008
Location: North Wales
Posts: 265
QuoteOriginally posted by Kunzite Quote
Maybe a compatibility issue with your GPU?
Maybe, to be honest I'm not that bothered, just thought I'd try it as you were all talking about it.

I have a nVidia GeForce GT730, it's not the latest and greatest but I don't play games and the PC runs fine for photo and video editing.

Just installed the latest drivers but no change
02-14-2019, 11:27 AM   #26
Site Supporter
Site Supporter




Join Date: Mar 2008
Location: Utah
Posts: 40
Works for me on my 4 1/2 year-old MacBook Pro. The estimate was 25 seconds it probably took about 28 seconds.

Not very exciting though, hardly any noticeable difference on the image I tried it with…

Last edited by mstahulak; 02-14-2019 at 11:28 AM. Reason: Added more thoughts
02-14-2019, 12:04 PM   #27
Site Supporter
Site Supporter




Join Date: Apr 2008
Location: North Wales
Posts: 265
I just tried it with a raw file from my Sony RX100 and get the same black image so that suggests it's a hardware / Windows 10 / Lr issue rather than Pentax issue.
02-14-2019, 12:35 PM   #28
Pentaxian




Join Date: Dec 2015
Posts: 389
QuoteOriginally posted by woodworm Quote
I just tried it with a raw file from my Sony RX100 and get the same black image so that suggests it's a hardware / Windows 10 / Lr issue rather than Pentax issue.
Do You have all the latest updates of Win10? (try to make them manually)
02-14-2019, 04:31 PM   #29
Forum Member




Join Date: Jan 2008
Location: belgium
Posts: 52
QuoteOriginally posted by jgnfld Quote
Silkypix (newer versions, anyway) and DCU, of course.

And RawTherapee too, I think.
Silkypix doesn't support dynamic pixel shift. I quote from the Silkypix website, under 'supported digital camera's' - Pentax K1-II:
"*13 ... For RAW images shot with "Pixel Shift Resolution", several features such as a demosaicing sharpness are unavailable."
"*21 ... RAW images shot with "Image Stabilization On" mode of "Pixel Shift Resolution" are not supported. They would be loaded as the RAW images shot with "Pixel Shift Resolution" turned off."

---------- Post added 02-15-2019 at 12:33 AM ----------

QuoteOriginally posted by Oakland Rob Quote
Yes; Rawtherapee (check the long thread hereabouts).

And Adobe (just not dynamic pixel shift, and the Enhance function doesn't work on pixel shift).
Are you sure RawTherapee supports dynamic pixel shift?
02-15-2019, 09:15 AM   #30
Site Supporter
Site Supporter




Join Date: Apr 2008
Location: North Wales
Posts: 265
QuoteOriginally posted by taktoon Quote
Do You have all the latest updates of Win10? (try to make them manually)
Hi. Running build 1809 of Windows 10.

From what I've read about this it's not something I feel I'm missing out on
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
adobe, detail, details, dng, enhance, file, function, image, images, lightroom, lr, pentax, pentax news, pentax rumors, pixel, rawtherapee, shift, shot, silkypix, update
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fixing Adobe's problem with maps in LR 5 and LR 6 beholder3 Digital Processing, Software, and Printing 4 01-23-2019 05:22 PM
LR>Plugins>LR>PS>Plugins>LR>Save as a Preset? BruceBanner Digital Processing, Software, and Printing 3 04-23-2018 11:59 AM
LR update, May 2017 + GPU Acceleration issue. BruceBanner Digital Processing, Software, and Printing 2 07-29-2017 07:35 PM
Pentax lens profiles missing after LR 6.10 update lightbox Digital Processing, Software, and Printing 14 05-01-2017 01:23 PM
Question Are you allowed to ask why someone gets excluded? MetteHHH Site Suggestions and Help 8 07-04-2014 03:46 PM



All times are GMT -7. The time now is 02:14 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top