Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-02-2010, 01:41 PM   #31
Senior Member




Join Date: Apr 2007
Location: Brooklyn, NY
Posts: 116
QuoteOriginally posted by madhurvyas Quote
it seems to me aswell that AF speed/accuracy has improved on my DA*16-50,
may be its a post firmware update syndrome , but better if it stays like that for some more time.
Hmmm. It definitely didn't improve AF on my Tamron 28-75. I'll pull out some Pentax lenses to check it on them.

05-02-2010, 11:03 PM   #32
Veteran Member
StarDust's Avatar

Join Date: Apr 2008
Location: Uppsala, Sweden
Posts: 400
Only improvement for * lenses then? Unfortunately it will be a while and a few cameras down the road before I buy one of those. Hopefully the motors and glass will be improved for the new 28 MP Pentax cameras by then.
05-03-2010, 08:27 AM   #33
Veteran Member
awo425's Avatar

Join Date: Jan 2008
Location: NYC, USA
Posts: 481
As a former owner of K10D, I beleive the only thing that can improve AF of this camera is selling it on fleebay, and bying a different camera.
05-03-2010, 01:14 PM   #34
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
is it possible to update firmware while camera is in DEBUG mode?
Both of my K10s are permanently in this mode...

05-05-2010, 06:56 PM   #35
Veteran Member




Join Date: Jan 2008
Location: CT, USA
Posts: 499
I haven't downloaded the firmware update yet, but I'm positive that my fingers won't turn the focusing ring any faster after I have.
05-06-2010, 12:14 AM   #36
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
QuoteOriginally posted by 24X36NOW Quote
I haven't downloaded the firmware update yet, but I'm positive that my fingers won't turn the focusing ring any faster after I have.
you never know my friend
05-06-2010, 01:40 AM   #37
Senior Member
Billgscott's Avatar

Join Date: Apr 2008
Location: York
Posts: 235
SDHC Cards

No one seems to have posted anything about the actual reasons for the firmware upgrades. So I will.

when I first got my K20 I was using 4 cheap VEHO 8 gig cards that were fine in my K10. After about 5 - 10 shots, I got memory / card write fails on the K20 and had to get some Sandisk cards to solve the problem.

After I updated the firmware in my K20D I fitted a VEHO card and .... so far, 30 - 40 shots in, no errors reported.

Not an extensive test I know but I thought I would share.

Bill
05-06-2010, 06:21 PM   #38
New Member




Join Date: Nov 2006
Location: Minneapolis, MN USA
Posts: 5
QuoteOriginally posted by hut234 Quote
I'm not detecting a change in focus on my K10D.
My K10D with 16-50 has always had issues with locking focus when fully at 16mm. It would snap close to focused and then stop with the green hexagon just flashing.

My "fix" for it for the past two years has been to just put it in AF-C mode. The first focus-snap gets pretty close to the right focus and then I can shoot, even though it thinks "I'm not quite there".

With 1.31 it doesn't do that anymore. I can leave it in AF-S and 16mm and it locks focus and shoots like it ought to.

I'm still planning on getting a K7 this summer, but this little improvement (I swear I'm not imagining it) is welcome.

05-10-2010, 03:30 AM   #39
New Member




Join Date: Nov 2006
Location: Madrid - Spain
Posts: 6
No big AF changes but...

I have not noticed significant enhancements in AF, if any, in my K10D.

BUT i ahve noticed that the time the camera keeps now menu screens is quite short. Too much short, most of time, and not consistente. Sometimes, it reamins enough for you to check and change what needed but sometimes, it gets out of the screen before you have time to set anything.

Anybody more has also see that?
07-02-2010, 05:12 PM   #40
Inactive Account




Join Date: Jul 2010
Posts: 7
I'm having the same problem Eric had, except I did format my SD card and I DID put it in the root.

Last edited by Jeanimal; 07-02-2010 at 05:19 PM.
07-02-2010, 06:16 PM   #41
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,517
QuoteOriginally posted by Jeanimal Quote
I'm having the same problem Eric had, except I did format my SD card and I DID put it in the root.
Only thing I can think of is - did you format the card in camera or in the PC? Try formatting the card in the camera (if you haden't done that before).

Oh, slim chance the file got corrupted - also might try downloading it again. Good luck.
07-02-2010, 07:59 PM   #42
Inactive Account




Join Date: Jul 2010
Posts: 7
QuoteOriginally posted by ChipB Quote
Only thing I can think of is - did you format the card in camera or in the PC? Try formatting the card in the camera (if you haden't done that before).

Oh, slim chance the file got corrupted - also might try downloading it again. Good luck.
Thanks, Chip. Have done - SO many times. I'm starting to think the camera is defective.
07-02-2010, 09:32 PM   #43
Senior Member




Join Date: Sep 2006
Location: Grand Junction Colorado
Posts: 212
QuoteOriginally posted by Jeanimal Quote
Thanks, Chip. Have done - SO many times. I'm starting to think the camera is defective.
Did you run the exe file to unpack the txt and bin file? It is the bin file that needs to be moved to the root of the card.
07-03-2010, 08:58 AM   #44
Inactive Account




Join Date: Jul 2010
Posts: 7
QuoteOriginally posted by bobrapp Quote
Did you run the exe file to unpack the txt and bin file? It is the bin file that needs to be moved to the root of the card.
Yes, it was a bit stupider than that. I had the wrong firmware.... I actually bought a K-x not a K10, but the manual was confusing.
08-27-2010, 01:52 PM   #45
New Member




Join Date: Nov 2006
Location: FWB, FL
Posts: 14
QuoteOriginally posted by axl Quote
is it possible to update firmware while camera is in DEBUG mode?
Both of my K10s are permanently in this mode...
Yes, I just upgraded mine while in debug mode and the camera is still in debug mode currently after the successful upgrade.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, firmware, k10d, pentax news, pentax rumors
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shooting Raw with K7 improves noise? harleynitelite Troubleshooting and Beginner Help 2 03-08-2010 11:15 AM
New K7 Review finds firmware improves noise! harleynitelite Pentax DSLR Discussion 61 03-07-2010 07:13 AM
Canon 50D copies & improves on Pentax jms698 Non-Pentax Cameras: Canon, Nikon, etc. 48 09-01-2008 08:34 AM
No new K10D Firmware yet. maxamillion Pentax DSLR Discussion 40 02-09-2008 10:28 PM
K10D now at firmware 1.0.... slip Pentax DSLR Discussion 3 11-14-2006 02:58 PM



All times are GMT -7. The time now is 03:53 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top