Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-25-2015, 07:46 AM   #1
New Member




Join Date: Feb 2015
Posts: 3
GR closed lens on startup - dust?

This started happening recently with my GR - the lens is closed on startup until a blank photo is taken to get it to open up. Not a serious issue so far, more a pain as I have to point the camera at the sky or bright light otherwise it won't open quick enough.
Would this be a dust issue in the lens shutters area?

I've seen posts about cleaning the back of the camera by opening it up - any ideas how to clean the front of the camera around the lens area? maybe a can of compressed air? or vaccum cleaner on really low?

03-02-2015, 02:28 AM   #2
New Member
Romasato's Avatar

Join Date: Aug 2013
Location: London
Posts: 7
Ah - what a coincidence! My GR started having the same problem a week ago while travelling and I you beat me to posting about it here It was a quite cold night and my battery was running out - so I was turning the camera off and on again to save on the battery - and on some occassions it would just be dark screen, I thought might be the cold weather causing it... but it was not humid or anything.

So it is the same problem - looks like the diaphragm leafs do not move away on initial startup, but it is inconsistent - sometimes on startup it does open. So I get a dark screen (since sensor is covered and gets no light). It is inconsistent and when it happens the options are either a) taking a photo (so leafs are forced to move) or b) turning it off and on again (as they say in IT Crowd .

I've contacted the seller via Amazon and they've told me Ricoh GR provide 2 year manufacturer warranty. Luckily I bought it less than 2 years ago (Aug 2013), so will be calling the service centre for more details later today. Hopefully they can repair it quickly...

Here is the URL with more details: http://www.ricoh-imaging.co.uk/en/service-centre.html
03-03-2015, 05:40 AM   #3
New Member




Join Date: Feb 2015
Posts: 3
Original Poster
It's an odd one alright, as if you point the camera at a bright light it opens faster to make that first dud shot with the closed shutter, so not sure if that means dust or a mechanical issue. If they tell you what the issue was let me know!
The warranty seems to state it needed to be stamped by the original retailer which I can't get.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, digital camera, gr, gr closed lens, issue, lens, lens on startup, ricoh gr, startup
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
CC 2014 Error on startup Catscradle Digital Processing, Software, and Printing 3 07-26-2014 05:10 AM
Dust on GR Sensor? Options? geomez Ricoh GR 15 06-10-2014 06:15 PM
GR and dust. i83N Ricoh GR 23 01-16-2014 05:01 PM
Ricoh GR and dust on the sensor ghostdog Ricoh GR 3 11-16-2013 02:56 AM
dust on sensor or dust on lens 41ants Troubleshooting and Beginner Help 10 10-08-2009 10:28 AM



All times are GMT -7. The time now is 11:11 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top