Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-14-2020, 06:45 AM   #1
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
JPGs are read only after transfer

Greetings, I am a new GRiii user and love the camera so far.
One thing I noticed is that my pictures are read only when I transfer them to my laptop.
I do not use bluetooth for transfer ... I drag and drop the folder.
I can select the photos and change the permission but it's a PIA.
Any solution to this?

Thanks ....

06-14-2020, 08:26 AM   #2
Unregistered User
Guest




QuoteOriginally posted by eddiemack Quote
Greetings, I am a new GRiii user and love the camera so far.
One thing I noticed is that my pictures are read only when I transfer them to my laptop.
I do not use bluetooth for transfer ... I drag and drop the folder.
I can select the photos and change the permission but it's a PIA.
Any solution to this?

Thanks ....
Are you copying them to your computer's hard-disk, that is the c,d or e? If you copy them any to external drive they always have the read only attribute.
06-14-2020, 08:38 AM   #3
Senior Moderator
Loyal Site Supporter
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 17,931
I don't know if this would work, but try changing the attribute of the folder itself, before transferring.
My thought is that it may not apply the read only to future jpegs.
06-14-2020, 10:26 AM   #4
Site Supporter
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Hampstead, NC
Photos: Gallery
Posts: 14,123
Drag and drop will also drag and drop all permissions of the folder and files. If you can copy to the new location you should be OK.

06-14-2020, 01:53 PM   #5
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
QuoteOriginally posted by AfterPentax Quote
Are you copying them to your computer's hard-disk, that is the c,d or e? If you copy them any to external drive they always have the read only attribute.
Yes, I drag the folder from the camera to my desktop via the USB-C cable connection. Strange that would make the files read only as my fuji cameras don't do that.
Thanks for the reply... I just have to remember to select all the photos and change the properties after copy.
06-14-2020, 03:18 PM   #6
Unregistered User
Guest




QuoteOriginally posted by eddiemack Quote
Yes, I drag the folder from the camera to my desktop via the USB-C cable connection. Strange that would make the files read only as my fuji cameras don't do that.
Thanks for the reply... I just have to remember to select all the photos and change the properties after copy.
If you connect the camera to the computer, your camera is an external drive. Check if the attribute of the files is read only in the camera folder. It could also be a result of dragging and dropping the folder. In modern Windows the folder is always read only. Try to copy the individual files to your computer through drag and drop. But if the files themselves are already read only in the camera's folder than it is a setting specific for the GRIII. I always copy the individual files to the computer and never have this problem, I never copy the folder. Hope this helps.
06-15-2020, 12:03 AM   #7
Pentaxian




Join Date: Jun 2015
Location: Ontario, Canada
Photos: Albums
Posts: 781
I would also try formatting the card. Perhaps it is something in the original filesystem of the card that is messed up.

06-15-2020, 05:30 AM   #8
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
Thank you all for the suggestions.
I tried reformatting the SD card (in camera and on PC), tried a different SD card... also put the SD card in the computer and ensured its attributes are set to editable. Both folder and pictures still in read only mode when I query the permissions. If I copy the folder or individual photos over it doesn't matter... the permission is still read only.
The root of the problem seems to be that the GR writes out the files as read only so it stands to reason the transfer will be read only as well.
I wrote to Ricoh to see if there is any way I can change the way the camera writes the photo files... I can't change the folder or file permissions on the SD card. I can only change the permissions after transfer. That works for now but changes my work flow.
I'll update if I find a solution....
06-15-2020, 08:19 AM - 1 Like   #9
Site Supporter
Site Supporter
lsimpkins's Avatar

Join Date: Feb 2013
Location: SE Pennsylvania
Photos: Gallery | Albums
Posts: 418
I do not own a GRiii, but this issue piqued my curiosity. Is there a possibility that you have turned on "Protect All Images"? See page 97 of the on line GRiii manual (http://www.ricoh-imaging.co.jp/english/support/man-pdf/gr-3.pdf).
I suspect that this sets the file properties to read only to prevent unwanted file deletion.
06-16-2020, 04:10 AM   #10
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
QuoteOriginally posted by lsimpkins Quote
I do not own a GRiii, but this issue piqued my curiosity. Is there a possibility that you have turned on "Protect All Images"? See page 97 of the on line GRiii manual (http://www.ricoh-imaging.co.jp/english/support/man-pdf/gr-3.pdf).
I suspect that this sets the file properties to read only to prevent unwanted file deletion.
Thanks for the reply,
That function is to protect pictures already taken from being deleted.
It doesn't appear to change folder or picture permissions...
06-16-2020, 06:32 AM   #11
Site Supporter
Site Supporter
lsimpkins's Avatar

Join Date: Feb 2013
Location: SE Pennsylvania
Photos: Gallery | Albums
Posts: 418
QuoteOriginally posted by eddiemack Quote
Thanks for the reply,
That function is to protect pictures already taken from being deleted.
It doesn't appear to change folder or picture permissions...
The only file attribute that would keep a file from being deleted is the Read Only attribute. So, if the files are protected from deletion, that means that the RO attribute has been set. Hence when you import the files to a computer, you would not be able to edit them without changing the RO attribute back. Just sayin'.
06-16-2020, 10:29 AM   #12
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
QuoteOriginally posted by lsimpkins Quote
The only file attribute that would keep a file from being deleted is the Read Only attribute. So, if the files are protected from deletion, that means that the RO attribute has been set. Hence when you import the files to a computer, you would not be able to edit them without changing the RO attribute back. Just sayin'.
In order to protect the image you have to go to the menu and choose the file or files to protect via the menu option.
The photos have to exist on the camera in order to protect them. The protect option is not a system setting where you can tell the camera how to save an image, t is one you manually employ.
What I'm looking for is the system setting that is telling the GR to save as read only.
Thanks for the replies tho....
06-16-2020, 12:05 PM   #13
Site Supporter
Site Supporter
lsimpkins's Avatar

Join Date: Feb 2013
Location: SE Pennsylvania
Photos: Gallery | Albums
Posts: 418
One of the options is "Protect All". No individual selection of images is necessary (pg. 97 of the linked manual).
06-17-2020, 03:32 AM   #14
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
QuoteOriginally posted by lsimpkins Quote
One of the options is "Protect All". No individual selection of images is necessary (pg. 97 of the linked manual).
The protect option is not a system setting where you can tell the camera how to save an image
06-17-2020, 11:32 AM   #15
New Member
eddiemack's Avatar

Join Date: Jun 2020
Location: Northeast USA
Posts: 7
Original Poster
What I found to work after playing around today is, use the import pop up that appears when the camera is plugged into the laptop ....and import the files into the default picture folder. That folder and files in it are not read only.
I'm not used to using the import feature as I like to drag the folder off the camera and put it where I like. I'll just have to get used to the extra steps... either drag and drop, then select all and change properties, or import and move the folder.
Thanks for the input everyone... I appreciate the help.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
digital camera, ricoh gr, transfer
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not using wifi transfer (not good for hundreds of photos to transfer) Penview52 Pentax K-S1 & K-S2 36 10-17-2019 04:04 PM
Pentax K5 II JPgs Vivid noise Issue FabioPirovano Troubleshooting and Beginner Help 5 07-08-2019 05:25 PM
Photos becoming corrupts after transfer and view Zafar Iqbal Troubleshooting and Beginner Help 17 08-20-2016 02:28 PM
Are the DS JPGs too highly compressed? Ole Pentax DSLR and Camera Articles 5 09-03-2009 01:53 AM



All times are GMT -7. The time now is 07:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top