Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-01-2021, 11:37 AM   #121
New Member




Join Date: May 2015
Photos: Gallery
Posts: 23
Mine died a year ago, absolutely nothing worked . took the battery out and left the camera until about a week ago . used an A/C adapter and tried to light it up . to my surprise it works sort of . I can't open live or it doesn't come on by itself so no menu or preview etc. But i can use the view finder to focus and the shutter works in all functions I can see basic settings on the top screen. No flash either. In short I can take photos but no screen to preview adjust menu and flash. I can even use the 4way but can only see the basics in the top screen multi exposure ,remote etc. All I have to do now is get the live view working and flash most everything else appears to work.

04-01-2021, 12:42 PM   #122
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2008
Location: Central NY, USA
Posts: 765
QuoteOriginally posted by pentaxic Quote
In short I can take photos but no screen to preview adjust menu and flash.
Have you confirmed that a file is actually saved on the SD card? From my experience, it seems these cameras can hang if the CPU can't communicate correctly with one of the ancillary functions, rear LCD, GPS (on K-3 II), and likely the flash. Some other functions that don't use a serial bus still seem to operate correctly.
04-01-2021, 06:55 PM   #123
New Member




Join Date: May 2015
Photos: Gallery
Posts: 23
QuoteOriginally posted by reduno Quote
Have you confirmed that a file is actually saved on the SD card? From my experience, it seems these cameras can hang if the CPU can't communicate correctly with one of the ancillary functions, rear LCD, GPS (on K-3 II), and likely the flash. Some other functions that don't use a serial bus still seem to operate correctly.

that was my first indication that there was a pulse . When I turned it on I was hooked up to the A/C adapter & USB cord and could read the Flu Card which was the only one I had in there. I then put a card in port 1 and took a few pictures indoors . So has anybody got any ideas on how to bring back the live view etc. short of a taser and 19,000 volts to get its attention. Meanwhile I will use it through the Peep Hole and top LCD.
04-01-2021, 07:27 PM   #124
Loyal Site Supporter
Loyal Site Supporter




Join Date: Apr 2008
Location: Central NY, USA
Posts: 765
QuoteOriginally posted by pentaxic Quote
When I turned it on I was hooked up to the A/C adapter & USB cord and could read the Flu Card which was the only one I had in there.
That's good news if it can access the SD card. You indicated there was no display on the rear LCD screen. Does it look like the backlight on the LCD is turning on but the screen is black? You may need to be in a darker location to see the faint glow. When you activate live-view, does the mirror flip up as normal? Also, does the camera turn off straight away when the power switch is turned off, or does it seem to wait for the auto power off timer to expire? I certainly would not recommend zapping it with a high voltage discharge.

04-01-2021, 08:41 PM   #125
Loyal Site Supporter
Loyal Site Supporter
ivanvernon's Avatar

Join Date: Oct 2012
Location: Medina, OH
Photos: Albums
Posts: 5,713
K-3 failure to power on

K-3 failure to power on is a known weakness of this model, and much dicussed as to cause or cure. I had one myself. The usual cure is to drop it into the trash can or sell it for $75 for parts. Apparently Pentax replaced them for a while, but no more.
04-03-2021, 05:05 AM   #126
New Member




Join Date: May 2015
Photos: Gallery
Posts: 23
QuoteOriginally posted by reduno Quote
That's good news if it can access the SD card. You indicated there was no display on the rear LCD screen. Does it look like the backlight on the LCD is turning on but the screen is black? You may need to be in a darker location to see the faint glow. When you activate live-view, does the mirror flip up as normal? Also, does the camera turn off straight away when the power switch is turned off, or does it seem to wait for the auto power off timer to expire? I certainly would not recommend zapping it with a high voltage discharge.

The only visible thing it appears that does not work is the Live LCD & the internal Flash . Completely dark but the shutter is working up & down with the live view button , the ready light off & on with every thing (preview, live view etc.) the four way all functions that I can read in the top LCD are working except so far I can't read the flash settings. The mode wheel is working for what I can see in the top LCD. Rear focus is working . It turns off and on with the main even the grip aux buttons work. The hot shoe works with a AF360FGZ. When I try to change the flash settings the top LCD goes blank so I can't at this point anyway see what setting is on but the external is working at this point. The lens I have tried on it all work.

In a nut shell the back LCD does not work so no Menu Adj. Preview or any functions that rely on seeing the setting and the Internal flash not working but the hot shoe is. I can read both card slots through the USB harness and the battery , grip and A/C adapter all work. Any ideas on screen replacement or some other cheap repair . And Simpleton's Responses only please some of you techs on here give me a headache. My brain at 75 is very selective and violently rejects overload. Meanwhile I'll use it as is in TAv mode. I now can see in the top LCD the changes to the external flash using the 4 X .

Last edited by pentaxic; 04-03-2021 at 06:59 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cameras, customer, dslr, failure, friend, ii, k-3, k3, pentax, pentax k-3, phone, pm, power, repair, reports, ricoh, service, spread
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-3 II Dust Alert will not work Zafar Iqbal Troubleshooting and Beginner Help 6 08-27-2016 03:16 AM
Help! My Pentax K-01 Will Not Turn On CameraObscura Troubleshooting and Beginner Help 23 05-24-2015 05:24 PM
K5 will not power up kaju Troubleshooting and Beginner Help 8 04-12-2015 09:35 PM
K-3 will not autofocus AntonioD Troubleshooting and Beginner Help 21 04-05-2015 02:07 AM
Help K10D Will not Power on !!! daacon Pentax DSLR Discussion 31 12-11-2007 12:35 AM



All times are GMT -7. The time now is 08:49 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top