Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-01-2021, 04:45 PM   #1
New Member




Join Date: Mar 2021
Posts: 3
Sigma 50-500 4-6.3 APO DG won't work with K3

I have a Sigma 50-500 4-6.3 APO DG lens (the "Bigma") that worked beautifully with my K10D that won't work with my K3.

The lens mounts to the K3 as one would expect, feels/sounds perfect as it clicks into place, but it doesn't seem like the lens is communicating with the camera. I get nothing in the viewfinder except a flashing "F--" at the bottom, as if there's no information about the aperture (or anything else) coming from the lens.

I have no idea what's going on here. Any ideas? Thanks folks!

03-01-2021, 04:53 PM   #2
Site Supporter
Site Supporter




Join Date: Jun 2008
Location: Idaho
Photos: Gallery
Posts: 1,151
Make sure the lens aperture is clicked into the "Auto" position (A with a little jogged line) on the aperture ring. I have the same lens (older model) and use it with my K-1 with no issues, so it should work with the K3 unless it's something particular to the K3 or contact problems as you mentioned. If the aperture isn't in the auto mode, the lens will choose the aperture making it an aperture priority shot which might disagree with what the camera expects, hence the flashing F.
03-01-2021, 05:07 PM - 1 Like   #3
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,632
Flashing F means the camera cannot detect a lens. That is either because the lens is fully manual, is an "A" type lens but not in the "A" position or the contacts are dirty.

Verify that the lens is in the "A" position, if that does not help try cleaning the contacts on both lens and camera. Usually buffing with a microfiber cloth is enough, but alcohol can be used sparingly if absolutely needed.
03-01-2021, 05:08 PM   #4
Site Supporter
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Hampstead, NC
Photos: Gallery
Posts: 13,354
If that does not work clean the contacts of the lens and the camera (microfibre cloth with a drop of alcohol works well), there could be just a little dirt blocking a connection between the two. Hopefully that's all it needs.

Third party lenses are apparently reverse engineered, and sometimes even it though if it is too far one way on the specs you can have this happen. It's not too common though I have experienced it. I once bought a new Tamron lens that worked with one camera but not another, I had to send it to Tamron twice to get it adjusted, second time with the camera.

03-01-2021, 05:40 PM - 1 Like   #5
New Member




Join Date: Mar 2021
Posts: 3
Original Poster
Wow, thanks everyone...I will try the advice and report back!
03-01-2021, 07:50 PM   #6
New Member




Join Date: Mar 2021
Posts: 3
Original Poster
Thanks again everyone! I have no idea how the aperture ring got bumped off of auto, but that was the problem. I feel a bit dopey that I didn't figure that out on my own, but sometimes it takes a village!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
apo, apo dg, dg, dslr, k-3, k-3 iii, k10 d, k3, lens, pentax k-3, sigma, sigma 50-500 f4-6.3
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Sigma 500mm F4.5 APO EX DG, Sigma 1.4x EX DG TC, Sigma 2x EX DG TC MightyMike Sold Items 7 01-29-2021 08:11 AM
Sigma 170-500 APO f/5-6.3 DG or non-DG comparison Landscape_with_K1 Pentax SLR Lens Discussion 13 08-25-2019 05:01 AM
Sigma 50-500mm1:4-6.3 APO DG won't mount to my K3-II murviper Pentax K-3 & K-3 II 14 05-21-2016 04:53 PM
Sigma 170-500 apo dg vs apo non dg shimoyjk Pentax SLR Lens Discussion 2 12-26-2010 07:17 PM



All times are GMT -7. The time now is 10:06 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top